OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
xamindar doesn't have a personal statement currently.
Personal Info
38 years old
Gender Not Set
Born Jan-29-1982
ZAURUS!, Computers, Linux, Anime, Mountain Biking, Swimming.
Joined: 30-March 04
Profile Views: 12,569*
Last Seen: 1st August 2011 - 05:41 PM
Local Time: Apr 7 2020, 01:45 AM
803 posts (0 per day)
Contact Information
AIM Xamindar
Yahoo Xamindar
ICQ 17713745
MSN Xamindar
* Profile views updated each hour



My Content
13 Sep 2010
Well seeing the dvd catalyst post inspired me to post my video experience with my c3100. Here is my way of doing it which makes stable, smooth, clear enough movies just about every time.
I use handbrake which is free so no need to spend any money at all. Handbrake is best ripping from DVDs. I also use a mencoder script ro convert anything else that handbrake doesn't like. I attached my handbrake profile below which includes my zaurus encoding info.
This encodes with settings:
640x480 resolution
600kbps (2-pass) video
96kbps audio (faac)
default video framerate (doesn't change it)

packages needed to get this playing smoothly:
kino2_0.4.3c_arm.ipk or QuasarMediaPlayer_0.96_r193_r31-2010-03-28.ipk for a player
mplayer-bvdd-iwmmxt_1.1.5-1_arm.ipk which has hardware acceleration with bvdd
bvdd_0.4.0-1_arm.ipk for the kernel module
libffmpeg_0.4.6_20030304_arm.ipk for the video codec (I think, been a while)
You also need a kernel that allows overclocking the cpu. Tetsus or eviljazz should work. I am using eviljazz's.
qtopia-combbatteryapplet_1.0.6_arm.ipk to overclock from an applet easily

The best results I have had is to overclock to the (520/260/130 Mhz) setting. Anything higher and it is more choppy and can lock up and anything lower and the framerate drops.
Load up kino2 or quasar. I find quasar better for playback control but they both work fine either way.
Quasar: In the quasar configuration have all the boxes checked under "MPlayer" section, my cache is set to 512 KiB. Also add "-noslices -noaspect" to the addtional options. Noslices really speeds up framrate and makes it play smooth. You can set frame drop to normal or hard. Mine is set to hard right now but occasionally you will come across a video that will crash mplayer on hard, in that case just set it back to normal.
Kino2: In kino2 preferences on the general tab check "enable cache" and set it to 512, and add "-noslices" to the "options for mplayer" section. On the Video tab, only check "Drop frames", "Enable Doublebuffering", Disable aspect ratio correction", and "Enable audio autosync". And on the audio tab do not check "Resample audio", it will slow it down a little. Other options are up to you. Another nice thing about kino2 is that it can overclock automaticly for you when you play a video so you don't have to do it manually.

Now encode your video with handbrake, copy it to your Z, and play it with kino2 OR quasar. Remember to overclock or it wont play smooth. Surprising that overclocking makes such a big difference but it does. You might be able to increase the video bitrate a little. I got some videos to play smoothly on up to 1000kbps settings but not all. (I think I will try re-encoding Avatar to a higher than 600kbps setting as that movie looks more blocky than others). The bandwith of the SD slot seems just over 1mb/s and the CF slot is just a little higher than that so it limits the bitrate of the videos quite a bit. CF slot is probably better to use but all my movies play smooth from the SD slot at 600kbps.

White screen problem: With using the bvdd driver for video playback comes another issue. I found that after 5 minutes of playback my screen would go all white all of a sudden in a manner that looks like the zaurus locked up or crashed. I then had to hit cancel a bunch of times and turn off and on my Z until I got the screen back. At first I thought it was a bug in the driver or the overclocking was overheating the Z but that's not the case. It turns out when the screensaver kicks in it causes this. At least it is a simple and easy fix; disable the screensaver. Edit /home/zaurus/settings/qpe.conf and set to "Interval_AC_Screensaver = 0" to disable the screensaver on AC and "Interval = 0" to disable screensaver on battery. Problem solved.

Good luck! I still haven't found a phone/pda that can do what the Z still does today!
Attached thumbnail(s)
Attached Image

Attached File(s)
Attached File  Handbrake_My_Devices.zip ( 1.52K ) Number of downloads: 169
8 Sep 2010
I finally got fbvncserver working on my c3100. I had the package on my machine, but not installed, for years. I don't remember if I ever tried it or if it ever worked before. But it didn't work this time. After fiddling around I finally got it to work, for the most part. Here are my steps in case anyone else ever tries it and has the same issues.

Getting fbvncserver-c3000_0.9.4-0.2_arm.ipk working on the C3100

Install the package.
Then, as root:

1) "ln -sf /usr/local/bin/fbvncinput /etc/rc.d/init.d/fbvncinput"
because the link from the package is broken (note: if you start this service without rebooting you will be able to start a vnc server and connect to it but you will not be able to send input to the vnc server. Do not run it.)

2) edit all "vncserver_*" files under /usr/local/bin/ and remove the "-r0" from their vnc server launch commands (last line). That option causes vncserver to segfault for some reason. I suspect it is a screen rotation command (0 meaning no rotation) but I was unable to find any info on that command on the web.

3) reboot and then do the screen calibration by taping the very top left and then the very bottom right (including the quick icon area). If you check your running processes you should now have a "tssimd" service running and the kernel module "kbdsim" loaded. If not, then something is still not working.

4) launch the server utility and choose double or normal. I don't think the rotate one works and for me both choices launch a double size server. Oh well. But at least it works now on the c3100 and probably the c3200 as well.
15 Jul 2010
Lately I can not get Opera (7.30) to stay open on just about any web page. It will just randomly die on me. Sometimes while loading a page, and sometimes while I am scrolling a page. It is to the point it is unusable. I have also tried opera 7.25 and I think a 7.55 version but all have this crashing problem on my c3100.

Anyone have any idea what the issue is here? Are websites using something that causes it to crash? Is opera looking for something on my Zaurus that isn't there anymore?
7 Jun 2010
I am thinking about replacing my internal microdrive (again) with a compact flash card this time. Anyone know the maximum speed the zaurus can write on that interface? It might even be the same as the external interface in which case I can probably just test it myself before I reopen my Z. It would be pointless to install a card that can be written to at 40mb/s if the zaurus could only go at, for example, 4mb/s.

On a related note, ho can I test it? hdparm? What is the best way to test any cards actual speed?
21 Dec 2008
As anyone who uses the sharp rom knows, you can't connect to an essid that has a space in the name. I tried searching these forums but couldn't turn up any info on how to do it. Can the config file be modified to add a space? Is there some manual way to add it? I tried modifying the config with stuff like "ess id" and 'ess id' but no go.

Is there any way?
Last Visitors

29 Jan 2018 - 0:18

19 Jan 2015 - 22:25

8 Feb 2011 - 10:14

13 Jun 2010 - 6:00

12 Jun 2010 - 19:18

Other users have left no comments for xamindar.

There are no friends to display.
RSS Lo-Fi Version Time is now: 7th April 2020 - 12:45 AM