OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Qbedic Available For Pdaxrom
iamasmith
post Jan 7 2005, 02:58 AM
Post #1





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



Users of ZBedic that have migrated from the Sharp ROM and want the use of this great free Dictionary can now get it from the RC8 unstable feed.

Download dictionaries from the Home Page of the project http://www.sf.net/projects/bedic

- Andy
Go to the top of the page
 
+Quote Post
badog
post Feb 4 2005, 01:36 AM
Post #2





Group: Members
Posts: 248
Joined: 25-November 04
Member No.: 5,608



can't install in rc9
Go to the top of the page
 
+Quote Post
iamasmith
post Feb 4 2005, 05:44 AM
Post #3





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



Could you be more specific ?

Can you install from the command line ? Do you actually mean it installs but won't run ? Any messages that you get from the command line if you can install it ?

- Andy
Go to the top of the page
 
+Quote Post
Xumbi
post Feb 4 2005, 11:35 AM
Post #4





Group: Members
Posts: 178
Joined: 7-July 04
Member No.: 3,941



Hmmm, I couldn't install it either. Package manager complained that it couldn't find QBEDic_0.9.1_armv5tel.ipk, I think it's a letter case issue.

I downloaded the ipk and tried installing manually, it looked like it installed, but I can't run it from the command line, and I don't see anything for it in /usr/share/applications.
Go to the top of the page
 
+Quote Post
iamasmith
post Feb 4 2005, 12:51 PM
Post #5





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



Does the following command return anything ?

ipkg files qbedic
Go to the top of the page
 
+Quote Post
pgas
post Feb 5 2005, 12:34 AM
Post #6





Group: Members
Posts: 1,097
Joined: 17-December 03
From: Athens, Greece
Member No.: 1,210



ipkg and qpkg seems to have trouble because the name of the archive is qbedic_xxxx.ipk while in the control file the name is QBEDic.
Go to the top of the page
 
+Quote Post
iamasmith
post Feb 5 2005, 04:10 AM
Post #7





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



QUOTE(pgas @ Feb 5 2005, 08:34 AM)
ipkg and qpkg seems to have trouble because the name of the archive is qbedic_xxxx.ipk while in the control file the name is QBEDic.
*


OK, originally the file name was in upper case but the feed upload didn't seem to like that.

Let me change the control file, and re post it. I'll let you know when it's done.

OK, package updated please give it a try now.
Go to the top of the page
 
+Quote Post
Xumbi
post Feb 5 2005, 09:48 AM
Post #8





Group: Members
Posts: 178
Joined: 7-July 04
Member No.: 3,941



It works! I downloaded the English-German and Wikipedia (200MB!) files, and it works great.

Now if only I could find a font that would display the pronunciations correctly...
Go to the top of the page
 
+Quote Post
badog
post Feb 5 2005, 08:23 PM
Post #9





Group: Members
Posts: 248
Joined: 25-November 04
Member No.: 5,608



it needs libqpe.so.1
Go to the top of the page
 
+Quote Post
iamasmith
post Feb 6 2005, 06:00 AM
Post #10





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



QUOTE(badog @ Feb 6 2005, 04:23 AM)
it needs libqpe.so.1
*


Hmm, are you saying that this was previosly in RC8 but isn't in RC9 stock install ?.

This was built for RC8 - didn't have an issue with missing dependencies and should function on RC9.

Actually, curiousor and curiousor...... examining the direct depends on qbedic shows it is dependent on libqt-mt .... I know that but not libqpe. What are you seeing when you run it badog ? do you see libqpe if you ldd the file ?
Go to the top of the page
 
+Quote Post
badog
post Feb 6 2005, 06:46 AM
Post #11





Group: Members
Posts: 248
Joined: 25-November 04
Member No.: 5,608



i run pdaxrom rc9.

ipkg files zbedic0.9.3

run :zbedic~~ display ....libpqe.so.1....
Go to the top of the page
 
+Quote Post
iamasmith
post Feb 6 2005, 07:11 AM
Post #12





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



QUOTE(badog @ Feb 6 2005, 02:46 PM)
i run pdaxrom rc9.

ipkg files zbedic0.9.3

run :zbedic~~ display ....libpqe.so.1....
*


OK, looks like you have zbedic and not qbedic from the unstable PDAXROM feed. zbedic is built for Qtopia and would therefore need a Sharp ROM. qbedic is built for X using the QT framework (not the QPE framework associated with Qtopia).

Have a look at the unstable feed and get qbedic instead. I think that should sort things out.
Go to the top of the page
 
+Quote Post
badog
post Feb 7 2005, 05:46 PM
Post #13





Group: Members
Posts: 248
Joined: 25-November 04
Member No.: 5,608



thank you for help
it is wokeing now.smile.gif
Go to the top of the page
 
+Quote Post
ShiroiKuma
post Jan 5 2006, 03:05 AM
Post #14





Group: Members
Posts: 900
Joined: 22-May 04
Member No.: 3,385



QUOTE(iamasmith @ Jan 7 2005, 11:58 AM)
Users of ZBedic that have migrated from the Sharp ROM and want the use of this great free Dictionary can now get it from the RC8 unstable feed.
*

Reviving an old thread... Andy could you provide the source code for your Qbedic compilation. It doesn't work under KDE 3.5 in 1.1.0beta1, so I'd like to recompile it in order to make it useable.

We've had the same success with Portabase, which Zdevil recompiled and it works under KDE now.
Go to the top of the page
 
+Quote Post
pgas
post Jan 5 2006, 03:33 AM
Post #15





Group: Members
Posts: 1,097
Joined: 17-December 03
From: Athens, Greece
Member No.: 1,210



maybe qbedic-src:

http://sourceforge.net/project/showfiles.php?group_id=51673
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st November 2019 - 02:25 PM