OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> console scroll
dtruchan
post Mar 14 2004, 03:50 PM
Post #1





Group: Members
Posts: 89
Joined: 15-February 04
From: NJ
Member No.: 1,738



Is anyone else having a problem with scrolling after booting to runlevel 2 on CackoQT?

I only get the bottom line to scroll, the area under the picture.

I tried pdaXrom and I also have the problem, only the area under the picture scrolls. Although after quitting X, it works fine.

Using clear does clear the screen, but in both cases, the area where the picture was displayed is only repainted once and scrolling doesnt take place.
Go to the top of the page
 
+Quote Post
maslovsky
post Mar 15 2004, 07:11 AM
Post #2





Group: Members
Posts: 1,426
Joined: 22-October 03
Member No.: 89



What ROM version do you use?
Go to the top of the page
 
+Quote Post
albertr
post Mar 15 2004, 09:32 AM
Post #3





Group: Members
Posts: 535
Joined: 7-March 04
Member No.: 2,195



Are you talking about TUX logo? If so, I believe it's by design... Take a look at linux/drivers/video/fbcon.c. I have an SL-5500, and in my kernel to allow console to access all the screen I had to remove TUX logo completely from fbcon.c. There must be a better way to do it, but I'm just lazy.
-albertr
Go to the top of the page
 
+Quote Post
dtruchan
post Mar 15 2004, 06:56 PM
Post #4





Group: Members
Posts: 89
Joined: 15-February 04
From: NJ
Member No.: 1,738



In a not so very elegant way, I fix it.

After seeing this I got an idea.

I used consolescroll and updater.sh.c860 from here.

I pulled zImage and initrd.bin out of slc7x0-Qtopia-1438050304.zip and put them all on a CF and flashed it.
First thing I noticed was the Sharp image started to scroll away but the flash didn't work. Some spawn too fast error, I don't remember exactly.
Dejected, I flashed slc7x0-Qtopia-1438050304 and the sharp image again scrolled away. / then c at wait... and everything works now.

I don't know what consolescroll does, but it seems to have stuck past the flash. biggrin.gif



QUOTE
What ROM version do you use?  


It has happened to me using the following

original Sharp ROM
slc7x0-Qtopia-1033040304
slc7x0-Qtopia-1256240204
slc7x0-Qtopia-1438050304
pdaXrom-1.0.0

only at boot up by pressing a (or c) on the QT ROMs and just login to pdaXrom.
It looks like to me that the boot logo is displayed in all cases and don't go away until something... then it works.
But it looks like Sharp fixed it, I don't think my method was what they intended though. tongue.gif

QUOTE
Are you talking about TUX logo? If so, I believe it's by design


no, the Sharp logo on CackoQT and the ShirtPocket logo on pdaXrom.
Go to the top of the page
 
+Quote Post
maslovsky
post Mar 15 2004, 10:58 PM
Post #5





Group: Members
Posts: 1,426
Joined: 22-October 03
Member No.: 89



I thought it was only me, but I did the same before - I simply executed consolescroll binary and it fixed the scrolling! The strange thing is that it survices reflashing of ROMs...

I'll add the consollscroll binary to the downloads section.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 13th November 2019 - 10:55 AM