OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Debian amnesia ..., WIFI/Keyboard conf is not preserved
LinuxGuy
post Feb 28 2020, 01:01 PM
Post #1





Group: Members
Posts: 23
Joined: 2-January 20
Member No.: 862,679



blink.gif
Hi there

I am exploring "mouseless" my cosmo. I managed to configure my keyboard-layout at the console via : setxkbmap -model planetcosmo -layout de
Also I registered my wifi-password. Everything is lost after reboot - where can I edit these values permanently (with nano)?

Thanks foryour help.
Go to the top of the page
 
+Quote Post
Piece_Maker
post Feb 28 2020, 03:37 PM
Post #2





Group: Members
Posts: 19
Joined: 22-June 19
Member No.: 850,533



I can't even figure out how to access the symbol keys... The Fn key acts as a super in Debian so I can't use that to access any of the extra symbols on my number line or the ones on IOP/JKL keys!

Has anyone figured that part out yet?
Go to the top of the page
 
+Quote Post
ArchiMark
post Feb 28 2020, 06:51 PM
Post #3





Group: Admin
Posts: 1,747
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



QUOTE(Piece_Maker @ Feb 28 2020, 03:37 PM) *
I can't even figure out how to access the symbol keys... The Fn key acts as a super in Debian so I can't use that to access any of the extra symbols on my number line or the ones on IOP/JKL keys!

Has anyone figured that part out yet?



Did you read the 'Tips' section within the Debian/KDE section on the PC Linux on Cosmo page?

Mark
Go to the top of the page
 
+Quote Post
szopin
post Feb 29 2020, 02:46 AM
Post #4





Group: Members
Posts: 58
Joined: 24-February 19
Member No.: 842,637



QUOTE(LinuxGuy @ Feb 28 2020, 10:01 PM) *
blink.gif
Hi there

I am exploring "mouseless" my cosmo. I managed to configure my keyboard-layout at the console via : setxkbmap -model planetcosmo -layout de
Also I registered my wifi-password. Everything is lost after reboot - where can I edit these values permanently (with nano)?

Thanks foryour help.

Wifi settings are not lost, it's just by default saved for a given mac which gets randomized on each reboot, in NetworkManager settings for the connection manually clear the field 'Restrict to device' and it should automatically connect after reboot
Go to the top of the page
 
+Quote Post
LinuxGuy
post Feb 29 2020, 10:42 AM
Post #5





Group: Members
Posts: 23
Joined: 2-January 20
Member No.: 862,679



Hello Szopin

QUOTE(szopin @ Feb 29 2020, 02:46 AM) *
Wifi settings are not lost, it's just by default saved for a given mac which gets randomized on each reboot, in NetworkManager settings for the connection manually clear the field 'Restrict to device' and it should automatically connect after reboot


Thanks a lot - works.

Also, if someone would like to get rid of the Kwallet -> installl kwalletmanager -> then you will have a new item in your system preferences about the user account -> there you can deactivate KWallet (and then uninstall kwalletmanager :-) )

Concerning the non-english keyboard layout:

sudo nano /etc/X11/xorg.conf

paste inside (for a german-de cosmo):
Section "InputClass"
Identifier "keyboard"
MatchIsKeyboard "yes"
Option "XkbLayout" "de"
Option "XkbVariant" "planetcosmo"
EndSection

reboot

smile
Go to the top of the page
 
+Quote Post
Piece_Maker
post Mar 1 2020, 09:55 AM
Post #6





Group: Members
Posts: 19
Joined: 22-June 19
Member No.: 850,533



QUOTE(ArchiMark @ Feb 29 2020, 02:51 AM) *
QUOTE(Piece_Maker @ Feb 28 2020, 03:37 PM) *
I can't even figure out how to access the symbol keys... The Fn key acts as a super in Debian so I can't use that to access any of the extra symbols on my number line or the ones on IOP/JKL keys!

Has anyone figured that part out yet?



Did you read the 'Tips' section within the Debian/KDE section on the PC Linux on Cosmo page?

Mark


I did read it, but switching it to gb keyboard didn't seem to help, until I removed the 'US' keyboard layout from my options and just set it to GB only. Now it all seems to work.

The WiFi passphrase loss on reboot above worked for me too!

Now just to get bluetooth and 4G working... hmmm...
Go to the top of the page
 
+Quote Post
lokomoko
post Mar 2 2020, 03:42 PM
Post #7





Group: Members
Posts: 11
Joined: 21-February 20
Member No.: 866,005



QUOTE(LinuxGuy @ Feb 29 2020, 07:42 PM) *
sudo nano /etc/X11/xorg.conf

paste inside (for a german-de cosmo):
Section "InputClass"
Identifier "keyboard"
MatchIsKeyboard "yes"
Option "XkbLayout" "de"invoking it from /etc/X11/Xsession
Option "XkbVariant" "planetcosmo"
EndSection


Thanks for this hint. Works perfectly for user cosmo. For another user I usually login as, it did not work I added that user to all groups cosmo belongs to, but without success. Any ideas?

The
CODE
setxkbmap -model planetcosmo -layout de

works just fine session-wide for any user's session when issued in a console. I was't successful invoking it from any kind of skript at startup. Neither invoking it from /etc/X11/Xsession.d/ nor putting it into a desktop-file in /etc/skel/.config/autostart/ really seemed to work.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 11th July 2020 - 11:30 AM