OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

6 Pages V   1 2 3 > »   
Reply to this topicStart new topic
> Debian on Gemini - Usage
ArchiMark
post May 8 2018, 08:59 AM
Post #1





Group: Admin
Posts: 1,598
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Managed to get Debian running on Gemini!

Working, but runs a bit slow.....

Have a few issues/questions....thought it would be good to start a thread for such things....

1. Mouse

I plugged my tiny little Targus mini-mouse into Gemini usb hub but it was not recognized.

Has anyone used a mouse successfully? If so, did you plug into the hub or ?


2. Window Manager

Any pros/cons for using KWin vs Xfwm4?

Also, in the window that allows you to choose, it listed KWin twin, but since window is so small, you can't read all the text description. Is this just a duplicate entry or are there 2 different versions?


3. Wireless Network

Used ConnMan to connect to the guest network at work. However, the guest network requires that you login via a webpage. For some unknown reason, I get an error message in browsers when I try to connect to that page.

I have no problem connecting to the login page when using Android on Gemini.

Any suggestions?


Thanks for any help.

Mark
Go to the top of the page
 
+Quote Post
Adam Boardman
post May 9 2018, 03:14 AM
Post #2





Group: Members
Posts: 113
Joined: 29-December 17
Member No.: 815,489



Slow:
Well yesterday evening TheKit put a patch in that got gtkperf to go from 214s -> 65s, so a 3x performance improvement. Just an apt-get update & upgrade away.

Mouse:
I found the connectivity kit hub to have an audible electronic hum so hadn't tried it much, but I just tried it now and it does seem to dislike mice in both Android and Linux. I've been using a mouse happily with a more pocket-able USB Converter.

WM:
I picked KWin, never tried the other.

Wireless:
The code within cmst (the Connman UI) has a second tab for its wifi-password entry to supposedly attempt to handle those kind of guest networks. Could you try with a regular Debian 9 install on a x86 laptop to identify if the problem is a generic one with stretch or with our changes?
Go to the top of the page
 
+Quote Post
ArchiMark
post May 9 2018, 06:16 AM
Post #3





Group: Admin
Posts: 1,598
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



QUOTE(Adam Boardman @ May 9 2018, 04:14 AM) *
Slow:
Well yesterday evening TheKit put a patch in that got gtkperf to go from 214s -> 65s, so a 3x performance improvement. Just an apt-get update & upgrade away.


Sounds good, will do upgrade....



QUOTE
Mouse:
I found the connectivity kit hub to have an audible electronic hum so hadn't tried it much, but I just tried it now and it does seem to dislike mice in both Android and Linux. I've been using a mouse happily with a more pocket-able USB Converter.



Sounds good, will get an adaptor....although seems odd that we can't use the hub...


QUOTE
WM:
I picked KWin, never tried the other.


Did you see KWin listed twice in the list to choose from?


QUOTE
Wireless:
The code within cmst (the Connman UI) has a second tab for its wifi-password entry to supposedly attempt to handle those kind of guest networks. Could you try with a regular Debian 9 install on a x86 laptop to identify if the problem is a generic one with stretch or with our changes?


This login page does not have a password to enter....it requires that you click on a tiny checkbox and then click on a button that says 'Login'.

Used the second tab, selected network, then chromium as browser. It opened up chromium, but get error message:

QUOTE
This site can't be reached

Shows URL and says 'is unreachable' at end of URL

ERR_ADDRESS_UNREACHABLE


I do not have this problem with my x86 laptop that dual boots Win10 and LinuxMint.


Thank you for all your help, Adam!
Go to the top of the page
 
+Quote Post
Adam Boardman
post May 9 2018, 08:19 AM
Post #4





Group: Members
Posts: 113
Joined: 29-December 17
Member No.: 815,489



Yes there was two KWins, no idea why.

LinuxMint has probably a bunch of newer versions of various packages, so my request still stands that I would like you to try out an x86 Debian 9 to isolate the problem to whether its in something we've changed or just that the older versions of things in D9 just don't support your kind of guest network.
Go to the top of the page
 
+Quote Post
ArchiMark
post May 9 2018, 09:03 AM
Post #5





Group: Admin
Posts: 1,598
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



QUOTE(Adam Boardman @ May 9 2018, 09:19 AM) *
Yes there was two KWins, no idea why.

LinuxMint has probably a bunch of newer versions of various packages, so my request still stands that I would like you to try out an x86 Debian 9 to isolate the problem to whether its in something we've changed or just that the older versions of things in D9 just don't support your kind of guest network.



OK, will try to get Debian 9 install setup...
Go to the top of the page
 
+Quote Post
ArchiMark
post May 9 2018, 01:06 PM
Post #6





Group: Admin
Posts: 1,598
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



OK, was able to get Debian 9 running on my lil' Lenovo Flex 10 laptop.....

Selected the guest network and opened Firefox and it already had a button near top of window that says 'login page'. Clicked it and Voila! it connected to the login page and worked when I logged in....

So, there's something funky with the Debian/ConnMan setup on the Gemini I assume.....

Meanwhile, when I get home from work, I should be able to do the apt-get upgrade there.

Let me know if you have any other suggestions regarding being able to connect the guest network at my office.

Thanks!

This post has been edited by ArchiMark: May 9 2018, 02:06 PM
Reason for edit: Clarification
Go to the top of the page
 
+Quote Post
ArchiMark
post May 9 2018, 08:20 PM
Post #7





Group: Admin
Posts: 1,598
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Playing with Debian on Gemini this evening at home...

Good news is that it connects easily to my home WiFi network. Selected my home network from list in ConnMan, clicked 'Connect' and then it popped open a window asking me to enter my network password.

Also, bought a nice little sleek MacAlly USB to USB-C adapter. Mouse works well now.

Meanwhile, a new issue....

I wanted to do 'apt-get upgrade', but I can't type some of the characters I need such as ' - '.

4. Keyboard Layout

How do you type the characters that are printed on the front edge of the keyboard keys?

I went into Preferences > LXQt Settings > Keyboard and Mouse > Keyboard Layout and it shows 'US Keyboard', which is good since I am in USA.

Underneath this is 'Keyboard model' and next to it is a pop-down menu with a long list of models to choose. It was set to 'Generic 101-key PC'. Is this OK or is there a better one to use?

Or is there something else I need to do to get the right keyboard layout?

Would help if there was an on-screen keyboard to use for now to get access to needed characters.....


5. Terminal

Which terminal is best to use?

UXterm gives error message in the terminal window when opened.

Xterm opens OK, but text is microscopic in size, have to use a magnifying lens to read text in window....can one enlarge size of text?


Thanks for any and all help.

Mark
Reason for edit: Added note about mouse working
Go to the top of the page
 
+Quote Post
Adam Boardman
post May 10 2018, 01:22 AM
Post #8





Group: Members
Posts: 113
Joined: 29-December 17
Member No.: 815,489



You need to update all the packages the keyboard layouts were done after the first image. DebianTP has lots of helpful stuff to do with getting things updated to the latest state. QTerminal supports zoom levels but you need to fix the shell before its usable.
Go to the top of the page
 
+Quote Post
ArchiMark
post May 10 2018, 05:04 AM
Post #9





Group: Admin
Posts: 1,598
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



THANK YOU for the input and link, Adam!

Took a quick look at that page and it does have lots of good info. Wish I'd known about it earlier....

So, will work my way through the various things mentioned there in order to get my setup correct.

And then will try to connect to the guest network at work again to see if it will connect....
Go to the top of the page
 
+Quote Post
ArchiMark
post May 14 2018, 06:34 AM
Post #10





Group: Admin
Posts: 1,598
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



At home, last evening I did some of the items on DebianTP page....WiFi connection works well at home.

SSH'd into the Gemini and did the following items (showing the Heading from the DebianTP page):

Set a shell so that the device is usable

More disk space

Locales


A. Shared Internet Connection

Now I would like to use apt-get to more updates.

However, I'm at work now and I still cannot connect to guest network from Gemini. However, I can connect to guest network from GPD Pocket running LinuxMint.

Is it possible to piggyback off of the WiFi connection on GPD Pocket to access internet?

I'm connected Gemini to Pocket with the usb cable to use ssh.


UPDATE: Figured out how to setup Pocket as 'Hotspot'. However, won't work at work on guest network. Got error message that this connection cannot be shared. Oh well....will continue update process when I get home this evening....



B. Keyboard Mapping


Not clear about getting keyboard mapping working properly.

Will doing apt-get upgrades will get mapping working properly or do I need to update the kernel or ?


Thank you for help.

Mark

This post has been edited by ArchiMark: May 14 2018, 09:30 AM
Reason for edit: Added update regarding shared internet connection
Go to the top of the page
 
+Quote Post
depscribe
post May 14 2018, 11:10 AM
Post #11





Group: Members
Posts: 241
Joined: 3-January 18
Member No.: 815,753



QUOTE(ArchiMark @ May 14 2018, 06:34 AM) *
Will doing apt-get upgrades will get mapping working properly or do I need to update the kernel or ?

As the wiki notes (it is easy to miss stuff; I did and made a mess), for the new keyboard mapping to work a hacked kernel is necessary:

Update the kernel

NOTE[HAZARD WARNING]: If you've used the Gemini Partition Tool to swap your primary boot to linux then its its no longer possible to update your kernel in this way. You'll have to go back to the flashing tool.

Gemian now includes a branch of xkb with some initial keyboard maps, these need a newer kernel, this can be done on device without going back to the flashing system:

CODE
wget https://gemian.thinkglobally.org/linux-boot-2018-03-26-H4.img
sudo dd if=linux-boot-2018-03-26-H4.img of=/dev/disk/by-partlabel/linux_boot

You can check your kernel version with a:

uname -a
After the update it should show:

Linux localhost 3.18.41+ #4 SMP PREEMPT Wed Mar 26 22:43:05 MSK 2018 aarch64 GNU/Linux
Probably best to check your version before updating it, the date stamp is the most reliable way of knowing what is newer, the build numbers randomly reset.

[eoq]

Unless you used the partitioning tool -- did you? It askes which operating system you want as the default and how you want to divide the available space -- that should worj just fine, no reflash needed.
Go to the top of the page
 
+Quote Post
ArchiMark
post May 14 2018, 01:18 PM
Post #12





Group: Admin
Posts: 1,598
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



QUOTE(depscribe @ May 14 2018, 12:10 PM) *
QUOTE(ArchiMark @ May 14 2018, 06:34 AM) *
Will doing apt-get upgrades will get mapping working properly or do I need to update the kernel or ?


As the wiki notes (it is easy to miss stuff; I did and made a mess), for the new keyboard mapping to work a hacked kernel is necessary:

Update the kernel

NOTE[HAZARD WARNING]: If you've used the Gemini Partition Tool to swap your primary boot to linux then its its no longer possible to update your kernel in this way. You'll have to go back to the flashing tool.

Gemian now includes a branch of xkb with some initial keyboard maps, these need a newer kernel, this can be done on device without going back to the flashing system:

CODE
wget https://gemian.thinkglobally.org/linux-boot-2018-03-26-H4.img
sudo dd if=linux-boot-2018-03-26-H4.img of=/dev/disk/by-partlabel/linux_boot

You can check your kernel version with a:

uname -a
After the update it should show:

Linux localhost 3.18.41+ #4 SMP PREEMPT Wed Mar 26 22:43:05 MSK 2018 aarch64 GNU/Linux
Probably best to check your version before updating it, the date stamp is the most reliable way of knowing what is newer, the build numbers randomly reset.

[eoq]

Unless you used the partitioning tool -- did you? It askes which operating system you want as the default and how you want to divide the available space -- that should worj just fine, no reflash needed.


THANK YOU, dep, for your input!

Yes, read page and trying to follow it carefully....but wasn't completely sure if you did need to update the kernel to get keyboard mapping set correctly....

Will do kernel update this evening at home...

I did not use the partitioning tool....I did the resize command as noted on the GemianTP page.

Hope to have a usable Debian setup on Gemini soon....

Mark
Go to the top of the page
 
+Quote Post
ArchiMark
post May 14 2018, 07:39 PM
Post #13





Group: Admin
Posts: 1,598
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



OK, did the system upgrades with apt-get and the kernel update per GemianTP page.

Checked kernel version to make sure it matched info on GemianTP page.

Tried typing, but could not get the characters on front edge of keys to type.

I rebooted Gemini and still can't type the characters on front edge of keys with pressing Fn key too.

I checked LXQt settings, ‘keyboard and mouse’. There keyboard is shown as ‘English (US) and keyboard layout as ‘generic 101-key PC’. There is a message about these settings may be ignored if system uses some other controls. So, don’t know if this Debian setup ignores preferences shown.

I have US keyboard on my Gemini.

Is there some other configuration step I need to do that is not described on GemianTP page???

Thanks for any help.

Mark

This post has been edited by ArchiMark: May 14 2018, 09:18 PM
Reason for edit: Added additional info
Go to the top of the page
 
+Quote Post
Adam Boardman
post May 14 2018, 11:30 PM
Post #14





Group: Members
Posts: 113
Joined: 29-December 17
Member No.: 815,489



Sorry should probably mention it on the page. Once you've done the updates the sddm (the login screen) has in its top edge a dropdown so you can pick the keyboard layout. This will (should) set the keyboard for the session.

The only trouble is if you've also manually set a session keyboard within the LXQt settings this will probably override it. In that case you need to pick your layout and then select 'Planet Computers Gemini' for the 'Keyboard model'. Also if your keyboard layout has two sets of letters printed the keyboard will be auto-configured to use left+right shift to swap the letters in use, this may conflict with other multi-layout settings you can pick from the UI.

The idea was to have the keyboard types auto detect based upon plugging so that the internal one will automatically be selected as a Gemini and an external one as pc104 etc, and the layouts work as expected. Any lxqt settings set break this. I'm not entirely convinced its working right just yet either I've not tested it recently, it was working once upon a time. If someone wants to try testing it then edit files in .config to remove any keyboard settings first, then select from the login screen.

The kernel update enables things like Sleep on Close, Bluetooth, the use of the ESC key as fn+esc to 'sleep (off)'. All the rest of the keys are the same without the kernel update. (the updated shortcuts may also require a reset of your .config/lxqt/globalkeyshortcuts.conf)
Go to the top of the page
 
+Quote Post
ArchiMark
post May 15 2018, 05:01 AM
Post #15





Group: Admin
Posts: 1,598
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



THANKS, Adam, for your help....that did it...

I logged out, then selected keyboard on login screen. Then logged in and went to LXQt preferences, Keyboard and Mouse. Then in Keyboard, I selected 'English (US)' and clicked 'Remove' button and closed window.

Tried typing characters on front edge of keys and it finally worked !!!

Now have a working Gemini with Debian.....

tongue.gif

Mark
Go to the top of the page
 
+Quote Post

6 Pages V   1 2 3 > » 
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th December 2018 - 01:25 PM