OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Keymap weirdness?
NormMonkey
post Nov 29 2019, 12:41 PM
Post #1





Group: Members
Posts: 41
Joined: 22-November 19
Member No.: 860,015



Hi all, I connected my bluetooth keyboard - I know, I know, half the reason for having a Cosmo is the fantastic keyboard, but I have this one Lenovo BT keyboard with the TrackPoint nipple thing that I love and when I'm sitting at my desk I use the one keyboard for everything: PC, laptop, phone ... it has the bluetooth multi-connect thing. Anyways, on the Cosmo, the single and doublequote and the twiddle and backtick keys make slashes and pipes. I haven't figured out how to do quotes via BT keyboard. I haven't tried plugging in a USB keyboard to see if it has the same issue. Anyone else seeing the same thing?
Go to the top of the page
 
+Quote Post
Daniel W
post Dec 7 2019, 08:08 AM
Post #2





Group: Members
Posts: 145
Joined: 22-May 18
From: Sweden
Member No.: 823,019



QUOTE(NormMonkey @ Nov 29 2019, 09:41 PM) *
Hi all, I connected my bluetooth keyboard - I know, I know, half the reason for having a Cosmo is the fantastic keyboard, but I have this one Lenovo BT keyboard with the TrackPoint nipple thing that I love and when I'm sitting at my desk I use the one keyboard for everything: PC, laptop, phone ... it has the bluetooth multi-connect thing. Anyways, on the Cosmo, the single and doublequote and the twiddle and backtick keys make slashes and pipes. I haven't figured out how to do quotes via BT keyboard. I haven't tried plugging in a USB keyboard to see if it has the same issue. Anyone else seeing the same thing?

While I haven't tried with my Gemini (yet anyway), I have connected a Lenovo KT-1255 Bluetooth keyboard to my other Android phone, and I also got some symbols wrong, even though the physical keyboard layout matches the locale set on my phone (Sweden, in my case). I think the reason is that the Lenovo keyboard is tuned to work with Windows, which seems to associate some scan codes (or similar) to other symbols than Android. I solved my problem by using External Keyboard Helper Pro from the Play Store. There's a free Demo version and a ($2 or so) paid version. Beyond checking to see that "ok, this seems to work", I haven't really USED that keyboard much with the phone (first, I got a smaller BT keyboard, for which Keyboard Helper did the trick, and then I got the Gemini) so I can't say if it works WELL. I seem to recall that my Lenovo keyboard was a bit finicky to pair, as it has no pairing button, but rather seems to automatically go to paring mode when unpaired from the last device it was paired to, which, for me, made it too much of a hassle to move between devices, so nowadays it mostly collects dust, on its way to oblivion, I'm afraid.
Go to the top of the page
 
+Quote Post
NormMonkey
post Dec 9 2019, 06:28 AM
Post #3





Group: Members
Posts: 41
Joined: 22-November 19
Member No.: 860,015



QUOTE(Daniel W @ Dec 7 2019, 11:08 AM) *
While I haven't tried with my Gemini (yet anyway), I have connected a Lenovo KT-1255 Bluetooth keyboard to my other Android phone, and I also got some symbols wrong, even though the physical keyboard layout matches the locale set on my phone (Sweden, in my case).


Mine's a Lenovo KT-1525 which is essentially the same as the 1255 except it can pair to 3 BT devices. I love the Lenovo TrackPoint, I have never met its equal on any other keyboard (mostly because hardly any keyboards have them which I think is a shame smile.gif


I ended up sorting this out pretty easily, in the end:
Settings : Languages & input : Keyboard & inputs, you should find two:

* Virtual keyboard
* Physical keyboard
Choose Physical keyboard. When the BT keyboard is connected you should see both:
* Integrated keyboard
* Thinkpad keyboard (or whatever your device shows up as)
Choose your device, and you should find it is set to your language and "Gemini keyboard". Change "Gemini keyboard" to "Android Keyboard" and that does the trick.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 12th December 2019 - 04:36 PM