OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Alt+Tab turning on Caps Lock, Has anyone else experienced this?
adfh
post Dec 20 2019, 09:14 PM
Post #1





Group: Members
Posts: 16
Joined: 11-December 19
From: I come from a land down under
Member No.: 861,112



I use Alt+Tab to quickly switch between applications. It works on the Cosmo, but from time to time, the first press will toggle Caps Lock (which should be Fn+Tab) instead. Subsequent presses will perform Alt+Tab without issue.

When the phone is feeling like doing this, if you Fn+Tab to turn caps lock off, Alt+Tab will turn it back on again (wheeee!).. Bug in the keyboard matrix scanning?
Go to the top of the page
 
+Quote Post
shuntcap
post Dec 21 2019, 07:01 PM
Post #2





Group: Members
Posts: 29
Joined: 10-January 10
From: Roseboom, NY, USA
Member No.: 59,214



QUOTE(adfh @ Dec 21 2019, 12:14 AM) *
I use Alt+Tab to quickly switch between applications. It works on the Cosmo, but from time to time, the first press will toggle Caps Lock (which should be Fn+Tab) instead. Subsequent presses will perform Alt+Tab without issue.

When the phone is feeling like doing this, if you Fn+Tab to turn caps lock off, Alt+Tab will turn it back on again (wheeee!).. Bug in the keyboard matrix scanning?

Other users have noted the same issue on the Cosmo, which is odd because the Gemini has it, too. You'd think it would have been fixed by now.

The Gemini had a keyboard ghosting issue. For example, if you press and hold left Shify then press and hold 9, then press and hold 0, you don't get (), you get (0). There's a kernel fix available from the community, but I'm very curious as to whether or not the Cosmo has the same hardware issue. Due to all the QC complaints I've seen, mine still sits unopened. But yes, the Alt-Tab Caps Lock LED issue drove me nuts on the Gemini and I'm disappointed to hear that it's still in the Cosmo.
Go to the top of the page
 
+Quote Post
NormMonkey
post Dec 28 2019, 07:21 AM
Post #3





Group: Members
Posts: 74
Joined: 22-November 19
Member No.: 860,015



Try this:
  • Push Fn and release
  • now push Tab
If Fn is used as part of some other key combo like Fn+A, the flag still remains set and so pressing Tab results in CapsLock instead.

So if you ever find that using Tab has caused a CapsLock instead of a Tab, press and release Fn and then press Tab to clear it and continue on.
Go to the top of the page
 
+Quote Post
gidds
post Jan 2 2020, 10:34 AM
Post #4





Group: Members
Posts: 291
Joined: 13-January 18
From: UK
Member No.: 816,386



Yes, this is a long-standing minor annoyance for me too.

I've got into the habit of tapping the left Shift key briefly before using Alt+Tab if I haven't used it for a while.  That usually seems to prevent the problem, in a similar way to your suggestion.

If that fails, I press Fn+Tab to disengage Caps Lock, then continue as above.

I agree that these keyboard glitches are disappointing… key rollover was a solved problem 40 years ago!
Go to the top of the page
 
+Quote Post
LinuxGuy
post Jan 5 2020, 03:11 AM
Post #5





Group: Members
Posts: 8
Joined: 2-January 20
Member No.: 862,679



Hi Adfh

QUOTE(adfh @ Dec 20 2019, 09:14 PM) *
I use Alt+Tab to quickly switch between applications. It works on the Cosmo, but from time to time, the first press will toggle Caps Lock (which should be Fn+Tab) instead.

I got the same problem, it turns caps lock on allmost everytime. It really annoying! I filed a bug-report on the PC support site.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th January 2020 - 01:40 PM