OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Gemini won’t charge, Battery
Paul H
post Jan 30 2020, 12:16 PM
Post #1





Group: Members
Posts: 16
Joined: 17-June 18
Member No.: 824,644



My Gemini won’t take a charge. The red light comes on when plugged in but it will not charge. The red light is on but. Won’t charge or turn on even with it plugged in.

Does anyone know where I can get a replacement battery?

Thx
Go to the top of the page
 
+Quote Post
jdcard
post Jan 30 2020, 01:52 PM
Post #2





Group: Members
Posts: 10
Joined: 6-June 18
Member No.: 823,975



E-mail to "Customer Care (Support)" <hello@planetcom.co.uk> is how I ordered mine. They will send you a PayPal invoice ($79.00) and once you've paid they promise to ship the replacement battery. I ordered mine on 2019-11-29 and received e-mail today saying "We are sorry for the delays with this. We've been very low on battery stock, but we have a few spares now. We will ship you one this week for sure. It will be traceable upon request early next week."
Go to the top of the page
 
+Quote Post
Paul H
post Jan 31 2020, 04:11 AM
Post #3





Group: Members
Posts: 16
Joined: 17-June 18
Member No.: 824,644



Thanks. I will go that route.
Go to the top of the page
 
+Quote Post
rasva
post Jan 31 2020, 09:23 AM
Post #4





Group: Members
Posts: 56
Joined: 12-October 07
From: Czech republic
Member No.: 20,815



Are you sure that the battery is dead? It could be only deeply discharged, it could also be some other problem. If it is deeply discharged then usually keeping it plugged in for few hours will resolve it.
Go to the top of the page
 
+Quote Post
mithrandir
post Feb 1 2020, 04:52 AM
Post #5





Group: Members
Posts: 170
Joined: 7-January 18
Member No.: 815,997



QUOTE(rasva @ Jan 31 2020, 09:23 AM) *
Are you sure that the battery is dead? It could be only deeply discharged, it could also be some other problem. If it is deeply discharged then usually keeping it plugged in for few hours will resolve it.

Not accepting any charge in case of a bad battery also sounds not very probable for me. In most cases one notices capacity loss first, and it is not that old, yet. I also have noticed some (rare, have not seen this for a long time) times the Gemini not charging despite of being plugged in. I would try anything else first. Replugging many times, rebooting, deleting cache (if on Android), etc. ..., before ordering a new battery.

Battery voltage might be below the charging circuits lower limit. Are you capable of measuring the battery voltage at the battery terminals?

Btw. are you using the original charger? I have noticed with a Samsung tablet, that it won't start charging with my 3rd party charger when it is completely empty. With the original one then it worked.
Go to the top of the page
 
+Quote Post
Paul H
post Feb 3 2020, 07:23 AM
Post #6





Group: Members
Posts: 16
Joined: 17-June 18
Member No.: 824,644



I have not used the Gemini that much over the past few months and let the battery sit uncharged. Once I did hear it try to turn on while plugged in but it didn’t. I can’t even get it to turn on while plugged in. I can try a different charger and see if that helps. I did have another charger from Planet Computers but that didn’t make a difference. The weird thing is I reached out to support a week ago and have not heard back.
Go to the top of the page
 
+Quote Post
Eldkatten
post Feb 4 2020, 07:15 AM
Post #7





Group: Members
Posts: 98
Joined: 5-June 18
Member No.: 823,876



Hello,

just to hint to a common mistake: only the left side USB-port can be used for charging.
Go to the top of the page
 
+Quote Post
rasva
post Feb 4 2020, 08:35 AM
Post #8





Group: Members
Posts: 56
Joined: 12-October 07
From: Czech republic
Member No.: 20,815



QUOTE(Paul H @ Feb 3 2020, 04:23 PM) *
I have not used the Gemini that much over the past few months and let the battery sit uncharged. Once I did hear it try to turn on while plugged in but it didn’t. I can’t even get it to turn on while plugged in. I can try a different charger and see if that helps. I did have another charger from Planet Computers but that didn’t make a difference. The weird thing is I reached out to support a week ago and have not heard back.


Try what I wrote above. If the battery is deeply discharged then the phone (any phone using li-ion battery) will not turn ON even when plugged in. Just keep the Gemini on the charger (left USB), for many hours. Most likely it will come to life. Also a good thing here would be an "USB doctor", it will tell you if the USB device is actually consuming any power from USB.

Quick usb charger will not make any difference here.

As a last resort if above does not help is to remove battery and charge it externally, but this needs to be done by someone who knows how to do it.
Go to the top of the page
 
+Quote Post
NormMonkey
post Feb 4 2020, 09:50 AM
Post #9





Group: Members
Posts: 92
Joined: 22-November 19
Member No.: 860,015



QUOTE(Paul H @ Feb 3 2020, 10:23 AM) *
I have not used the Gemini that much over the past few months and let the battery sit uncharged. Once I did hear it try to turn on while plugged in but it didn’t. I can’t even get it to turn on while plugged in. I can try a different charger and see if that helps. I did have another charger from Planet Computers but that didn’t make a difference. The weird thing is I reached out to support a week ago and have not heard back.


Recommend try a different charger in case your charger is misbehaving.

If you have a 5V/500mA or 5V/1A old-school "slow" charger, I recommend to try that.
Go to the top of the page
 
+Quote Post
Paul H
post Feb 6 2020, 05:24 PM
Post #10





Group: Members
Posts: 16
Joined: 17-June 18
Member No.: 824,644



I will leave it in for a while. When I try to power on the Gemini it does vibrate but does not turn on. Also concerning is I’ve yet to hear from Planet Computers web site and it’s been almost 2 weeks. Send a few emails. Not a peep from them.
Go to the top of the page
 
+Quote Post
Paul H
post Feb 10 2020, 09:36 AM
Post #11





Group: Members
Posts: 16
Joined: 17-June 18
Member No.: 824,644



I did hear back finally from a Planet. Told me to hold then ESC and silver buttons down until the device vibrates. Still nothing. They also want me to do a full restore. Not hopeful on that end
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd February 2020 - 03:22 AM