OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Additional keyboard layout, Fn combinations do not work when extra layout added
Yagiza
post Feb 29 2020, 11:46 PM
Post #1





Group: Members
Posts: 17
Joined: 10-September 18
From: Magnitogorsk, Russian Federation
Member No.: 830,699



After adding another keyboard layout, besides default English, Fn combinations do not work anymore.
I added Russian layout to the list. Now I can switch to Russian and type Cyrillic letters, but Fn combinations do not work even in English layout! I can't even type "-" or "=", so the keyboard goes almost unusable. When I remove extra layout, leaving only default English, everything goes back to normal.
Yes, I set keyboard to "Planet Computers Cosmo Communicator" on Hardware tab of Settings, but didn't notice any effect.
Go to the top of the page
 
+Quote Post
Bernhard
post Mar 5 2020, 12:22 AM
Post #2





Group: Members
Posts: 5
Joined: 2-March 20
Member No.: 866,482



QUOTE(Yagiza @ Mar 1 2020, 08:46 AM) *
After adding another keyboard layout, besides default English, Fn combinations do not work anymore.
I added Russian layout to the list. Now I can switch to Russian and type Cyrillic letters, but Fn combinations do not work even in English layout! I can't even type "-" or "=", so the keyboard goes almost unusable. When I remove extra layout, leaving only default English, everything goes back to normal.
Yes, I set keyboard to "Planet Computers Cosmo Communicator" on Hardware tab of Settings, but didn't notice any effect.


Well, that is interesting. I experience a similar problem with the german keyboard. The Fn combinations produce double character sequence. E.g. when pressing Fn+k to get a '-', I get sk instead.

When I remove the german layout, I can use the Fn key again.

So, the situation is not good, but improved.
Go to the top of the page
 
+Quote Post
szopin
post Mar 5 2020, 02:23 AM
Post #3





Group: Members
Posts: 46
Joined: 24-February 19
Member No.: 842,637



QUOTE(Bernhard @ Mar 5 2020, 09:22 AM) *
QUOTE(Yagiza @ Mar 1 2020, 08:46 AM) *
After adding another keyboard layout, besides default English, Fn combinations do not work anymore.
I added Russian layout to the list. Now I can switch to Russian and type Cyrillic letters, but Fn combinations do not work even in English layout! I can't even type "-" or "=", so the keyboard goes almost unusable. When I remove extra layout, leaving only default English, everything goes back to normal.
Yes, I set keyboard to "Planet Computers Cosmo Communicator" on Hardware tab of Settings, but didn't notice any effect.


Well, that is interesting. I experience a similar problem with the german keyboard. The Fn combinations produce double character sequence. E.g. when pressing Fn+k to get a '-', I get sk instead.

When I remove the german layout, I can use the Fn key again.

So, the situation is not good, but improved.

Only one layout at a time seems to work, so you should be able to remove us (uk?) one and have the german or russian one working (though make sure it is working correctly, polish one was broken for example)
Go to the top of the page
 
+Quote Post
lokomoko
post Mar 5 2020, 03:14 AM
Post #4





Group: Members
Posts: 5
Joined: 21-February 20
Member No.: 866,005



You might also want to have a look at this thread.
Go to the top of the page
 
+Quote Post
Bernhard
post Mar 5 2020, 03:33 AM
Post #5





Group: Members
Posts: 5
Joined: 2-March 20
Member No.: 866,482



QUOTE(szopin @ Mar 5 2020, 11:23 AM) *
QUOTE(Bernhard @ Mar 5 2020, 09:22 AM) *
QUOTE(Yagiza @ Mar 1 2020, 08:46 AM) *
After adding another keyboard layout, besides default English, Fn combinations do not work anymore.
I added Russian layout to the list. Now I can switch to Russian and type Cyrillic letters, but Fn combinations do not work even in English layout! I can't even type "-" or "=", so the keyboard goes almost unusable. When I remove extra layout, leaving only default English, everything goes back to normal.
Yes, I set keyboard to "Planet Computers Cosmo Communicator" on Hardware tab of Settings, but didn't notice any effect.


Well, that is interesting. I experience a similar problem with the german keyboard. The Fn combinations produce double character sequence. E.g. when pressing Fn+k to get a '-', I get sk instead.

When I remove the german layout, I can use the Fn key again.

So, the situation is not good, but improved.

Only one layout at a time seems to work, so you should be able to remove us (uk?) one and have the german or russian one working (though make sure it is working correctly, polish one was broken for example)


This did it. Great int! Thank you so much!
Go to the top of the page
 
+Quote Post
Yagiza
post Mar 6 2020, 07:56 AM
Post #6





Group: Members
Posts: 17
Joined: 10-September 18
From: Magnitogorsk, Russian Federation
Member No.: 830,699



QUOTE(szopin @ Mar 5 2020, 03:23 PM) *
Only one layout at a time seems to work, so you should be able to remove us (uk?) one and have the german or russian one working (though make sure it is working correctly, polish one was broken for example)

Well... How can I work with only Russian layout enabled? How to type Latin letters?
Go to the top of the page
 
+Quote Post
Adam Boardman
post Mar 6 2020, 11:10 AM
Post #7





Group: Members
Posts: 179
Joined: 29-December 17
Member No.: 815,489



QUOTE(Yagiza @ Mar 6 2020, 04:56 PM) *
Well... How can I work with only Russian layout enabled? How to type Latin letters?

If your using the gemian layouts and no one changed things since the gemini to break things then they come with two groups, you just press both shift keys to swap groups to quickly change which set of characters are used.

The gemini login screen was changed to allow you to have two drop downs one for the language variant (symbols) and then one for the layout (group) with a test text entry box so you could try it out. This time around Nikita has swapped everything so someone has to do all that work again. You also lose the special keys as they are not supported on letter+modifier key mappings by upstream projects.

I don't have a functioning Cosmo so can't check.
Go to the top of the page
 
+Quote Post
Yagiza
post Mar 7 2020, 02:49 AM
Post #8





Group: Members
Posts: 17
Joined: 10-September 18
From: Magnitogorsk, Russian Federation
Member No.: 830,699



QUOTE(Adam Boardman @ Mar 7 2020, 12:10 AM) *
QUOTE(Yagiza @ Mar 6 2020, 04:56 PM) *
Well... How can I work with only Russian layout enabled? How to type Latin letters?

If your using the gemian layouts and no one changed things since the gemini to break things then they come with two groups, you just press both shift keys to swap groups to quickly change which set of characters are used.

Yeah, that worked! Thanx!
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 6th April 2020 - 02:39 PM