Author Topic: Kathrin-rc9 Sdk  (Read 1296 times)

prohto

  • Newbie
  • *
  • Posts: 12
    • View Profile
Kathrin-rc9 Sdk
« on: May 02, 2005, 04:40:30 am »
Hi everybudy, I'm happy using my zaurus with the latest pdaxrom, the best rom I tried. After a few day I decided to port my owns appl. (maybe evince, because xpdf fails to open a pdf )  to pdaxrom, for that I tried:

pdaxromsdk-1.1.0-softfloat.tar

But when I try to compile something I get errors like this:

/opt/zaurus/cross/arm/3.3.2-vfp/bin/../lib/gcc-lib/armv5tel-cacko-linux/3.3.2/../../../../armv5tel-cacko-linux/bin/as: Symbol `bfd_abs_section' has different size in shared object, consider re-linking
/opt/zaurus/cross/arm/3.3.2-vfp/bin/../lib/gcc-lib/armv5tel-cacko-linux/3.3.2/../../../../armv5tel-cacko-linux/bin/as: Symbol `bfd_und_section' has different size in shared object, consider re-linking
/opt/zaurus/cross/arm/3.3.2-vfp/bin/../lib/gcc-lib/armv5tel-cacko-linux/3.3.2/../../../../armv5tel-cacko-linux/bin/as: Symbol `bfd_com_section' has different size in shared object, consider re-linking
Assembler messages:
FATAL: can't create /tmp/ccppN4Be.o: Invalid bfd target

And whe I run the assembler directly:

armv5tel-linux-as: Symbol `bfd_abs_section' has different size in shared object, consider re-linking
armv5tel-linux-as: Symbol `bfd_und_section' has different size in shared object, consider re-linking
armv5tel-linux-as: Symbol `bfd_com_section' has different size in shared object, consider re-linking
GNU assembler version 2.15 (armv5tel-cacko-linux) using BFD version 2.15
Assembler messages:
FATAL: can't create a.out: Invalid bfd target


Somebody could tell what is wrong?


Best regards

prohto

  • Newbie
  • *
  • Posts: 12
    • View Profile
Kathrin-rc9 Sdk
« Reply #1 on: May 03, 2005, 03:15:32 am »
Hi everybudy, for all the ones who could get this kind of error, I solved it by recomiling a new toolchain using pdaXrom-builder-22.20_30.01.05.
After that,  with the following minor adjustemen I was able to compile some packages:

1.- glibc.make downlods link broken
2.- gtk22.make version upgrade
3.- glib22.make version adjustment ( malor, minor and micro )


On my first try,  was unable to compile the kernel ( some assembler error, I will try it another day ).  


My Zaurus is a c860 and my linux box is a debian sarge.


Best regards

pgas

  • Hero Member
  • *****
  • Posts: 1097
    • View Profile
    • http://
Kathrin-rc9 Sdk
« Reply #2 on: May 03, 2005, 05:20:37 am »
To build the kernel I think you need to build the  2.95 toolchain.
You can build it as decribed for te 3.3.2 using the corgi-arm-hardfloat-2.95.3-2.2.5-2.4.18 config.

then specify the toolchain to use in the kernel menu
as described here:https://www.oesf.org/index.php?title=PdaXrom:_pdaXrom-builder
SLC-860 cacko / senao wifi