Author Topic: Bitbake Scripts...  (Read 1678 times)

ironstorm

  • Jr. Member
  • **
  • Posts: 86
    • View Profile
    • http://
Bitbake Scripts...
« on: June 03, 2005, 08:34:43 am »
June 3, 2005...

My rough work towards making a bitbake image on Debian under QEMU...  There is a problem with the compiler path I can't resolve (says it can't find arm-linux-gcc-2.95, but it is in the path)...

I use a build account called "bitbake" w/ sudo permissions to do everything root can.
I put all of my OE "/stuff" in ~/bb

- unzip this file
- grant sudo privledges to your build account
- cut and paste lines from bitbake_install.txt to command prompt
- get path settings from .bashrc add them to your shell, log out and back in, then type "export" to check your paths for PATH and BBPATH
- run refresh_toolchain.sh to get the latest build of bitbake and OE package data

If you are using a collie (5500), you can copy local.conf to ~/bb/build/conf/local.conf, otherwise you'll have to edit ~/bb/build/conf/local.conf as per the docs @ http://oe.handhelds.org/cgi-bin/moin.cgi/GettingStarted

Once your local.conf is done, you can start a build by doing:
cd ~/bb/build
bitbake openzaurus-sa


Let me know how it works/doesn't for you...

Cheers,
-Ironstorm

jamesm

  • Full Member
  • ***
  • Posts: 102
    • View Profile
    • http://
Bitbake Scripts...
« Reply #1 on: June 03, 2005, 09:40:36 am »
I'll try it out tonight and post the results here.
Victim of c3000 ebay scam.... Now after c3100

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Bitbake Scripts...
« Reply #2 on: June 03, 2005, 10:22:25 am »
Quote
There is a problem with the compiler path I can't resolve (says it can't find arm-linux-gcc-2.95, but it is in the path)...

Are you sure that you remembered to rename the arm-linux-gcc file to arm-linux-gcc-2.95 ?


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

ironstorm

  • Jr. Member
  • **
  • Posts: 86
    • View Profile
    • http://
Bitbake Scripts...
« Reply #3 on: June 03, 2005, 02:25:30 pm »
Quote
Quote
There is a problem with the compiler path I can't resolve (says it can't find arm-linux-gcc-2.95, but it is in the path)...
Are you sure that you remembered to rename the arm-linux-gcc file to arm-linux-gcc-2.95 ?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=82641\"][{POST_SNAPBACK}][/a][/div]

Yes, it's gets mv'd in the bitbake_install.txt commands...  And /usr/local/arm/2.95.3/bin
is exported both BBPATH and PATH...

At first I had it symlinked but then I realized that might not work from ZaurusKernels where Mickeyl said that ln might leave it still in the path (it could conflict w/ 3.3 or 3.4 or whatever is used to compile the non-kernel packages, I guess)...

I'm wondering if maybe the directory path is too long or something (the kernel compile like 6 directories below /home/bitbake/bb/build vs. /stuff/build which is used in the OE docs)...

It also seems to work executing the "ccache arm-linux-gcc-2.95 ..." command from the command line in the directory it supposedly died in...

-Ironstorm