Author Topic: Locked Out Of C1k  (Read 1629 times)

gdog

  • Full Member
  • ***
  • Posts: 246
    • View Profile
Locked Out Of C1k
« on: July 02, 2005, 11:11:18 am »
Trouble!!!

I remounted my / as rw. I umounted /tmp and removed the /tmp link to /dev/shm. I created a link /tmp to a directory on my cf card (ln -s /mnt/cf/tmp /tmp), and that worked fine. I then rebooted my Z but it will no longer boot past the CG Zaurus screen.

I tried going into single user mode and remarking out the line where /dev/shm is mounted on /tmp, and adding a line to where /mnt/cf/tmp was mounted on /tmp. But it didn't work, and when I finally booted back into single user mode the revised fstab file was gone, replaced with the original.

/tmp now shows up as a directory which I can't remove, and can't umount even with a umount -f command.

When I started I seem to recall that a df -k on /tmp showed NONE for a filesystem, but an ls -al in / showed /tmp as a symbolic link to /dev/shm/tmp. But after all I did tmp was missing from /dev/shm/, even though I didn't remove it. So I recreated it but the system still refuses to boot.

Note: my mount command does show /dev/shm    /tmp    ..... so it is mounting and I am able to copy into it, but the Z just won't make it past the CG Silicon screen.

Can someone with a C1K send me the output of a mount command, as well as what the /etc/fstab shows, and the contents of /dev/shm? Something is hinky here and I'm not sure what, but I think it's something to do with either what is now /tmp the directory, and/or /dev/shm/tmp the directory. My fstab is back to what it was to begin with, so I don't see what else it could be....

Any help would be greatly appreciated.

Booting into the command line this is what I see:

mount
/rootfs on / type rootfs (rw)
/dev/root on / type ext2 (ro)
/proc on /prod type proc (rw)
/dev/shm on /tmp type tmpfs (rw)
/none on /dev/pts type devpts (rw)

then my two cards' mounts are listed. Same output if I cat /etc/mtab
###

cat /etc/fstab
/dev/root   /   ext2   rw   1 1
/dev/shm   /tmp   tmpfs 1 2
/dev/mmcda1   /mnt/card   auto   noauto,owner 0 0
/none    /dev/pts   devpts   gid=5,mode=620   0 0

###
ls -al /
/tmp shows up as a directory instead of what I believe should be a symbolic link to /dev/shm/tmp

I cannot umount it even if I use -f. I'm not sure how it became a directory because when I originally umounted /tmp as I explained above, I then created a symbolic link of /tmp to /mnt/cf/tmp

PROBLEM SOLVED THANKS TO STUBEAR AND A NAND RESTORE.

Thanks,

gdog
« Last Edit: July 02, 2005, 11:51:58 pm by gdog »
You can tell a lot about a man by the condition of his shoes