Author Topic: Port Requests Here:  (Read 28995 times)

LordDavon

  • Full Member
  • ***
  • Posts: 161
    • View Profile
    • http://
Port Requests Here:
« Reply #60 on: March 18, 2004, 11:25:42 am »
Quote
Lord:  

your stonx isn\'t complete.... your STonX dir is nor o+r, but I did a make under sparc (runs fast!) and found the filenames.  
for your tar, you need Keysyms and cartridge.img (both in the top level of STonX make dir).  However, even with that,
stonx didn\'t seem to want to run... it kept locking up after the keysym load.  It\'s too bad, because it seems to have a lot
more config options than hatari.  I tried about a dozen roms and a dozen settings (all roms and settings worked on
a 500mhz sparc).  nothing working on the zaurus :-<

I tried hatari... but the pointer was always off.  it wasn\'t always off by the same amount, but 80% of the time I couldn\'t
even get the pointer to go up high enough to get to the menus... most of the time, the emulator ran so slow... for
instance, one time, it took about 15 seconds to draw the first gem desktop screen.  :-<  What and how did you
set up your hatari that allowed you to run a game?  

I\'ll work some more on the other emulators, etc.

Scott

I am going to continue to debug stonx and see what is going on.  As for hatari, it was running pretty good on my C760.  I was running it in fullscreen to resolve the pointer issue.  I am not sure why it is not working with the mouse coords defines in X, but this is the same issue as with Dosbox.  Let me see what I can find out.

LD

ScottYelich

  • Hero Member
  • *****
  • Posts: 992
    • View Profile
    • http://www.zaurususergroup.com/modules.php?opmodload&namephpWiki&filei
Port Requests Here:
« Reply #61 on: March 18, 2004, 12:17:25 pm »
ya, I tried wiping my pointercal ... and recalibrating, but that didn\'t help.
I tried overclocking and underclocking.. that didn\'t help.

I tried tapping first, where the \"bee\" was to see if it was a vnc-like first click calibration...
that wasn\'t it.  

I tried full screen.  I tried --vdi (btw: --frameskip gives invalid option) ... didn\'t work.
I had almost decent calibration with full screen, but I noticed that when I clicked near the
menus -- the pointer JUMPED.. then it was not accurate.

Do you have any references for any disk images?  I\'d hate to have to convert all those
steem disks over (512 of\'m) ...  

stonx seems like it has many more options that will allow for finer tuning of the system,
so it would be good to see where it is failing (profiling, tracing, etc?)

I also tried bochs... but we don\'t have bios image, etc.  I think we should work on making
these into ipk or at least usable.  When I get some time, perhaps this weekend, I\'ll try
to do what it takes to make each emulator work with at least some sort of boot image, etc.

I tried xu4-9 and it said it:
I/O warning: failed to load external entity \"egaPalette.xml\"
xu4: error: error parsing egaPalette.xml

also, maybe the bunary should be named xu4 and not just u4?

What I did was grab all the files in the feeds/davonz -- and now have my 760 at work..
but I don\'t have net access here.  so I can\'t xfer any other files, etc.

Scott

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Port Requests Here:
« Reply #62 on: March 19, 2004, 09:47:00 am »
I don\'t especially want anyone to port if for me (as I\'m perfectly capable), but is there a terminal app (like rxvt) which has a scroll bar on the side so I can go back and look at what\'s been spewed out? This may actually be possible with xterm for all I know?

Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

ChrisEBoy

  • Newbie
  • *
  • Posts: 47
    • View Profile
Port Requests Here:
« Reply #63 on: March 19, 2004, 09:54:12 am »
use the middle button and ctrl together anywhere on the xterm, at the top of the pop up menu will be scroll bar, check it and you\'ve got a scroll bar.  Bad thing is you have to use the middle button to scroll.  Forget it at your peril, the command prompt isn\'t fond of letting you forget :-)

HTH
Chris

ScottYelich

  • Hero Member
  • *****
  • Posts: 992
    • View Profile
    • http://www.zaurususergroup.com/modules.php?opmodload&namephpWiki&filei
Port Requests Here:
« Reply #64 on: March 20, 2004, 04:39:47 pm »
davon -- with the latest exult you have compiled -- I get screen corruption.... under the pointer, etc.
Has anyone else tried exult? does it work for you?  This would be an awesome game, if the pointer
didn\'t have the corruption under it.

Scott

LordDavon

  • Full Member
  • ***
  • Posts: 161
    • View Profile
    • http://
Port Requests Here:
« Reply #65 on: March 20, 2004, 05:21:25 pm »
It may be that I used the old SDK on it.  I will recompile a new one under the latest SDK.

LD

jeffk

  • Newbie
  • *
  • Posts: 17
    • View Profile
Port Requests Here:
« Reply #66 on: March 20, 2004, 05:38:23 pm »
Quote
Minimo (Netscape based browser) has already been ported (afaik). Take a look at the GPE mailing list.

I would *really* love to try a port of minimo, if anyone has one for pdaxrom. This looks like the perfect browser for pdaxrom.

I tried the one from http://ipkgfind.handhelds.org/details.phtm...?package=minimo , but haven\'t been able to get it to install, even using ipkg command line. Can we get a build (with xft enabled) and have it added to the pdaxrom feed? Thanks.

CoreyC

  • Sr. Member
  • ****
  • Posts: 288
    • View Profile
    • http://
Port Requests Here:
« Reply #67 on: March 20, 2004, 06:21:29 pm »
I think minimo is on everyones wishlist.  Have you tried dillo?  It is far from perfect, works good for me until a minimo port is available.

ScottYelich

  • Hero Member
  • *****
  • Posts: 992
    • View Profile
    • http://www.zaurususergroup.com/modules.php?opmodload&namephpWiki&filei
Port Requests Here:
« Reply #68 on: March 20, 2004, 06:27:30 pm »
dillo is amazing for simple HTML... try scrolling in dillo (try middle button, etc).

dillo full screen, dillo-xft... very nice.

firefox when you need it, dillo when it\'s good enough.  I tend to browse with both, in dillo, and then paste to firefox if the
rendering is too far off.

Lord -- thanks for the new SDK.  also, I think the latest exult is 1.1.10rc2 or 3 ...

Scott

ScottYelich

  • Hero Member
  • *****
  • Posts: 992
    • View Profile
    • http://www.zaurususergroup.com/modules.php?opmodload&namephpWiki&filei
Port Requests Here:
« Reply #69 on: March 22, 2004, 11:23:07 pm »
ok, still have scrolling graphics under the poiinter with the latest exult 10

mame doesn\'t run any roms that it use to! argh.  perhaps it\'s my
advmamerc ... where is yours again?

Scott

biospank

  • Newbie
  • *
  • Posts: 12
    • View Profile
Port Requests Here:
« Reply #70 on: March 23, 2004, 03:38:04 am »
Hi all,
another porting request:
DIA
a gtk+ based diagram creation program http://www.lysator.liu.se/~alla/dia/

thanks,

bio.
C760 pdaxrom 1.0
memorex CF 128
hexon mmc 128
pretec CompactWLAN CF card

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Port Requests Here:
« Reply #71 on: March 23, 2004, 04:57:57 am »
minimo: is the problem simply that it\'s an ar type ipk?
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

obs1

  • Newbie
  • *
  • Posts: 26
    • View Profile
Port Requests Here:
« Reply #72 on: March 23, 2004, 06:46:05 am »
Quote
minimo: is the problem simply that it\'s an ar type ipk?

no i repackaged minimo available from the official site and installed the IPK. However it would not run because its compiled for GLIBC_2.3.

When I tried to recompile it using the pdaXrom sdk and instructions at http://www.mozilla.org/projects/minimo/build.html I got an error because it was trying to make use of shellcode for the intel processor (!?). Maybe I\'m missing something ..

LordDavon

  • Full Member
  • ***
  • Posts: 161
    • View Profile
    • http://
Port Requests Here:
« Reply #73 on: March 23, 2004, 10:42:13 am »
Quote
ok, still have scrolling graphics under the poiinter with the latest exult 10

mame doesn\'t run any roms that it use to! argh.  perhaps it\'s my
advmamerc ... where is yours again?

Scott

I had the same problem with that version.  I think it is due to the changes that were made.  

I compiled the vanilla version 79.1 and ran it on my system without any issues.  I then took the sources on my drive and copied to a 79.1.scott version for you to try to make your changes with again.  Get them in and I will recompile and test.

LD

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Port Requests Here:
« Reply #74 on: March 23, 2004, 01:09:36 pm »
Has anyone done xscreensaver?

Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva