Author Topic: Mkipkg Problem  (Read 1238 times)

w14

  • Full Member
  • ***
  • Posts: 180
    • View Profile
    • http://
Mkipkg Problem
« on: February 23, 2006, 12:41:17 pm »
I've compiled the latest version of Bestcrypt. I set up vmware player with the cross compile environment as in jerrybme's howto.

The make and make install went fine after a bit of messing with the makefiles.

When I run mkipkg against the temp directory, I'm getting the error:

tar: --exclude=CONTROL: Cannot stat: No such file or directory
tar: error exit delayed from previous errors

Everything seems fine ... all the files and directories are there, including the CONTROL directory with the control file.

Can anyone point me in the right direction?

Cheers,

Mike.
sl-c3100
pdaxrom 1.1.0 beta1

w14

  • Full Member
  • ***
  • Posts: 180
    • View Profile
    • http://
Mkipkg Problem
« Reply #1 on: February 23, 2006, 12:50:43 pm »
Its ok ... found the answer. Old version of mkipkg.
sl-c3100
pdaxrom 1.1.0 beta1

desertrat

  • Hero Member
  • *****
  • Posts: 743
    • View Profile
    • http://
Mkipkg Problem
« Reply #2 on: April 07, 2007, 04:45:11 am »
Quote
more specifically, you needed an old version of tar (eg 1.13  https://www.oesf.org/forums/index.php?showtopic=23649)

 
I would rather use an "updated" version of mkipkg than downgrade to an old version of tar.
« Last Edit: April 07, 2007, 04:48:19 am by desertrat »
SL-C3100 / Ambicon WL1100C-CF / pdaXrom 1.1.0beta3 / IceWM

telemetric_au

  • Sr. Member
  • ****
  • Posts: 327
    • View Profile
    • http://www.tyrannozaurus.com/feed/contribs/telemetric/index.htm
Mkipkg Problem
« Reply #3 on: April 07, 2007, 08:54:13 pm »
Quote
Quote
more specifically, you needed an old version of tar (eg 1.13  https://www.oesf.org/forums/index.php?showtopic=23649)

 
I would rather use an "updated" version of mkipkg than downgrade to an old version of tar.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=158159\"][{POST_SNAPBACK}][/a][/div]


i realise this too now seeing that downgrading tar breaks ipkg installs ...,  where can i fnd new verion ??
Collie w/ pdaxrom & Puppy OS w/ cross-sdk
Hawking HCF686TX 10/100, Ambicom 802.11b (WL1100C-CF), Xircom 56K Global CF
Kingston CF Elite Pro & SD 1Gb & 128mb for flashing
$2 screen protector, collie.pdaxrom.feed : my collie pdaxrom site

desertrat

  • Hero Member
  • *****
  • Posts: 743
    • View Profile
    • http://
Mkipkg Problem
« Reply #4 on: April 08, 2007, 03:43:28 am »
Quote
i realise this too now seeing that downgrading tar breaks ipkg installs ...,  where can i fnd new verion ??
https://www.oesf.org/index.php?title=Pdaxro...te_An_Ipk_Howto
http://mail.pdaxrom.org/contrib/misc/mkipkg

Perhaps you should edit your other posts on this subject (or delete them).
SL-C3100 / Ambicon WL1100C-CF / pdaXrom 1.1.0beta3 / IceWM

telemetric_au

  • Sr. Member
  • ****
  • Posts: 327
    • View Profile
    • http://www.tyrannozaurus.com/feed/contribs/telemetric/index.htm
Mkipkg Problem
« Reply #5 on: April 08, 2007, 03:57:09 am »
Quote
Quote
i realise this too now seeing that downgrading tar breaks ipkg installs ...,  where can i fnd new verion ??
https://www.oesf.org/index.php?title=Pdaxro...te_An_Ipk_Howto
http://mail.pdaxrom.org/contrib/misc/mkipkg

Perhaps you should edit your other posts on this subject (or delete them).
[div align=\"right\"][a href=\"index.php?act=findpost&pid=158238\"][{POST_SNAPBACK}][/a][/div]


thats the one of being trying to use unsuccessfully... is there newwer ??
« Last Edit: April 08, 2007, 03:58:25 am by telemetric_au »
Collie w/ pdaxrom & Puppy OS w/ cross-sdk
Hawking HCF686TX 10/100, Ambicom 802.11b (WL1100C-CF), Xircom 56K Global CF
Kingston CF Elite Pro & SD 1Gb & 128mb for flashing
$2 screen protector, collie.pdaxrom.feed : my collie pdaxrom site

desertrat

  • Hero Member
  • *****
  • Posts: 743
    • View Profile
    • http://
Mkipkg Problem
« Reply #6 on: April 08, 2007, 11:59:52 am »
Quote
thats the one of being trying to use unsuccessfully... is there newwer ??
That's the one I've always been using and my tar is 1.15. Maybe try Meanie's package?:
https://www.oesf.org/forums/index.php?showt...ndpost&p=155263
SL-C3100 / Ambicon WL1100C-CF / pdaXrom 1.1.0beta3 / IceWM

telemetric_au

  • Sr. Member
  • ****
  • Posts: 327
    • View Profile
    • http://www.tyrannozaurus.com/feed/contribs/telemetric/index.htm
Mkipkg Problem
« Reply #7 on: April 16, 2007, 10:35:16 am »
ive fixed the mkipkg syntax section thats being problematic, very simple, the new version is attached... for my "documentation" see the readme or the following thread:

https://www.oesf.org/forums/index.php?showtopic=23649

 

coincidently i just fix it and then find the same fix...

https://www.oesf.org/forums/index.php?showt...t=&#entry108895
« Last Edit: April 16, 2007, 10:45:33 am by telemetric_au »
Collie w/ pdaxrom & Puppy OS w/ cross-sdk
Hawking HCF686TX 10/100, Ambicom 802.11b (WL1100C-CF), Xircom 56K Global CF
Kingston CF Elite Pro & SD 1Gb & 128mb for flashing
$2 screen protector, collie.pdaxrom.feed : my collie pdaxrom site