Author Topic: 3.5.4.x Upgrades  (Read 66937 times)

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
3.5.4.x Upgrades
« Reply #195 on: September 06, 2006, 05:40:57 am »
From the .bb files, it's probably in:

ftp://ftp.trolltech.com/pub/qt/source/qt-...e-3.3.5.tar.bz2
+ a conf file from the OE metadata under the qmake directory.

See here: http://www.openembedded.org/repo/org.opene...native_1.07a.bb


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
3.5.4.x Upgrades
« Reply #196 on: September 06, 2006, 09:15:53 am »
Quote
From the .bb files, it's probably in:

ftp://ftp.trolltech.com/pub/qt/source/qt-...e-3.3.5.tar.bz2
+ a conf file from the OE metadata under the qmake directory.

See here: http://www.openembedded.org/repo/org.opene...native_1.07a.bb


Si
[div align=\"right\"][a href=\"index.php?act=findpost&pid=140826\"][{POST_SNAPBACK}][/a][/div]

if you want to build it natively, then the first thing it does is build qmake, followed by moc and then the qt-mt shared or static library. if you then further compile the tools, it will first compile uic and the rest of the tools. you probbaly want to compile designer, linguistics and assistant.
« Last Edit: September 06, 2006, 09:16:36 am by Meanie »
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

zhy08043

  • Newbie
  • *
  • Posts: 7
    • View Profile
3.5.4.x Upgrades
« Reply #197 on: September 15, 2006, 05:31:57 pm »
Hrw, Thanks for your great work. Can you also add the following to the feed:

fbvncserver-kmodule for tosa?

Thanks again!!

Hrw

  • Hero Member
  • *****
  • Posts: 1366
    • View Profile
3.5.4.x Upgrades
« Reply #198 on: September 16, 2006, 04:15:38 am »
http://ewi546.ewi.utwente.nl/tmp/hrw/fb/?a...k7-pxa3-embedix show that it is already provided for Tosa.
OpenZaurus 3.5.4x Release Manager
OpenEmbedded, Ångström, Poky developer
My website

Misc embedded hardware.

Hrw

  • Hero Member
  • *****
  • Posts: 1366
    • View Profile
3.5.4.x Upgrades
« Reply #199 on: September 29, 2006, 11:26:50 am »
Updated:
- scummvm 0.9.0
- kismet 2006-04-R1

Added:
- xournal 0.3.1
- task-native-sdk - should be enough to build something
« Last Edit: October 03, 2006, 06:04:29 am by Hrw »
OpenZaurus 3.5.4x Release Manager
OpenEmbedded, Ångström, Poky developer
My website

Misc embedded hardware.

Lurker

  • Jr. Member
  • **
  • Posts: 74
    • View Profile
3.5.4.x Upgrades
« Reply #200 on: October 05, 2006, 03:37:40 pm »
Please build spca5xx for C3000.
Thanks!
Zaurus SL-C3000
Zonet 802.11g USB (ZEW2501) --> Zydas ZD1211
IOGear Bluetooth USB (GBU211) --> Broadcom BCM2035
OpenZaurus 3.5.4.1 / GPE 2.7

..bk..

  • Newbie
  • *
  • Posts: 16
    • View Profile
    • http://
3.5.4.x Upgrades
« Reply #201 on: October 08, 2006, 11:22:23 am »
can you update the firefox package, please?

see here:
https://www.oesf.org/forums/index.php?showtopic=21570

and here:
http://bugs.openembedded.org/show_bug.cgi?id=1436

thanks for solving this!

..bk..

  • Newbie
  • *
  • Posts: 16
    • View Profile
    • http://
3.5.4.x Upgrades
« Reply #202 on: October 16, 2006, 12:05:58 pm »
Quote
Updated:
- scummvm 0.9.0
- kismet 2006-04-R1

hrw,
the kismet package from the upgrades feed is broken. won't start because the binaries are linked to libuclibc++0 _and_ libstdc++6.

here's what happens:
Code: [Select]
root@zoe:~# ./kismet_server
*** glibc detected *** ./kismet_server: double free or corruption (!prev): 0x000c2968 ***
======= Backtrace: =========
/lib/libc.so.6[0x40245f18]
./kismet_server[0x8cea4]
/lib/libc.so.6(__libc_start_main+0xbc)[0x401fbc10]
======= Memory map: ========
00008000-000ae000 r-xp 00000000 1f:03 13608      /home/root/kismet_server
000b6000-000b8000 rw-p 000a6000 1f:03 13608      /home/root/kismet_server
000b8000-000e3000 rwxp 000b8000 00:00 0          [heap]
40000000-40019000 r-xp 00000000 1f:02 712        /lib/ld-2.3.90.so
4001d000-4001f000 rw-p 4001d000 00:00 0
40020000-40022000 rw-p 00018000 1f:02 712        /lib/ld-2.3.90.so
40022000-4003b000 r-xp 00000000 1f:02 28870      /usr/lib/libuClibc++.so.0.1.9
4003b000-40042000 ---p 00019000 1f:02 28870      /usr/lib/libuClibc++.so.0.1.9
40042000-40044000 rw-p 00018000 1f:02 28870      /usr/lib/libuClibc++.so.0.1.9
40044000-40048000 rw-p 40044000 00:00 0
40048000-40114000 r-xp 00000000 1f:02 6572       /usr/lib/libstdc++.so.6.0.3
40114000-4011b000 ---p 000cc000 1f:02 6572       /usr/lib/libstdc++.so.6.0.3
4011b000-40121000 rw-p 000cb000 1f:02 6572       /usr/lib/libstdc++.so.6.0.3
40121000-40127000 rw-p 40121000 00:00 0
40127000-401cb000 r-xp 00000000 1f:02 725        /lib/libm-2.3.90.so
401cb000-401d2000 ---p 000a4000 1f:02 725        /lib/libm-2.3.90.so
401d2000-401d4000 rw-p 000a3000 1f:02 725        /lib/libm-2.3.90.so
401d4000-401dd000 r-xp 00000000 1f:02 724        /lib/libgcc_s.so.1
401dd000-401e4000 ---p 00009000 1f:02 724        /lib/libgcc_s.so.1
401e4000-401e5000 rw-p 00008000 1f:02 724        /lib/libgcc_s.so.1
401e5000-402e8000 r-xp 00000000 1f:02 718        /lib/libc-2.3.90.so
402e8000-402ef000 ---p 00103000 1f:02 718        /lib/libc-2.3.90.so
402ef000-402f0000 r--p 00102000 1f:02 718        /lib/libc-2.3.90.so
402f0000-402f4000 rw-p 00103000 1f:02 718        /lib/libc-2.3.90.so
402f4000-402f6000 rw-p 402f4000 00:00 0
bec47000-bec5c000 rwxp bec47000 00:00 0          [stack]
Aborted

i re-built the kismet package myself using the org.openembedded.oz354x branch (but had to add a dependency to ncurses to get it built...) and it works perfectly (since not being linked to two c++ libs).

so could you just rebuild the package, so that other users don't end up with a broken kismet package?

thanks...

Hrw

  • Hero Member
  • *****
  • Posts: 1366
    • View Profile
3.5.4.x Upgrades
« Reply #203 on: October 16, 2006, 06:34:17 pm »
Rebuilt:
- kismet (thx for info)

Updated:
- keymap for tosa (close #1500 and part of #1498)
« Last Edit: October 17, 2006, 03:18:23 am by Hrw »
OpenZaurus 3.5.4x Release Manager
OpenEmbedded, Ångström, Poky developer
My website

Misc embedded hardware.

danboid

  • Hero Member
  • *****
  • Posts: 881
    • View Profile
    • http://
3.5.4.x Upgrades
« Reply #204 on: October 22, 2006, 05:38:24 am »
Could you please update

libgsf to 1.14.2 as this fixes a bug in importing incorrectly formatted excel files (as produced by Psiwin) into Gnumeric

Thanks!
« Last Edit: October 22, 2006, 05:40:39 am by danboid »
Zaurus SL-C3000 w/ MD swapped for a Kingston 32GB Ultimate 266X CF running ALARM
Banana Pi running ALARM on a WD Scorpio SATA II HD
System76 Gazelle Pro i7 laptop w/ SAMSUNG 840 EVO SSD running Arch x64

How to install Arch on your C3x00 Zaurus https://github.com/danboid/ZALARM-install

jerrybme

  • Hero Member
  • *****
  • Posts: 639
    • View Profile
    • http://
3.5.4.x Upgrades
« Reply #205 on: October 24, 2006, 02:05:58 pm »
Quote
Updated:
- vim 7.0 with features=big
- opie-multikey with Italian and Hebrew keymap
- gpe-package

about qmake: we do not have it yet - I will pester Mickeyl for it.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=140441\"][{POST_SNAPBACK}][/a][/div]

Has Mickeyl had any time to do qmake yet?

Cheers
SL-C3100
Angstrom-GPE
Lexar SD 1 GB
PQI 2GB CF
Ambicom WL1100 CF

Stilgar

  • Newbie
  • *
  • Posts: 43
    • View Profile
3.5.4.x Upgrades
« Reply #206 on: October 29, 2006, 03:32:39 pm »
Chris,
The latest update to SDL - what is it supposed to fix? Can you detail a bit about it or post a link about the change?

Any work on that is VERY appreciated... many things that I enjoy depend on SDL...

STrRedWolf

  • Newbie
  • *
  • Posts: 36
    • View Profile
    • http://stalag99.net
3.5.4.x Upgrades
« Reply #207 on: October 29, 2006, 05:24:01 pm »
Still wondering about recompiling MPlayer to work on 2.4 kernel Collie in 3.5.4.

CoreDump

  • Hero Member
  • *****
  • Posts: 713
    • View Profile
    • http://www.hentges.net
3.5.4.x Upgrades
« Reply #208 on: October 30, 2006, 12:37:00 pm »
Quote
Still wondering about recompiling MPlayer to work on 2.4 kernel Collie in 3.5.4.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=145065\"][{POST_SNAPBACK}][/a][/div]

A simple recompile doesn't do the trick as fresh images also show the libmad problem.
Webmaster of hentges.net & Embedded Linux Developer.

YoG

  • Jr. Member
  • **
  • Posts: 56
    • View Profile
3.5.4.x Upgrades
« Reply #209 on: November 15, 2006, 04:27:35 am »
A request:

Can qpe-gaim be upgraded?

Thanx,
YoG
C860 Autobuilt Angstrom (OPIE) & Zubuntu 9.04  dual boot using kexec
SanDisk SDHC 4GB, Agiwara Sys-Com CF 1GB, Sandisk CF 256MB, Socket BT, Linksys WCF12 Wifi card, RoyalTek RBT-1000 Bluetooth GPS
yogzlog.blogspot.com