Author Topic: Socket Go Wi-fi! P500  (Read 5421 times)

charlesa

  • Jr. Member
  • **
  • Posts: 89
    • View Profile
    • http://
Socket Go Wi-fi! P500
« on: August 02, 2006, 05:54:12 am »
Hi all -

I'm in the market for a new CF WiFi card.  Does anyone have any experience with the Socket Go Wi-Fi! P500?  Will it work in a Zaurus?  I'm using Cacko 1.22 & 1.23.

http://www.socketstore.com/product.asp?sku=2850722

Da_Blitz

  • Hero Member
  • *****
  • Posts: 1579
    • View Profile
    • http://www.pocketnix.org
Socket Go Wi-fi! P500
« Reply #1 on: August 02, 2006, 08:28:56 pm »
if its 802.11b then there is a good chance it will work

check here to see if it works or update the entry if its not there https://www.oesf.org/index.php?title=Wireless_Card_Support
Personal Blog
Code
Twitter

Gemini Order: #95 (roughly)
Current Device: Samsung Chromebook Gen 3
Current Arm Devices Count: ~30
Looking to acquire: Cavium Thunder X2 Hardware

charlesa

  • Jr. Member
  • **
  • Posts: 89
    • View Profile
    • http://
Socket Go Wi-fi! P500
« Reply #2 on: August 03, 2006, 04:55:18 am »
Thx.  I'll give ot a go.  Socket even provide a table of supported products for the Zaurii; always a  good sign.

http://www.socketcom.com/ZaurusSharp.asp

Da_Blitz

  • Hero Member
  • *****
  • Posts: 1579
    • View Profile
    • http://www.pocketnix.org
Socket Go Wi-fi! P500
« Reply #3 on: August 05, 2006, 06:48:39 am »
they forget to mention that if it works with one Z then it can be made to work with all the Z's
Personal Blog
Code
Twitter

Gemini Order: #95 (roughly)
Current Device: Samsung Chromebook Gen 3
Current Arm Devices Count: ~30
Looking to acquire: Cavium Thunder X2 Hardware

jackburton

  • Newbie
  • *
  • Posts: 22
    • View Profile
    • http://
Socket Go Wi-fi! P500
« Reply #4 on: August 23, 2006, 02:08:02 pm »
I tried it out on my C-3200 and it does not work. I'm not sure what driver it would use, either.

Any idea on how to determine the chipset?


Quote
they forget to mention that if it works with one Z then it can be made to work with all the Z's
[div align=\"right\"][a href=\"index.php?act=findpost&pid=137508\"][{POST_SNAPBACK}][/a][/div]

johnla

  • Newbie
  • *
  • Posts: 29
    • View Profile
    • http://
Socket Go Wi-fi! P500
« Reply #5 on: September 16, 2006, 12:32:35 am »
I just got my Zaurus C1000 this week. And I love it. A big part of that was this forum providing a lot of answers and tips. Appreciation!

I'm also interested in gettin this card to work. Anyone on here able to?
[span style=\'font-size:11pt;line-height:100%\']C1000 - 4GB SD - Planex CF Wifi
Cacko 1.23
[/font][/span]

Da_Blitz

  • Hero Member
  • *****
  • Posts: 1579
    • View Profile
    • http://www.pocketnix.org
Socket Go Wi-fi! P500
« Reply #6 on: September 17, 2006, 03:53:52 am »
have you done a search on the othero fourms, i remeber this card bieng mentioned
Personal Blog
Code
Twitter

Gemini Order: #95 (roughly)
Current Device: Samsung Chromebook Gen 3
Current Arm Devices Count: ~30
Looking to acquire: Cavium Thunder X2 Hardware

johnla

  • Newbie
  • *
  • Posts: 29
    • View Profile
    • http://
Socket Go Wi-fi! P500
« Reply #7 on: September 18, 2006, 10:28:23 pm »
Yea, I did a search and this is the thread I found!  I have a sinking feeling that it's not supported which sucks being that I just paid $60 for it..
[span style=\'font-size:11pt;line-height:100%\']C1000 - 4GB SD - Planex CF Wifi
Cacko 1.23
[/font][/span]

Da_Blitz

  • Hero Member
  • *****
  • Posts: 1579
    • View Profile
    • http://www.pocketnix.org
Socket Go Wi-fi! P500
« Reply #8 on: September 19, 2006, 12:31:59 am »
well time to debug the problem:

type dmesg > temp_file
then plug the card in
then dmesg > temp_file2

copy those to your pc and post the bit that differs
Personal Blog
Code
Twitter

Gemini Order: #95 (roughly)
Current Device: Samsung Chromebook Gen 3
Current Arm Devices Count: ~30
Looking to acquire: Cavium Thunder X2 Hardware

johnla

  • Newbie
  • *
  • Posts: 29
    • View Profile
    • http://
Socket Go Wi-fi! P500
« Reply #9 on: September 19, 2006, 11:54:18 pm »
Thanks for taking the time!

I attached the temp files and the 'diff temp_file1 temp_file2' results in the diff_res.txt file.

The file is kind of long so i won't paste the whole thing. But here are the highlights:

1,80c1,107
<  get RID fd51 (len=6) - no PRI f/w
< wifi0: cannot get RID fd51 (len=6) - no PRI f/w
 ........ REPEATS ..........
< wifi0: cannot get RID fd51 (len=6) - no PRI f/w
---
> ODE_ACCESS failed (res=-110, rid=fd51, len=6)
> wifi0: hfa384x_cmd_issue: cmd reg was busy for 5000 usec
> wifi0: hfa384x_cmd_issue - timeout - reg=0x8888
> wifi0: hfa384x_cmd: entry still in list? (entry=c388e2e0, type=0, res=-1)
> wifi0: hfa384x_cmd: interrupted; err=-110
> wifi0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd51, len=6)
> wifi0: hfa384x_cmd_issue: cmd reg was busy for 5000 usec
> wifi0: hfa384x_cmd_issue - timeout - reg=0x8888
> hostap_cs: CS_EVENT_CARD_REMOVAL
> wifi0: card already removed or not configured during shutdown
> pxa_pcmcia_init(0)
> hostap_crypt: unregistered algorithm 'WEP'
> hostap_cs: Driver unloaded
> hostap_crypt: unregistered algorithm 'NULL' (deinit)
97,102d123
< hostap_cs: CS_EVENT_PM_RESUME
< hostap_cs: CS_EVENT_CARD_RESET
< wifi0: __hfa384x_cmd_no_wait(6) - timeout - reg=0xf940
< hostap_cs: first command failed - assuming card does not have primary firmware
< new hp status=0
< hostap_cs: assuming no Primary image in flash - card initialization not completed
107c128
< wifi0: cannot get RID fd51 (len=6) - no PRI f/w
---
> new hp status=0
118,126d138
< wifi0: cannot get RID fd51 (len=6) - no PRI f/w
< hostap_cs: CS_EVENT_PM_SUSPEND
< hostap_cs: CS_EVENT_RESET_PHYSICAL
< wifi0: hfa384x_cmd_issue: cmd reg was busy for 5000 usec
< wifi0: hfa384x_cmd_issue - timeout - reg=0xf940
> wifi0: hfa384x_cmd: entry still in list? (entry=c388e2e0, type=0, res=-1)
> wifi0: hfa384x_cmd: interrupted; err=-110
> wifi0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd51, len=6)
> wifi0: hfa384x_cmd_issue: cmd reg was busy for 5000 usec
> wifi0: hfa384x_cmd_issue - timeout - reg=0x8888
........ REPEATS ............
> wifi0: hfa384x_cmd: entry still in list? (entry=c388e2e0, type=0, res=-1)
> wifi0: hfa384x_cmd: interrupted; err=-110
> wifi0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd51, len=6)
> hostap_cs: CS_EVENT_CARD_REMOVAL
> wifi0: card already removed or not configured during shutdown
> pxa_pcmcia_init(0)
> hostap_crypt: unregistered algorithm 'WEP'
> hostap_cs: Driver unloaded
> hostap_crypt: unregistered algorithm 'NULL' (deinit)
97,102d123
< hostap_cs: CS_EVENT_PM_RESUME
< hostap_cs: CS_EVENT_CARD_RESET
< wifi0: __hfa384x_cmd_no_wait(6) - timeout - reg=0xf940
< hostap_cs: first command failed - assuming card does not have primary firmware
< new hp status=0
< hostap_cs: assuming no Primary image in flash - card initialization not completed
107c128
< wifi0: cannot get RID fd51 (len=6) - no PRI f/w
---
> new hp status=0
118,126d138
< wifi0: cannot get RID fd51 (len=6) - no PRI f/w
< hostap_cs: CS_EVENT_PM_SUSPEND
< hostap_cs: CS_EVENT_RESET_PHYSICAL
< wifi0: hfa384x_cmd_issue: cmd reg was busy for 5000 usec
< wifi0: hfa384x_cmd_issue - timeout - reg=0xf940
< wifi0: hfa384x_cmd: entry still in list? (entry=c38ebf60, type=0, res=-1)
< wifi0: hfa384x_cmd: interrupted; err=-110
< hostap_cs: Shutdown failed
< pxa_pcmcia_suspend(0)
135,168d146
< wifi0: cannot get RID fd51 (len=6) - no PRI f/w
............ REPEATS ..............
< wifi0: cannot get RID fd51 (len=6) - no PRI f/w
< hostap_cs: CS_EVENT_CARD_REMOVAL
< wifi0: card already removed or not configured during shutdown
< pxa_pcmcia_init(0)
< wifi0: cannot get RID fd51 (len=6) - no PRI f/w
< hostap_crypt: unregistered algorithm 'WEP'
< hostap_cs: Driver unloaded
< hostap_crypt: unregistered algorithm 'NULL' (deinit)


I hope that's what you needed and I did that right. Let me know if there's anything else.

Thanks again!
[span style=\'font-size:11pt;line-height:100%\']C1000 - 4GB SD - Planex CF Wifi
Cacko 1.23
[/font][/span]

Da_Blitz

  • Hero Member
  • *****
  • Posts: 1579
    • View Profile
    • http://www.pocketnix.org
Socket Go Wi-fi! P500
« Reply #10 on: September 22, 2006, 02:30:42 am »
< hostap_cs: CS_EVENT_PM_RESUME
< hostap_cs: CS_EVENT_CARD_RESET
< wifi0: __hfa384x_cmd_no_wait(6) - timeout - reg=0xf940
< hostap_cs: first command failed - assuming card does not have primary firmware
< new hp status=0
< hostap_cs: assuming no Primary image in flash - card initialization not completed
107c128
< wifi0: cannot get RID fd51 (len=6) - no PRI f/w

note how it mentions there is no primary firmware, ethire it has to be loaded or somthing else

if you can see if you can get it swapped as it sounds like writing a script to load the firmware is somthing you dont want to do
Personal Blog
Code
Twitter

Gemini Order: #95 (roughly)
Current Device: Samsung Chromebook Gen 3
Current Arm Devices Count: ~30
Looking to acquire: Cavium Thunder X2 Hardware