Author Topic: Newbie Questions  (Read 4730 times)

Wildherb

  • Jr. Member
  • **
  • Posts: 92
    • View Profile
Newbie Questions
« on: October 04, 2006, 11:54:43 am »
As a previous pdaXrom user I'm trying out the latest version of GPE on my C3000. There is much about it that I like, it is clear and fast and comes with many of my favourite security apps such as dsniff and driftnet. However, and sorry if there are lots of questions here:

Why wont Kismet work with my Ambicom wireless card? In kismet.conf I've set the source=hostap,eth0,hostapsource.

Is there an easy way to store different wireless profiles? I want one called "home" and one called "train" for using the Wireless on the trains and one for RF Monitor mode sniffing. pdaXrom made this very easy and I cant believe you have to go into a GUI to redefine the settings for eth0 every time you connect to a different network.

Has anybody got bluetooth to a GPRS phone working?

Is there a version of ethereal or even tethereal?

Has anybody tried running debian under GPE ? (this would enable me to get my missing apps)

Can I install X11 packages from pdaXrom feeds? I know they still use the older kernel so is there backward compatability?

On a lighter note,
Why does supertux not run?
Are there versions of frozen-bubble and tuxpaint?

Thanks in advance for any help.
C3000 running OpenBSD 4.4
C3100 running OpenZaurus

Wildherb

  • Jr. Member
  • **
  • Posts: 92
    • View Profile
Newbie Questions
« Reply #1 on: October 05, 2006, 03:05:00 am »
To answere a couple of my own questions,

Wifi profiles can be setup
http://wiki.openzaurus.org/HowTos/WifiMultipleProfiles

and ethereal appeared in the feed in the last few days and appears to work just fine. Thanks.
http://ewi546.ewi.utwente.nl/mirror/www.op.../feed/upgrades/
C3000 running OpenBSD 4.4
C3100 running OpenZaurus

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Newbie Questions
« Reply #2 on: October 05, 2006, 05:27:09 am »
Quote
Why does supertux not run?

Any output to strerr?


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Newbie Questions
« Reply #3 on: October 05, 2006, 10:17:39 am »
Quote
Can I install X11 packages from pdaXrom feeds? I know they still use the older kernel so is there backward compatability?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=143065\"][{POST_SNAPBACK}][/a][/div]

I installed multi-aterm and it works like a charm, although OZ is missing some fonts so the displayed font is smaller but it works nicely otherwise.

not all packages will work because oz is lacking certain libraries
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Newbie Questions
« Reply #4 on: October 05, 2006, 11:04:17 am »
Quote
not all packages will work because oz is lacking certain libraries

Which ones? Let us know and we can see what we need to add, or point to you to the correct package to install.


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

Wildherb

  • Jr. Member
  • **
  • Posts: 92
    • View Profile
Newbie Questions
« Reply #5 on: October 08, 2006, 06:11:25 am »
I'm re-installing my apps to an SD card as there is not much space in root but this is taking a very long time (slower memory?) and I'm taking care to do an ipkg-link add for each package. Here is what I get when I try to run kismet. Has anybody got kismet working or is there a version of wellenreiter? There must be some way for GPE users to sniff out wireless networks!

Code: [Select]
root@spitz:~# kismet
Server options:  none
Client options:  none
Starting server...
Waiting for server to start before starting UI...
*** glibc detected *** /usr/bin/kismet_server: double free or corruption (!prev): 0x000c2968 ***
======= Backtrace: =========
/lib/libc.so.6[0x40245f18]
/usr/bin/kismet_server[0x8cea4]
/lib/libc.so.6(__libc_start_main+0xbc)[0x401fbc10]
======= Memory map: ========
00008000-000ae000 r-xp 00000000 fe:01 8152       /media/card/usr/bin/kismet_server
000b6000-000b8000 rw-p 000a6000 fe:01 8152       /media/card/usr/bin/kismet_server
000b8000-000e3000 rwxp 000b8000 00:00 0          [heap]
40000000-40019000 r-xp 00000000 03:01 17995      /lib/ld-2.3.90.so
4001c000-4001e000 rw-p 4001c000 00:00 0
40020000-40022000 rw-p 00018000 03:01 17995      /lib/ld-2.3.90.so
40022000-4003b000 r-xp 00000000 fe:01 10156      /media/card/usr/lib/libuClibc++.so.0.1.9
4003b000-40042000 ---p 00019000 fe:01 10156      /media/card/usr/lib/libuClibc++.so.0.1.9
40042000-40044000 rw-p 00018000 fe:01 10156      /media/card/usr/lib/libuClibc++.so.0.1.9
40044000-40048000 rw-p 40044000 00:00 0
40048000-40114000 r-xp 00000000 fe:01 10145      /media/card/usr/lib/libstdc++.so.6.0.3
40114000-4011b000 ---p 000cc000 fe:01 10145      /media/card/usr/lib/libstdc++.so.6.0.3
4011b000-40121000 rw-p 000cb000 fe:01 10145      /media/card/usr/lib/libstdc++.so.6.0.3
40121000-40127000 rw-p 40121000 00:00 0
40127000-401cb000 r-xp 00000000 03:01 17992      /lib/libm-2.3.90.so
401cb000-401d2000 ---p 000a4000 03:01 17992      /lib/libm-2.3.90.so
401d2000-401d4000 rw-p 000a3000 03:01 17992      /lib/libm-2.3.90.so
401d4000-401dd000 r-xp 00000000 03:01 18019      /lib/libgcc_s.so.1
401dd000-401e4000 ---p 00009000 03:01 18019      /lib/libgcc_s.so.1
401e4000-401e5000 rw-p 00008000 03:01 18019      /lib/libgcc_s.so.1
401e5000-402e8000 r-xp 00000000 03:01 17988      /lib/libc-2.3.90.so
402e8000-402ef000 ---p 00103000 03:01 17988      /lib/libc-2.3.90.so
402ef000-402f0000 r--p 00102000 03:01 17988      /lib/libc-2.3.90.so
402f0000-402f4000 rw-p 00103000 03:01 17988      /lib/libc-2.3.90.so
402f4000-402f6000 rw-p 402f4000 00:00 0
bec2e000-bec43000 rwxp bec2e000 00:00 0          [stack]
[1] + Aborted                    ${BIN}/kismet_server --silent ${server}
root@spitz:~#
C3000 running OpenBSD 4.4
C3100 running OpenZaurus

mimeca

  • Hero Member
  • *****
  • Posts: 682
    • View Profile
    • http://www.innerzaurus.com
Newbie Questions
« Reply #6 on: October 08, 2006, 07:31:46 am »
Is there GPE version of kismet? I think it's only a QT app.
Nunca hagas de un lugar tu hogar. Construye tu hogar en el interior de tu propia cabeza. Encontrare¡s todo lo que necesites para amueblarla: recuerdos, amigos en los que puedes confiar, pasión por el conocimiento y otras cosas por el estilo. De esa forma podrás ir a donde te vayas. Nunca te faltará un hogar..., a menos que pierdas la cabeza, claro...

Innerzaurus => www.innerzaurus.com (Spanish Zaurus Site)

Wildherb

  • Jr. Member
  • **
  • Posts: 92
    • View Profile
Newbie Questions
« Reply #7 on: October 08, 2006, 08:53:50 am »
Quote
Is there GPE version of kismet? I think it's only a QT app.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=143439\"][{POST_SNAPBACK}][/a][/div]

I dont think so. Kismet is a console application so it shouldnt matter which GUI is being run. I do recall trying a previous version of GPE and  I'm sure Kismet ran on that. I've now tried an oder version from the GPE feeds but still no luck, and I cant get the pdaXrom version to install, GPE keeps trying to upgrade it.

So I'm stuck!  I cant even get the prsimstumbler/aeriel programs to work. Has anybody got wireless network sniffing working in any way?
C3000 running OpenBSD 4.4
C3100 running OpenZaurus

Wildherb

  • Jr. Member
  • **
  • Posts: 92
    • View Profile
Newbie Questions
« Reply #8 on: October 08, 2006, 04:30:25 pm »
Quote
Quote
Is there GPE version of kismet? I think it's only a QT app.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=143439\"][{POST_SNAPBACK}][/a][/div]

I dont think so. Kismet is a console application so it shouldnt matter which GUI is being run. I do recall trying a previous version of GPE and  I'm sure Kismet ran on that. I've now tried an oder version from the GPE feeds but still no luck, and I cant get the pdaXrom version to install, GPE keeps trying to upgrade it.

So I'm stuck!  I cant even get the prsimstumbler/aeriel programs to work. Has anybody got wireless network sniffing working in any way?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=143447\"][{POST_SNAPBACK}][/a][/div]

I've found that copying the airodump binary from the aircrack suite to /usr/bin/ on the Z appears to work.Remove the .txt extension if you want to use it.

airodump eth0 /dev/null

This shows that all the low-level stuff is working fine, I'm just disappointed that all the GUI s seem not to work. My only problem with airodump is that it over-wrap the terminal window. Is there a way to add a horizontal scroll bar to the terminal window?

I will continue to try to find a more usable solution for sniffing out wireless network as the rest of GPE is very nice indeed!
C3000 running OpenBSD 4.4
C3100 running OpenZaurus

Wildherb

  • Jr. Member
  • **
  • Posts: 92
    • View Profile
Newbie Questions
« Reply #9 on: October 08, 2006, 06:07:06 pm »
Quote
Quote
Can I install X11 packages from pdaXrom feeds? I know they still use the older kernel so is there backward compatability?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=143065\"][{POST_SNAPBACK}][/a][/div]

I installed multi-aterm and it works like a charm, although OZ is missing some fonts so the displayed font is smaller but it works nicely otherwise.

not all packages will work because oz is lacking certain libraries
[div align=\"right\"][a href=\"index.php?act=findpost&pid=143200\"][{POST_SNAPBACK}][/a][/div]

Thanks Meanie, I've had trouble with some of the packages but by changing the .ipk to a .gz and unzipping them I can copy the binaries which appear to work nicely.

Multi-aterm is a very handy app. Do you know if there is any way to change the font sizes, they are just a little small for my eyesight.
C3000 running OpenBSD 4.4
C3100 running OpenZaurus

Wildherb

  • Jr. Member
  • **
  • Posts: 92
    • View Profile
Newbie Questions
« Reply #10 on: October 15, 2006, 06:50:02 pm »
Quote
Why wont Kismet work with my Ambicom wireless card? In kismet.conf I've set the source=hostap,eth0,hostapsource.


[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

I conclude that the ipk in the feed is just rubbish.

However, the ipk from the pdaXrom feed can be made to work and it does work beatifully! [a href=\"http://mail.pdaxrom.org/download/1.1.0beta3/Zaurus-Cxx00/feed/kismet_2005.08.r1_armv5tel.ipk]http://mail.pdaxrom.org/download/1.1.0beta...r1_armv5tel.ipk[/url] Download it and change the ipk extension to gz and uncompress it . Then uncompress the "data" file and copy the files within it  to the /usr/bin, /usr/etc and /usr/share directories on the Zaurus respectively.

There are one or two more tricks to make it run.
Kismet must be run from a non-root account. You can make one using adduser. Mine is called auditor. So, I must run kismet from /home/auditor. I have an Ambicom CF card so I edit /usr/etc/kismet.conf:

suiduser=auditor
source=hostap,eth0,hostapsource

Works like magic! If anybody can tell me how to make an ipk that installs on OZ then I'll  be happy to package it all up. Enjoy!
C3000 running OpenBSD 4.4
C3100 running OpenZaurus

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Newbie Questions
« Reply #11 on: October 16, 2006, 05:19:13 am »
Quote
I conclude that the ipk in the feed is just rubbish.

Could you add a bug for that to the OE bugtracker then please.

Also attach your error output, etc.


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

koen

  • Hero Member
  • *****
  • Posts: 1008
    • View Profile
    • http://dominion.thruhere.net/koen/cms/
Newbie Questions
« Reply #12 on: October 16, 2006, 05:50:23 am »
Please don't encourage people to mix softfpa and softvfp binaries.
Forums are not bugtrackers!!! Smart questions
Ångström release team
iPAQ h2210, iPAQ h5550, iPAQ hx4700, Zaurus SL-C700, Nokia 770, all running some form of GPE
My blog

..bk..

  • Newbie
  • *
  • Posts: 16
    • View Profile
    • http://
Newbie Questions
« Reply #13 on: October 16, 2006, 12:14:46 pm »
Quote
I'm re-installing my apps to an SD card as there is not much space in root but this is taking a very long time (slower memory?) and I'm taking care to do an ipkg-link add for each package. Here is what I get when I try to run kismet. Has anybody got kismet working or is there a version of wellenreiter? There must be some way for GPE users to sniff out wireless networks!

Code: [Select]
root@spitz:~# kismet
Server options:  none
Client options:  none
Starting server...
Waiting for server to start before starting UI...
*** glibc detected *** /usr/bin/kismet_server: double free or corruption (!prev): 0x000c2968 ***
======= Backtrace: =========
/lib/libc.so.6[0x40245f18]
/usr/bin/kismet_server[0x8cea4]
/lib/libc.so.6(__libc_start_main+0xbc)[0x401fbc10]
======= Memory map: ========
00008000-000ae000 r-xp 00000000 fe:01 8152       /media/card/usr/bin/kismet_server
000b6000-000b8000 rw-p 000a6000 fe:01 8152       /media/card/usr/bin/kismet_server
000b8000-000e3000 rwxp 000b8000 00:00 0          [heap]
40000000-40019000 r-xp 00000000 03:01 17995      /lib/ld-2.3.90.so
4001c000-4001e000 rw-p 4001c000 00:00 0
40020000-40022000 rw-p 00018000 03:01 17995      /lib/ld-2.3.90.so
40022000-4003b000 r-xp 00000000 fe:01 10156      /media/card/usr/lib/libuClibc++.so.0.1.9
4003b000-40042000 ---p 00019000 fe:01 10156      /media/card/usr/lib/libuClibc++.so.0.1.9
40042000-40044000 rw-p 00018000 fe:01 10156      /media/card/usr/lib/libuClibc++.so.0.1.9
40044000-40048000 rw-p 40044000 00:00 0
40048000-40114000 r-xp 00000000 fe:01 10145      /media/card/usr/lib/libstdc++.so.6.0.3
40114000-4011b000 ---p 000cc000 fe:01 10145      /media/card/usr/lib/libstdc++.so.6.0.3
4011b000-40121000 rw-p 000cb000 fe:01 10145      /media/card/usr/lib/libstdc++.so.6.0.3
40121000-40127000 rw-p 40121000 00:00 0
40127000-401cb000 r-xp 00000000 03:01 17992      /lib/libm-2.3.90.so
401cb000-401d2000 ---p 000a4000 03:01 17992      /lib/libm-2.3.90.so
401d2000-401d4000 rw-p 000a3000 03:01 17992      /lib/libm-2.3.90.so
401d4000-401dd000 r-xp 00000000 03:01 18019      /lib/libgcc_s.so.1
401dd000-401e4000 ---p 00009000 03:01 18019      /lib/libgcc_s.so.1
401e4000-401e5000 rw-p 00008000 03:01 18019      /lib/libgcc_s.so.1
401e5000-402e8000 r-xp 00000000 03:01 17988      /lib/libc-2.3.90.so
402e8000-402ef000 ---p 00103000 03:01 17988      /lib/libc-2.3.90.so
402ef000-402f0000 r--p 00102000 03:01 17988      /lib/libc-2.3.90.so
402f0000-402f4000 rw-p 00103000 03:01 17988      /lib/libc-2.3.90.so
402f4000-402f6000 rw-p 402f4000 00:00 0
bec2e000-bec43000 rwxp bec2e000 00:00 0          [stack]
[1] + Aborted                    ${BIN}/kismet_server --silent ${server}
root@spitz:~#
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]


the kismet package from the upgrades feed is broken since being linked to _two_ different c++ libs instead of just one. i put a notice in the 3.5.4.x upgrades thread to ask hrw to rebuild it. in the meantime you can use my homebuilt kismet package located [a href=\"http://www2.informatik.hu-berlin.de/~beier/code/kismet_2006-04-R1-r0_arm.ipk]here[/url]. this is only temporary till the package in the official upgrades feed is fixed...

EDIT: this is now fixed in the upgrades feed, thanks hrw!
« Last Edit: October 19, 2006, 07:33:04 pm by ..bk.. »