Author Topic: Want Compiled Thread?  (Read 156729 times)

Capn_Fish

  • Hero Member
  • *****
  • Posts: 2342
    • View Profile
    • http://
Want Compiled Thread?
« Reply #150 on: February 15, 2007, 12:48:21 pm »
Quote
Quote
I will try that.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=154255\"][{POST_SNAPBACK}][/a][/div]

Thanks, now I can spend some time with my wife this evening, she'll thank you a miliion times.  
[div align=\"right\"][a href=\"index.php?act=findpost&pid=154267\"][{POST_SNAPBACK}][/a][/div]
Always glad to help out!  
SL-C750- pdaXrom beta 1 (mostly unused)
Current distro: Gentoo

tovarish

  • Sr. Member
  • ****
  • Posts: 297
    • View Profile
Want Compiled Thread?
« Reply #151 on: February 16, 2007, 03:13:37 am »
can someone try and compile qemu atleast to enable linux usermode x86 emulation. While i was using sharp rom i could use mathematica 5.2 for linux on my zaurus. I have an idea that we can use it to run opera for linux because it comes in a nice static package.
I tried it with a cross compiler but it seems difficult. Maybe you need to do on board compilation and I dont have the resources to do that (no hdd).

tovarish
« Last Edit: February 16, 2007, 03:31:51 am by tovarish »

Capn_Fish

  • Hero Member
  • *****
  • Posts: 2342
    • View Profile
    • http://
Want Compiled Thread?
« Reply #152 on: February 16, 2007, 10:42:53 am »
My impression is that QEMU would be useless on the Z. Anybody care to back this up or disprove it? I'd be happy to compile it if there was a point.
SL-C750- pdaXrom beta 1 (mostly unused)
Current distro: Gentoo

tovarish

  • Sr. Member
  • ****
  • Posts: 297
    • View Profile
Want Compiled Thread?
« Reply #153 on: February 16, 2007, 10:49:06 am »
it is sometimes useful to run software which is only released on i386 linux (skype, opera, mathematica, flashplayer etc.)
It is fine though i saw that the 0.6.1 version made for sharp roms also works in pdaxrom.

Capn_Fish

  • Hero Member
  • *****
  • Posts: 2342
    • View Profile
    • http://
Want Compiled Thread?
« Reply #154 on: February 16, 2007, 10:59:25 am »
You've tried this?
SL-C750- pdaXrom beta 1 (mostly unused)
Current distro: Gentoo

tovarish

  • Sr. Member
  • ****
  • Posts: 297
    • View Profile
Want Compiled Thread?
« Reply #155 on: February 16, 2007, 04:17:44 pm »
yeah i tried it. I run mathematica with it.
I also tried compiling qemu but it id not such an easy job

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
Want Compiled Thread?
« Reply #156 on: February 16, 2007, 04:29:57 pm »
In case anyone's interested, I found the sharp *.ipk version here: (Japanese site, version 0.6.1-1)
http://tbox.jpn.org/wiki/linuzau/wiki.cgi?...eb%a5%c9%2fQEMU

Source here:
http://fabrice.bellard.free.fr/qemu/download.html
(version 0.9.0)
« Last Edit: February 16, 2007, 04:33:03 pm by Jon_J »
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers

radiochickenwax

  • Full Member
  • ***
  • Posts: 158
    • View Profile
Want Compiled Thread?
« Reply #157 on: February 16, 2007, 06:18:08 pm »
If anyone would care to give it a try, I'd really like to see SciLab compiled for pdax.

http://www.scilab.org/

It needs fortran to build,  so it's pretty difficult.  The x86 cross-compiler

http://distro.ibiblio.org/pub/linux/distri...Zaurus-7x0-860/

has fortran support,   but it's  a little sketchy, and it since SciLab is an interpreter, the make files generate a lot of code that needs to be run natively.  AFAIK, there's no native support for fortran in pdaxrom yet.

I recompiled gcc3.4.5 for zaurus with fortran support, but I'm having trouble getting the resulting libgcc to work with everything else, and I don't really want to have to recompile *everything* just to get fortran working.
« Last Edit: February 16, 2007, 06:20:46 pm by radiochickenwax »
ZAURII:    sl-6000 : (temporarily) bricked pdaxrom b1   ||   sl-c3200 : yonggun/Debian-EABI
OTHERS:  htc-excalibur,  axim x5,  ipaq 4355, (still trying to find useable linux setups)
thinking about gumstix to replace/augment zaurus

radiochickenwax

  • Full Member
  • ***
  • Posts: 158
    • View Profile
Want Compiled Thread?
« Reply #158 on: February 16, 2007, 06:20:13 pm »
Quote
yeah i tried it. I run mathematica with it.
I also tried compiling qemu but it id not such an easy job
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

Was mathematica actually useful in this manner?  i.e. comparable to maxima?  I'd really like to be able to run MATLAB on Zaurus if at all possible.  Did you try MATLAB in qemu?  

Quote
In case anyone's interested, I found the sharp *.ipk version here: (Japanese site, version 0.6.1-1)
[a href=\"http://tbox.jpn.org/wiki/linuzau/wiki.cgi?LinuxZaurus%b8%fe%a4%b1%a5%d3%a5%eb%a5%c9%2fQEMU]http://tbox.jpn.org/wiki/linuzau/wiki.cgi?...eb%a5%c9%2fQEMU[/url]

Source here:
http://fabrice.bellard.free.fr/qemu/download.html
(version 0.9.0)
[div align=\"right\"][a href=\"index.php?act=findpost&pid=154427\"][{POST_SNAPBACK}][/a][/div]

Does this work in pdaxrom?
ZAURII:    sl-6000 : (temporarily) bricked pdaxrom b1   ||   sl-c3200 : yonggun/Debian-EABI
OTHERS:  htc-excalibur,  axim x5,  ipaq 4355, (still trying to find useable linux setups)
thinking about gumstix to replace/augment zaurus

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
Want Compiled Thread?
« Reply #159 on: February 16, 2007, 06:34:18 pm »
I don't know enough about it to try it.
I thought it would be interesting to get Opera running in pdaxrom with qemu, as mentioned above in this thread. post #154
The same person said the sharp version runs in pdaxrom.
I extracted the only file in the sharp 0.6.1 IPK (qemu-i386 is the file)
It was located here: /opt/QtPalmtop/bin/
Since it's the only file in this IPK, maybe it will work in pdaxrom.
I had to zip it to attach it.

Also I thought it would be s good idea to get this hard-to-find file before the website with sharp related stuff disappears.

EDIT: for completeness sake, here's the sharp IPK
« Last Edit: February 16, 2007, 07:15:22 pm by Jon_J »
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers

radiochickenwax

  • Full Member
  • ***
  • Posts: 158
    • View Profile
Want Compiled Thread?
« Reply #160 on: February 16, 2007, 06:40:41 pm »
[edited]
You're right they did say they got it to run in pdax...  guess I gotta try this.
« Last Edit: February 16, 2007, 06:47:20 pm by radiochickenwax »
ZAURII:    sl-6000 : (temporarily) bricked pdaxrom b1   ||   sl-c3200 : yonggun/Debian-EABI
OTHERS:  htc-excalibur,  axim x5,  ipaq 4355, (still trying to find useable linux setups)
thinking about gumstix to replace/augment zaurus

T3_slider

  • Full Member
  • ***
  • Posts: 125
    • View Profile
Want Compiled Thread?
« Reply #161 on: February 16, 2007, 10:40:35 pm »
I would be eternally greatful if someone could compile RasMol (version 2.6 is located here: ftp://marlin.bio.umass.edu/pub/shareware/...sMol26b2.tar.gz - see this page: http://www.umass.edu/microbio/rasmol/getras.htm#rasmol ). I gave it a shot, but it failed (I've never compild an app on the Zaurus before, although I have compiled some apps, including this one, on a Slackware PC).

It doesn't have a configure script, so it has to be done manually (see the INSTALL file), but I'm getting an error when I manually alter the Makefile and rasmol.h files.

I will continue to try again later if no one else does it. If someone else does compile it, however, I would love to know how you did it for future reference (and because I need practice).
Conics SL-C3200 running pdaXrom beta3 and XFCE with a Planex WiFi CF card.

Slackware rules!

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Want Compiled Thread?
« Reply #162 on: February 17, 2007, 12:44:09 am »
Quote
I would be eternally greatful if someone could compile RasMol (version 2.6 is located here: ftp://marlin.bio.umass.edu/pub/shareware/...sMol26b2.tar.gz - see this page: http://www.umass.edu/microbio/rasmol/getras.htm#rasmol ). I gave it a shot, but it failed (I've never compild an app on the Zaurus before, although I have compiled some apps, including this one, on a Slackware PC).

It doesn't have a configure script, so it has to be done manually (see the INSTALL file), but I'm getting an error when I manually alter the Makefile and rasmol.h files.

I will continue to try again later if no one else does it. If someone else does compile it, however, I would love to know how you did it for future reference (and because I need practice).
[div align=\"right\"][a href=\"index.php?act=findpost&pid=154474\"][{POST_SNAPBACK}][/a][/div]

your Makefile looks ok, the problem is in the rasmol.c file. it uses struct fd_set which is not necessary in linux since it is already using typedef.

so just replace all occurances of struct fd_set with just fd_set and off you go...
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

Ling

  • Sr. Member
  • ****
  • Posts: 350
    • View Profile
    • http://
Want Compiled Thread?
« Reply #163 on: February 17, 2007, 10:32:08 am »
Quote
I need the driver for my USB ethernet dongle. There has been some discussion here before so I am not the only one that has one and needs the driver. It is a Davicom Semiconductor Inc DM9601 based device. The driver is available for download at:

http://www.davicom.com.tw/eng/download/Dri...driver_9601.htm

I need it compiled for pdaXii13 5.2. Thanks for any assistance.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=152638\"][{POST_SNAPBACK}][/a][/div]

I am now running pdaXii13 5.3. My ethernet adapter is worthless without the driver. Without it I have to keep dragging my laptop around. Don't mean to be a pest, but would appreciate if someone could compile this driver. If you search the forum, you will notice that there are a couple of threads on this chipset, so obviously I am not the only one that needs it. Thanks.
SL-C3200 w/ pdaXii13 5.3
SL-C860 w/ OZ GPE 3.4.1
Accessories: 4GB Microdrive, 4GB Transcend SD, Linksys WFC12 CF 802.11b, Ambicom CF Modem, Socket Bluetooth

Capn_Fish

  • Hero Member
  • *****
  • Posts: 2342
    • View Profile
    • http://
Want Compiled Thread?
« Reply #164 on: February 17, 2007, 11:26:28 am »
Quote
Quote
I need the driver for my USB ethernet dongle. There has been some discussion here before so I am not the only one that has one and needs the driver. It is a Davicom Semiconductor Inc DM9601 based device. The driver is available for download at:

http://www.davicom.com.tw/eng/download/Dri...driver_9601.htm

I need it compiled for pdaXii13 5.2. Thanks for any assistance.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=152638\"][{POST_SNAPBACK}][/a][/div]

I am now running pdaXii13 5.3. My ethernet adapter is worthless without the driver. Without it I have to keep dragging my laptop around. Don't mean to be a pest, but would appreciate if someone could compile this driver. If you search the forum, you will notice that there are a couple of threads on this chipset, so obviously I am not the only one that needs it. Thanks.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=154509\"][{POST_SNAPBACK}][/a][/div]
I just got my C750 up and running again with Beta 3, so I'll try to compile it today. Sorry about forgetting, but I even got so far as downloading the code, then didn't have a 2.4.x machine to compile on.
SL-C750- pdaXrom beta 1 (mostly unused)
Current distro: Gentoo