Author Topic: Akita To Xp ... Are You There?  (Read 3285 times)

Armagon

  • Full Member
  • ***
  • Posts: 106
    • View Profile
    • http://
Akita To Xp ... Are You There?
« on: November 18, 2006, 11:31:14 am »
I'm wondering how to move data between my Akita (C1000) and a Windows XP box (such as those used at work.)

TCP/IP over USB

It appears that TCP/IP over USB not working with a C1000 and XP is a known issue:

Quote
The Cxx00 doesn't talk to Windows correctly yet. Richard Purdie "has some hints" which should make it work but he hasn't had time to implement them yet. :-/
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

Mass storage device

It appears to me that the mass storage device doesn't work without [a href=\"https://www.oesf.org/forums/index.php?showtopic=20291&view=findpost&p=134792]patching the kernel[/url], and that's really not something I want to do.  [I did play around with trying to modprobe g_file_storage with different devices, including a special file, as described here, but my PCs (running Linux or Win XP) weren't happy about it, and continually reset the usb connection.  [I can add more details if it helps.]]

Other alternatives

Sigh.  My SD card is ext2 formatted and running an altbooted GPE; I don't have a CF card.

... Wait a second ... I have a FAT formatted SD card in my camera ... and sure enough, I can write to it from my Z!  [Wow, using that to transfer data does rather strike me as (almost) ... abusing ... the camera!]

Well, that's probably easier than trying to force my 500 mA max USB to serial port converter to work (not to mention the fact that it means I don't need to make a null-modem cable) (although, perversely, if I had the time, I think I'd give it a try.  Surely normal communications use nowhere near 500 mA!  I just posted another question finding out if it is safe to use or not.)

The only other option (barring really esoteric things like playing back and recording data encoded in audio) I could see was IRDA, and my Z is the only device that uses it.  [Hmm... Still want to try to make it work as a TV remote control...]  And no, I don't have any bluetooth or wifi hardware at all.

Questions

My questions, then: am I right that the first two options do not currently work (and are they being addressed? -- ack... I didn't see them in the bugtracker.  Is there a guide for writing up OE bugs anywhere, or shall I just wing it?), and, um, was there any communication option that I've overlooked that might work for me.

Thank you,
Armagon
Sharp Zaurus SL-C1000 -- 2 GB SD Card -- Zippy Slim Mini Keyboard -- Loving pdaXii13!

deluxe

  • Full Member
  • ***
  • Posts: 186
    • View Profile
Akita To Xp ... Are You There?
« Reply #1 on: November 19, 2006, 11:29:21 am »
What about sending the data as a file attachment via email to somewhere like google: think the workaround was/is called Gstore or somesuch....
http://www.debian-administration.org/articles/198

Otherwise, why not just reformat a FAT partition for transfers onto your SD card and use that?
Neill Currie
Hillsborough
Nh, USA.
---------
SL-C3100, Cacko "heavy" ROM.
SL-C1000, Cacko "heavy" ROM.
A SL-5500 with TKrom.
Ambicom and Symbol CF wifi, 8gb Seagate Microdrive, <4gb Transcend SD. Assorted other digital detritus.
---------
Owner of a Nokia n810 Internet Tablet.
Also a Nokia n800, and a 4th generation iPod Touch.
---------

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Akita To Xp ... Are You There?
« Reply #2 on: November 20, 2006, 08:09:13 am »
If there's no bug then they are probably not being addressed. Many/most of the devs don't have a Windows box, so they may not even know about it.

I'm interested, but don't have a PXA270 machine. See this thread for a link to a possible patch: https://www.oesf.org/forums/index.php?showt...ndpost&p=143173

I'm not sure what RP's thoughts are on it, but posting a bug and mailing list question may provide more info.


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

Armagon

  • Full Member
  • ***
  • Posts: 106
    • View Profile
    • http://
Akita To Xp ... Are You There?
« Reply #3 on: November 21, 2006, 11:33:46 pm »
Quote
What about sending the data as a file attachment via email to somewhere like google: think the workaround was/is called Gstore or somesuch....
http://www.debian-administration.org/articles/198

Otherwise, why not just reformat a FAT partition for transfers onto your SD card and use that?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=146660\"][{POST_SNAPBACK}][/a][/div]

Wow.  That's really neat that I could mount gmail space under linux.  Very cool.  E-mailing data from home is certainly a possibility on some occasions.

I've wondered about having a FAT partition.  Do PCs like to work with partitioned cards? The biggest problem is that I can't safely remove the card without unmounting it, and I don't believe that you can unmount a card that you are altbooting off of ... well, not without shutting the Z off.  (Not just suspending, but actually powering down.)
Sharp Zaurus SL-C1000 -- 2 GB SD Card -- Zippy Slim Mini Keyboard -- Loving pdaXii13!

Armagon

  • Full Member
  • ***
  • Posts: 106
    • View Profile
    • http://
Akita To Xp ... Are You There?
« Reply #4 on: November 23, 2006, 12:29:26 am »
Quote
If there's no bug then they are probably not being addressed. Many/most of the devs don't have a Windows box, so they may not even know about it.

I'm interested, but don't have a PXA270 machine. See this thread for a link to a possible patch: https://www.oesf.org/forums/index.php?showt...ndpost&p=143173

I'm not sure what RP's thoughts are on it, but posting a bug and mailing list question may provide more info.


Si
[div align=\"right\"][a href=\"index.php?act=findpost&pid=146713\"][{POST_SNAPBACK}][/a][/div]

Thanks, Lardman.  Writing up those bugs is on my todo list, and with any luck I'll be able to scrounge up the time to do it on Saturday.   Would the mailing list you had in mind be the openzaurus-devel@lists.sf.net list?

Armagon
Sharp Zaurus SL-C1000 -- 2 GB SD Card -- Zippy Slim Mini Keyboard -- Loving pdaXii13!

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Akita To Xp ... Are You There?
« Reply #5 on: November 23, 2006, 05:01:52 am »
Yes, OpenZaurus-devel would be a good start. Some iPAQs also have PXA270 processors iirc, so it's not necessarily going to be confined to Zaurus only, but the openzaurus list is a good place to start.

Adding a bug to http://bugs.openembedded.org will get exposure to all of the groups using OE and may turn up some ideas/fixes


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

Armagon

  • Full Member
  • ***
  • Posts: 106
    • View Profile
    • http://
Akita To Xp ... Are You There?
« Reply #6 on: November 26, 2006, 02:38:39 am »
Quote
Yes, OpenZaurus-devel would be a good start. Some iPAQs also have PXA270 processors iirc, so it's not necessarily going to be confined to Zaurus only, but the openzaurus list is a good place to start.

Adding a bug to http://bugs.openembedded.org will get exposure to all of the groups using OE and may turn up some ideas/fixes


Si
[div align=\"right\"][a href=\"index.php?act=findpost&pid=147036\"][{POST_SNAPBACK}][/a][/div]


I wrote up bugs 1619 and 1621, and have sent an e-mail to the OZ dev list.

Armagon
Sharp Zaurus SL-C1000 -- 2 GB SD Card -- Zippy Slim Mini Keyboard -- Loving pdaXii13!