Author Topic: SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script  (Read 17703 times)

n8a

  • Full Member
  • ***
  • Posts: 235
    • View Profile
    • http://
SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script
« Reply #15 on: March 15, 2004, 12:18:09 am »
Doug -

- Go to Zaurus Downloads from the Home page
- type \"prep-home\" in the search box

The first item to appear from the search should be the file.

agosine

  • Full Member
  • ***
  • Posts: 123
    • View Profile
SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script
« Reply #16 on: March 15, 2004, 11:34:28 am »
Derekp, I\'ve found a bug with this new async IO kernel.  With your kernel I found that I cound not get my NPC card to work correctly.  It detected it fine, but the Network Connection icon in the taskbar would never come up.  Going back to the old kernel this works no problem.
SL5500 running nothing.  Will not hold a charge.  =(
C1000 running Sharp ROM

n8a

  • Full Member
  • ***
  • Posts: 235
    • View Profile
    • http://
SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script
« Reply #17 on: March 15, 2004, 12:01:47 pm »
Quote
Derekp, I\'ve found a bug with this new async IO kernel. With your kernel I found that I cound not get my NPC card to work correctly. It detected it fine, but the Network Connection icon in the taskbar would never come up. Going back to the old kernel this works no problem.

As I indicated as well, when I install the Bluez driver ipk with the async kernel (as opposed to the kernel that accompanies the latest tkcROM release), I get errors with the serial_cs module.  So I, too, had to abort my use of the kernel

Xaser

  • Newbie
  • *
  • Posts: 35
    • View Profile
    • http://
SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script
« Reply #18 on: March 15, 2004, 05:18:00 pm »
Hello revdjenk!

Here is the link that you ask...
http://www.zaurususergroup.com/modules.php...wdownload&cid=5

Im trying it by now, but is unsatble, after a reset, the filesystem crash, in had my Z5500 on stand by in hope that the fix for this unstable behavoir could be found....  Sadly,  I cant help toomuch because Im not a programer...

Best regards and luck!

Xaser
..: X :......Zaurus SL5500
....: A :......Proto TKCrom 1
......: S :......Cacko Async Kernel
........: E :......Lexar SD128mb
..........: R :......Targus 56k modem

Joshp

  • Sr. Member
  • ****
  • Posts: 265
    • View Profile
    • http://
SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script
« Reply #19 on: March 15, 2004, 05:41:55 pm »
Ok, coulde some please tell me what a \"NPC card\" is.  Am assumeing that it is a wirless card and or blue touth.  Now I have been using the async kernel since before it was posted.  I have yet to have any problumes (that i did not couse).  And form what I understand CONFIG_FS_SYNC forces the kernel to sync during wirites.  Now how this affects a network and or blue touth card, am not sure.  As for the serial_cs module I have goten errors on a 2.4.18 kernel on my laptop.  By the way could someone please tell me what a Bluez driver is for.

JP

n8a

  • Full Member
  • ***
  • Posts: 235
    • View Profile
    • http://
SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script
« Reply #20 on: March 15, 2004, 05:50:02 pm »
joshp - I can\'t answer your question regarding the NPC card, but I had the problems with my bluetooth card.  Namely, with tkcROM 2.0alpha3 I have not had any problems with getting the bluetooth card Bluez drivers to work properly.  However, just after installing the ASYNCIO kernel, when I tried to install the same Bluez driver I have the errors that I mentioned in a previous thread with the serial_cs module.  Once I switched back to the normal tkcROM zImage and flashed, the Bluez driver install did not cause any errors again.

Again, I\'m not sure what\'s causing the problems, but since the only variable that I changed was the kernel I must guess that it is causing the issue.  If anybody has any ideas on some good testing/possible resolutions to try, please let me know-

Nate

agosine

  • Full Member
  • ***
  • Posts: 123
    • View Profile
SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script
« Reply #21 on: March 15, 2004, 10:02:04 pm »
Joshp - Its a Network Phone Card (NPC) by Aerlink (actually Socket) the connects to cell phones and creates a serial interface similar to what a bluetooth card does.

n8a - I have a feeling our problems are one in the same as my card must be using the serial_cs module.  I\'m just not sure how to validate this though.  One difference is that mine installs without error.  Maybe someone can find a fix in this module.  Or is there another one floating around that I haven\'t yet tried?
?
SL5500 running nothing.  Will not hold a charge.  =(
C1000 running Sharp ROM

n8a

  • Full Member
  • ***
  • Posts: 235
    • View Profile
    • http://
SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script
« Reply #22 on: March 15, 2004, 11:14:27 pm »
Quote
n8a - I have a feeling our problems are one in the same as my card must be using the serial_cs module. I\'m just not sure how to validate this though. One difference is that mine installs without error. Maybe someone can find a fix in this module. Or is there another one floating around that I haven\'t yet tried?  
?

This is kinda the blind leading the blind, but if you want to find out if there are errors with the module:

# modprobe serial_cs

When I do that (see my old post in this thread), it outputs a bunch of error messages.  I\'m trying to learn more about the modules, testing/changing them, the custom kernels, etc., but there\'s just so much to learn!

revdjenk

  • Newbie
  • *
  • Posts: 48
    • View Profile
    • http://
SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script
« Reply #23 on: March 16, 2004, 01:52:00 pm »
thanks all!
I was searching in the wrong places!
God Bless
Doug

These are the words of him who has the Sharp...
Revelation 2:12

derekp

  • Full Member
  • ***
  • Posts: 154
    • View Profile
SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script
« Reply #24 on: March 19, 2004, 02:25:15 pm »
Quote
Any ideas here, Derek?  I\'d like to get this working, but replacing the existing driver with another copy of serial_cs.o that I have (then doing a depmod -a and modprobe) did not seem to work, so I\'m off to the original tkcROM zImage for now...

Sorry it took a while for me to get back to you on this on, I was out of town for a few days.
It looks like the serial driver is compiled into the tkc kernel.  When I compiled the async io kernel, I left most of the config options set to default, which ends up putting the serial driver as a module.
I\'ve attached the serail.o module, try insmoding this one before loading up your serial_cs.o modules and let me know if it works.

Anyone else who\'s having similar errors (symbol not found), let me know, and I\'ll add those modules to my list of ones that need to be compiled into the kernel.

Joshp

  • Sr. Member
  • ****
  • Posts: 265
    • View Profile
    • http://
SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script
« Reply #25 on: March 19, 2004, 03:31:56 pm »
Hey Derek Would you mind sending me your .config file for you async kernel.

thanks
JP

agosine

  • Full Member
  • ***
  • Posts: 123
    • View Profile
SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script
« Reply #26 on: March 19, 2004, 03:45:01 pm »
derekp - Sorry, my understanding of Linux isn\'t as great as I would like, but I\'m learning.  How do I use your serial.o module?
SL5500 running nothing.  Will not hold a charge.  =(
C1000 running Sharp ROM

n8a

  • Full Member
  • ***
  • Posts: 235
    • View Profile
    • http://
SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script
« Reply #27 on: March 19, 2004, 04:19:35 pm »
thanks, derek.  I\'ll have to try it after my vacation, as I\'m leaving for Lake Tahoe and I have everything working as I need it now.  Not a good time to start testing things out, unfortunately...

I will try it with your async-io kernel first, then with the home on SD along with that kernel.

Another thing too, Derek - I reloaded the tkcROM 2.0 alpha3 zimage and initrd.bin, and then simply tried out the home on SD without the asyncio kernel but with the -f option.  For some reason, each time I would reboot, it would give a TON of error messages, which would last about 5-10 minutes.  Then, finally it would boot up.  I don\'t know if you\'ve encountered that, but it made reboots brutal.  If you haven\'t experienced that, then perhaps it was something that I did (it was a while ago, so I dont\' fully remember unfortunately).

agosine

  • Full Member
  • ***
  • Posts: 123
    • View Profile
SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script
« Reply #28 on: March 22, 2004, 12:29:26 am »
Woohoo, the serial.o fix works great!  And I got it to load automatically when serial_cs.o loads by modifying the modules.dep file.
SL5500 running nothing.  Will not hold a charge.  =(
C1000 running Sharp ROM

Xaser

  • Newbie
  • *
  • Posts: 35
    • View Profile
    • http://
SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script
« Reply #29 on: March 22, 2004, 11:27:26 am »
Hello!
Well, about the async kernel,I have the same trouble but with my modem, this is the issues:
1) My Targus Pocket Modem 56k v.90 works fine with others roms but with the async it had the same bug, I made the settings but no connections icon appears, only appears the icon if I made an IR dialup connection BUT in that case, DONT appears the modem connection and only appears the IR Dialup connection.
2) The IR dialup connection works fine, so, please maintain it working when fix the other connections issues.

But, all around the async kernel with home on sd are GREAT!...  so, thanks very much to all the good people that are making it working!

Best regards!
..: X :......Zaurus SL5500
....: A :......Proto TKCrom 1
......: S :......Cacko Async Kernel
........: E :......Lexar SD128mb
..........: R :......Targus 56k modem