Author Topic: Can't Restore Backups On Sl-c3100  (Read 1350 times)

Capn_Fish

  • Hero Member
  • *****
  • Posts: 2342
    • View Profile
    • http://
Can't Restore Backups On Sl-c3100
« on: January 23, 2007, 03:04:50 pm »
I can't restore backups on my 3100.

I tried to reinstall r121 with uBoot, but that wasn't working, so I erased the NAND figuring I'd just have to reinstall uBoot first. I forgot about needing the Sharp bootloader. I downloaded the backup from Conics and tried to restore it, but I get a "net exist file." I tried freshly formatting my SD card with FAT on Windows, not FAT32. I got the same error with TRISoft's backup. What else can I try?

Thanks!
SL-C750- pdaXrom beta 1 (mostly unused)
Current distro: Gentoo

TRIsoft

  • Sr. Member
  • ****
  • Posts: 332
    • View Profile
    • http://www.trisoft.de
Can't Restore Backups On Sl-c3100
« Reply #1 on: January 24, 2007, 04:24:10 am »
Hi Capn_Fish,

"not exist file" means that the Zaurus doesn't see
the needed ".dbk" file on the card.

- is the filename systc310.dbk ?
- is it placed in the root directory ?
- if you try to restore from SD, is the CF slot empty ?

For NAND operations, the Zaurus will check the CF slot
first. If there's a card inserted, the Zaurus will not look
at the SD card.

Also, there're cards, that run well under normal
conditions, but won't let you do a NAND restore.

Try another card, preferably a CF card (but never use
a MicroDrive for NAND restore or flash updates).

///TRIsoft

Marc Stephan

Capn_Fish

  • Hero Member
  • *****
  • Posts: 2342
    • View Profile
    • http://
Can't Restore Backups On Sl-c3100
« Reply #2 on: January 24, 2007, 07:44:10 am »
Quote
Hi Capn_Fish,

"not exist file" means that the Zaurus doesn't see
the needed ".dbk" file on the card.

- is the filename systc310.dbk ?
- is it placed in the root directory ?
- if you try to restore from SD, is the CF slot empty ?

For NAND operations, the Zaurus will check the CF slot
first. If there's a card inserted, the Zaurus will not look
at the SD card.

Also, there're cards, that run well under normal
conditions, but won't let you do a NAND restore.

Try another card, preferably a CF card (but never use
a MicroDrive for NAND restore or flash updates).

///TRIsoft

Marc Stephan
[div align=\"right\"][a href=\"index.php?act=findpost&pid=152219\"][{POST_SNAPBACK}][/a][/div]

The file is named SYSTC310.DBK, and it is in the root directory. This card has worked numerous times for backups/restores before, and I have no CF card plugged in when attempting to to the restore. Unfortunately, the only CF card I have is a microdrive.

The file capitalization is supposed to be SYSTC310.DBK, correct? I tried changing it to lower case, but it didn't work either.

Thanks for your response, and if you have any other ideas, please let me know. I'll go try my SD card from my camera and see if that one works.
SL-C750- pdaXrom beta 1 (mostly unused)
Current distro: Gentoo

speculatrix

  • Administrator
  • Hero Member
  • *****
  • Posts: 3703
    • View Profile
Can't Restore Backups On Sl-c3100
« Reply #3 on: January 24, 2007, 10:07:17 am »
have you got the partition problem - use "fdisk -l" on the Z when its running and check there's a partition table on it.

if there's no partition, windows will quite happily create a file system across the whole card, rather than create a partition and then format it
Gemini 4G/Wi-Fi owner, formerly zaurus C3100 and 860 owner; also owner of an HTC Doubleshot, a Zaurus-like phone.

speculatrix

  • Administrator
  • Hero Member
  • *****
  • Posts: 3703
    • View Profile
Can't Restore Backups On Sl-c3100
« Reply #4 on: January 24, 2007, 10:07:42 am »
p.s. you can also do this with a linux desktop and card reader.
Gemini 4G/Wi-Fi owner, formerly zaurus C3100 and 860 owner; also owner of an HTC Doubleshot, a Zaurus-like phone.

Capn_Fish

  • Hero Member
  • *****
  • Posts: 2342
    • View Profile
    • http://
Can't Restore Backups On Sl-c3100
« Reply #5 on: January 24, 2007, 01:43:41 pm »
That just may be it...I'll go check.
SL-C750- pdaXrom beta 1 (mostly unused)
Current distro: Gentoo

Capn_Fish

  • Hero Member
  • *****
  • Posts: 2342
    • View Profile
    • http://
Can't Restore Backups On Sl-c3100
« Reply #6 on: January 24, 2007, 02:02:27 pm »
It looks like it may have lacked a partition table with Windows and may have been formatted wrong with the table. I'm trying a correctly formatted, correctly partitioned card from my camera, I'll see if that works.
SL-C750- pdaXrom beta 1 (mostly unused)
Current distro: Gentoo

Capn_Fish

  • Hero Member
  • *****
  • Posts: 2342
    • View Profile
    • http://
Can't Restore Backups On Sl-c3100
« Reply #7 on: January 24, 2007, 02:08:15 pm »
OK, it looks like my SD card was/is messed up, as the one from the camera works fine. I'll need to fix the formatting, I guess.

Thanks for your help! I was worried that something might have been wrong with my Z.  
« Last Edit: January 24, 2007, 02:08:36 pm by Capn_Fish »
SL-C750- pdaXrom beta 1 (mostly unused)
Current distro: Gentoo

speculatrix

  • Administrator
  • Hero Member
  • *****
  • Posts: 3703
    • View Profile
Can't Restore Backups On Sl-c3100
« Reply #8 on: January 25, 2007, 11:52:57 am »
Quote
OK, it looks like my SD card was/is messed up, as the one from the camera works fine. I'll need to fix the formatting, I guess.

Thanks for your help! I was worried that something might have been wrong with my Z. 
[div align=\"right\"][a href=\"index.php?act=findpost&pid=152275\"][{POST_SNAPBACK}][/a][/div]

I discovered this when I used the Z's backup HDD option in the D+M menu, and it tried to copy 4GB hard drive over the top of a 512MB flash card and it trashed the partition table (I think it simply wrapped the block counters). I put the card into a windows box, it said it was an invalid volume, and I formatted it. Worked fine in windows, but wouldn't automount in Z, but I could mount the "root" device, and then discovered the lack of partition.

I think that in theory using CF card should be more reliable than using an SD card for reflashing.

I recall borrowing a friend's CF card to reflash my 6000, and despite promising to restore its contents after use, had cocked up the backup and when I tried to restore it the tar.gz file was empty
Luckily he'd copied *most* of the photos off it
Gemini 4G/Wi-Fi owner, formerly zaurus C3100 and 860 owner; also owner of an HTC Doubleshot, a Zaurus-like phone.