Author Topic: Hsdpa Modem ?  (Read 41171 times)

craigtyson

  • Sr. Member
  • ****
  • Posts: 462
    • View Profile
Hsdpa Modem ?
« Reply #15 on: August 08, 2007, 09:08:01 am »
I get cannot open /dev/ttyUSB0: no such device.

I have loaded usbserial with vendor=0x12d1 product=0x1003
which works on myUBUNTU laptop? Any ideas?
Craig
SL-C1000, Angstrom GPE 2007.12r13
Ambicom WL1100C, SanDisk UltraII 1GB SD
 
Old Faithfull - SL-5500 battery out of the C750 (see below) TKC v1 (New) 1GB SD
Dead - SL-C750, Cacko 1.23 lite (Dropped, very messy!)
Ambicom WL1100C, SanDisk Dead - 1GB SD
Keep your Z on a bungee, you never know.....

sdjf

  • Sr. Member
  • ****
  • Posts: 447
    • View Profile
    • http://www.sdjf.wordpress.com and http://www.sdjf.esmartdesign.com
Hsdpa Modem ?
« Reply #16 on: August 08, 2007, 07:45:49 pm »
Quote
I get cannot open /dev/ttyUSB0: no such device.

I have loaded usbserial with vendor=0x12d1 product=0x1003
which works on myUBUNTU laptop? Any ideas?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=165937\"][{POST_SNAPBACK}][/a][/div]

How about running 'lsmod' to confirm your Z recognizes the module?  You might need one compiled specific for your hardware.  Did you already do that?

sdjf
http://www.sdjf.esmartdesign.com
http://www.sdjf.wordpress.com
-----------------
sl5500 running Sharp ROM 2.38 (dead batteries)
sl6000L running Sharp ROM 1.12 (still working)
Opera 7.25 and 7.30
Socket CF 56k modem
3Com USB Ethernet Adapter
Toshiba, Lexar and Kingston SD cards
Lexar, Kingston and Transcend CF cards

craigtyson

  • Sr. Member
  • ****
  • Posts: 462
    • View Profile
Hsdpa Modem ?
« Reply #17 on: August 09, 2007, 03:46:58 am »
lsusb lists nothing.  I think I assumed as there was a ttyUSB0 the e220 had been recogniesed.

I did some testing last night with a GPRS Motorola phone that my UBUNTU laptop sees as a generic USB modem.  The Z finds it shows it as a device in systeminfo, but I cannot see which device its using again ttyUSB0 cannot be found.

Unfortunatly, I have no idea where to start compiling my own driver fr the Z.  Though I have compiled stuff on my laptop for the e220 to make it stable and usable.
Craig
SL-C1000, Angstrom GPE 2007.12r13
Ambicom WL1100C, SanDisk UltraII 1GB SD
 
Old Faithfull - SL-5500 battery out of the C750 (see below) TKC v1 (New) 1GB SD
Dead - SL-C750, Cacko 1.23 lite (Dropped, very messy!)
Ambicom WL1100C, SanDisk Dead - 1GB SD
Keep your Z on a bungee, you never know.....

craigtyson

  • Sr. Member
  • ****
  • Posts: 462
    • View Profile
Hsdpa Modem ?
« Reply #18 on: August 09, 2007, 05:48:14 am »
Update.  I think there is an issue with my USB support.  I can mount USB Drives even my mobile phone micro SD.  But nothing else.  I have tried two mice, both are "seen" in systeminfo, but the icon has a warning triangle as if the driver is not loaded, and the UsbMouse applet does not find a mouse mousedev not found?

Any Ideas what I've messed up?
Craig
SL-C1000, Angstrom GPE 2007.12r13
Ambicom WL1100C, SanDisk UltraII 1GB SD
 
Old Faithfull - SL-5500 battery out of the C750 (see below) TKC v1 (New) 1GB SD
Dead - SL-C750, Cacko 1.23 lite (Dropped, very messy!)
Ambicom WL1100C, SanDisk Dead - 1GB SD
Keep your Z on a bungee, you never know.....

sdjf

  • Sr. Member
  • ****
  • Posts: 447
    • View Profile
    • http://www.sdjf.wordpress.com and http://www.sdjf.esmartdesign.com
Hsdpa Modem ?
« Reply #19 on: August 09, 2007, 10:43:00 am »
You didn't say if you did an lsmod, which lists all modules.

Do you mean the Z recognized  ttyUSB0?  Did you look at /etc/fstab?  And which of your Z's are you doing this on?  I can say from experience that drivers for one Z won't necessarily work for another model of Z.  And the sl5500 is known to not have a USB host controller, so a module alone won't do it on the collie if that's where you are trying.

Capn_Fish only does pdaXrom stuff, but maybe he would know where to get module source code.

sdjf
http://www.sdjf.esmartdesign.com
http://www.sdjf.wordpress.com
-----------------
sl5500 running Sharp ROM 2.38 (dead batteries)
sl6000L running Sharp ROM 1.12 (still working)
Opera 7.25 and 7.30
Socket CF 56k modem
3Com USB Ethernet Adapter
Toshiba, Lexar and Kingston SD cards
Lexar, Kingston and Transcend CF cards

craigtyson

  • Sr. Member
  • ****
  • Posts: 462
    • View Profile
Hsdpa Modem ?
« Reply #20 on: August 09, 2007, 11:05:02 am »
All this is on a C1000 with cacko 1.23 lite.  I dont have access to my Z at the mo, but will do some posts when I get back to it.

C
Craig
SL-C1000, Angstrom GPE 2007.12r13
Ambicom WL1100C, SanDisk UltraII 1GB SD
 
Old Faithfull - SL-5500 battery out of the C750 (see below) TKC v1 (New) 1GB SD
Dead - SL-C750, Cacko 1.23 lite (Dropped, very messy!)
Ambicom WL1100C, SanDisk Dead - 1GB SD
Keep your Z on a bungee, you never know.....

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
Hsdpa Modem ?
« Reply #21 on: August 09, 2007, 12:03:31 pm »
Do you have any extra modules installed that have "lite" in their filename?
Look in the cacko feed for this file or similar files with "lite" in their name.
usb-serial-modules-2.4.20_1.23-lite-1_arm.ipk

Any file with "lite" in the filename, are "missing" in cacko lite, and need to be installed if needed.

Sorry if you already know this, it' just a suggestion.

Jon
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers

craigtyson

  • Sr. Member
  • ****
  • Posts: 462
    • View Profile
Hsdpa Modem ?
« Reply #22 on: August 09, 2007, 12:17:49 pm »
I cought onto that and installed

usb-camera-modules-2.4.20 1.23-lite
usb-network-modules-2.4.20 1.23-lite
usb-serial-modules-2.4.20 1.23-lite
usb-storage-modules-2.4.20 1.23-lite

before starting

Cheers
« Last Edit: August 09, 2007, 12:18:12 pm by craigtyson »
Craig
SL-C1000, Angstrom GPE 2007.12r13
Ambicom WL1100C, SanDisk UltraII 1GB SD
 
Old Faithfull - SL-5500 battery out of the C750 (see below) TKC v1 (New) 1GB SD
Dead - SL-C750, Cacko 1.23 lite (Dropped, very messy!)
Ambicom WL1100C, SanDisk Dead - 1GB SD
Keep your Z on a bungee, you never know.....

speculatrix

  • Administrator
  • Hero Member
  • *****
  • Posts: 3703
    • View Profile
Hsdpa Modem ?
« Reply #23 on: August 09, 2007, 01:46:10 pm »
hmmm. are you plugging the usb device directly into the Z or using an external hub with a separate power supply? I've seen a few times when a usb device only partly functions if there's not enough power
Gemini 4G/Wi-Fi owner, formerly zaurus C3100 and 860 owner; also owner of an HTC Doubleshot, a Zaurus-like phone.

craigtyson

  • Sr. Member
  • ****
  • Posts: 462
    • View Profile
Hsdpa Modem ?
« Reply #24 on: August 09, 2007, 07:04:19 pm »
all with no hub.  My aim is to use the e220 0n the move.  As it draws little power (less than my phone which works - the phone also charges on usb) and all the lights flash as if the e220 is up I thing (hope) it will work.

OK lsmod with phone in storage mode (no issues)-
Module                  Size  Used by
usb-storage            64400   1
usb_ohci_pxa27x        21680   0 (unused)
usbcore                59216   1 [usb-storage usb_ohci_pxa27x]
hostap_crypt_wep        3616   1
hostap_cs              48064   2
hostap                 98272   0 [hostap_crypt_wep hostap_cs]
pxa_bi                 24848   0 (unused)
storage_fd            100368   0 (unused)
usbdcore               35504   0 [pxa_bi storage_fd]
bluez                  33216   0 (autoclean)
sd_mod                 11296   2 (autoclean)
scsi_mod               56800   2 [usb-storage sd_mod]
registers              52288   0 (unused) usbdmonitor             5488   0
usb-monitor             6496   0
sharp_mmcsd_m          41008   2
bvdd                   11136   0    

lsmod for phone in modem mode :-

Module                  Size  Used by
acm                     5856   0 (unused)
usb-storage            64400   0
usb_ohci_pxa27x        21680   0 (unused)
usbcore                59216   1 [acm usb-storage usb_ohci_pxa27x]
hostap_crypt_wep        3616   1
hostap_cs              48064   2
hostap                 98272   0 [hostap_crypt_wep hostap_cs]
pxa_bi                 24848   0 (unused)
storage_fd            100368   0 (unused)
usbdcore               35504   0 [pxa_bi storage_fd]
bluez                  33216   0 (autoclean)
sd_mod                 11296   0 (autoclean)
scsi_mod               56800   2 [usb-storage sd_mod]
registers              52288   0 (unused)
usbdmonitor             5488   0
usb-monitor             6496   0
sharp_mmcsd_m          41008   2
bvdd                   11136   0  

I hope that if I can get the phone to work as a modem then getting the e220 to work woud just be a case of reloading usbserial (which is how it works on UBUNTU)

C
Craig
SL-C1000, Angstrom GPE 2007.12r13
Ambicom WL1100C, SanDisk UltraII 1GB SD
 
Old Faithfull - SL-5500 battery out of the C750 (see below) TKC v1 (New) 1GB SD
Dead - SL-C750, Cacko 1.23 lite (Dropped, very messy!)
Ambicom WL1100C, SanDisk Dead - 1GB SD
Keep your Z on a bungee, you never know.....

craigtyson

  • Sr. Member
  • ****
  • Posts: 462
    • View Profile
Hsdpa Modem ?
« Reply #25 on: August 21, 2007, 05:53:03 am »
OK been doing some research, the e220 has some strange driver requirments that needs patching on older kernals so this is not a good buy for a Zaurus.  Here's a link to a patch for those of you wanting to run the e220 on an older linux x86 laptop http://oozie.fm.interia.pl/pro/huawei-e220/#WORKAROUND
 It may be that someone who knows how to hack this could get it up and running on the Z I can hope ;0)

C
Craig
SL-C1000, Angstrom GPE 2007.12r13
Ambicom WL1100C, SanDisk UltraII 1GB SD
 
Old Faithfull - SL-5500 battery out of the C750 (see below) TKC v1 (New) 1GB SD
Dead - SL-C750, Cacko 1.23 lite (Dropped, very messy!)
Ambicom WL1100C, SanDisk Dead - 1GB SD
Keep your Z on a bungee, you never know.....

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Hsdpa Modem ?
« Reply #26 on: October 22, 2007, 05:09:20 pm »
Quote from: craigtyson
OK been doing some research, the e220 has some strange driver requirments that needs patching on older kernals so this is not a good buy for a Zaurus.  Here's a link to a patch for those of you wanting to run the e220 on an older linux x86 laptop http://oozie.fm.interia.pl/pro/huawei-e220/#WORKAROUND
 It may be that someone who knows how to hack this could get it up and running on the Z I can hope ;0)

C

this says that e220 should work on kernel > 2.6.19 !
so perhaps you should try under modern zaurus distros like Angstrom or Debian !
let's give it a try and tell us about it ! please!!!!!!!
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Hsdpa Modem ?
« Reply #27 on: October 26, 2007, 12:46:26 pm »
any news about huawei e220 on the zaurus ?
i'm really about to buy it and use a portable battery powered usb hub ! that should work ,hu ?
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

craigtyson

  • Sr. Member
  • ****
  • Posts: 462
    • View Profile
Hsdpa Modem ?
« Reply #28 on: October 27, 2007, 07:37:18 pm »
No such luck.

It works great on my UBUNTU laptop, but no joy on the Z

C
Craig
SL-C1000, Angstrom GPE 2007.12r13
Ambicom WL1100C, SanDisk UltraII 1GB SD
 
Old Faithfull - SL-5500 battery out of the C750 (see below) TKC v1 (New) 1GB SD
Dead - SL-C750, Cacko 1.23 lite (Dropped, very messy!)
Ambicom WL1100C, SanDisk Dead - 1GB SD
Keep your Z on a bungee, you never know.....

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Hsdpa Modem ?
« Reply #29 on: October 29, 2007, 03:04:55 am »
Quote from: craigtyson
No such luck.

It works great on my UBUNTU laptop, but no joy on the Z

C

what distro do you have on your zaurus ?and which kernel ?
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun