Author Topic: Justreader Pdaxrom Beta 3, Pdaxii13 Problem  (Read 2230 times)

merli

  • Full Member
  • ***
  • Posts: 227
    • View Profile
    • http://
Justreader Pdaxrom Beta 3, Pdaxii13 Problem
« on: April 03, 2007, 07:22:58 am »
Hello

I have had installed pdaxrom beta1 for long time. Recently I upgraded to pdaxii13 and foud that my e-book application justreader does not want to display palm doc format cp 1250 characters (just does not display anything or square character instead accented char). Same books were workig in pdaxrom beta1 without any problem. I tried also patched wellswang version of justreader with same result. FB reader is working with libiconv and 1250 encoding conv installed but I like justreader much :-). Can somone help me if it is some configuration problem or bug in justreader?

Thnx
merli
------
SL-C1000 - pdaxii13 5.3.3 but considering go back to beta1
Wifi D-link DCF-650W CF card - not using
bluetooth Billionton BT CF card and Samsung SGH-i310 GPRS
Pretec Cheetah 133x 4GB SD, Pretec Cheetah 80x 1GB CF

wellswang

  • Jr. Member
  • **
  • Posts: 78
    • View Profile
    • http://wells.osall.com
Justreader Pdaxrom Beta 3, Pdaxii13 Problem
« Reply #1 on: April 03, 2007, 10:07:36 am »
Quote
Hello

I have had installed pdaxrom beta1 for long time. Recently I upgraded to pdaxii13 and foud that my e-book application justreader does not want to display palm doc format cp 1250 characters (just does not display anything or square character instead accented char). Same books were workig in pdaxrom beta1 without any problem. I tried also patched wellswang version of justreader with same result. FB reader is working with libiconv and 1250 encoding conv installed but I like justreader much :-). Can somone help me if it is some configuration problem or bug in justreader?

Thnx
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157848\"][{POST_SNAPBACK}][/a][/div]

can you send me your e-book file , and a screen snapshot of the file's content (FB reader's result)

I will try to fix this problem ...  

--wells.

merli

  • Full Member
  • ***
  • Posts: 227
    • View Profile
    • http://
Justreader Pdaxrom Beta 3, Pdaxii13 Problem
« Reply #2 on: April 03, 2007, 10:55:35 am »
Quote
Quote
Hello

I have had installed pdaxrom beta1 for long time. Recently I upgraded to pdaxii13 and foud that my e-book application justreader does not want to display palm doc format cp 1250 characters (just does not display anything or square character instead accented char). Same books were workig in pdaxrom beta1 without any problem. I tried also patched wellswang version of justreader with same result. FB reader is working with libiconv and 1250 encoding conv installed but I like justreader much :-). Can somone help me if it is some configuration problem or bug in justreader?

Thnx
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157848\"][{POST_SNAPBACK}][/a][/div]

can you send me your e-book file , and a screen snapshot of the file's content (FB reader's result)

I will try to fix this problem ...  

--wells.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157860\"][{POST_SNAPBACK}][/a][/div]

Here is book and screenshots from FBreader and Justreader

Thnx for helping
merli
------
SL-C1000 - pdaxii13 5.3.3 but considering go back to beta1
Wifi D-link DCF-650W CF card - not using
bluetooth Billionton BT CF card and Samsung SGH-i310 GPRS
Pretec Cheetah 133x 4GB SD, Pretec Cheetah 80x 1GB CF

wellswang

  • Jr. Member
  • **
  • Posts: 78
    • View Profile
    • http://wells.osall.com
Justreader Pdaxrom Beta 3, Pdaxii13 Problem
« Reply #3 on: April 03, 2007, 11:14:33 am »
Quote
Here is book and screenshots from FBreader and Justreader

Thnx for helping
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157868\"][{POST_SNAPBACK}][/a][/div]

Hi Merli,

I think the problem may relate with the font that JR used to display.
can you provide me the font file which used in FB reader ?
Thanks.

(BTW, I must go to bed now ...  )

--Wells.

merli

  • Full Member
  • ***
  • Posts: 227
    • View Profile
    • http://
Justreader Pdaxrom Beta 3, Pdaxii13 Problem
« Reply #4 on: April 03, 2007, 11:44:14 am »
Quote
Quote
Here is book and screenshots from FBreader and Justreader

Thnx for helping
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157868\"][{POST_SNAPBACK}][/a][/div]

Hi Merli,

I think the problem may relate with the font that JR used to display.
can you provide me the font file which used in FB reader ?
Thanks.

(BTW, I must go to bed now ...  )

--Wells.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157871\"][{POST_SNAPBACK}][/a][/div]

Working with Verdana, Times new roman, Curier new, Arial, Lucida Console
Not working with Fixed and Clean,
Serif=Times, Sans=Verdana and Monospaced=Courier.

In Justreader I am using same font names (I think that they are using same files) and it is not working with any
merli
------
SL-C1000 - pdaxii13 5.3.3 but considering go back to beta1
Wifi D-link DCF-650W CF card - not using
bluetooth Billionton BT CF card and Samsung SGH-i310 GPRS
Pretec Cheetah 133x 4GB SD, Pretec Cheetah 80x 1GB CF

wellswang

  • Jr. Member
  • **
  • Posts: 78
    • View Profile
    • http://wells.osall.com
Justreader Pdaxrom Beta 3, Pdaxii13 Problem
« Reply #5 on: April 05, 2007, 09:39:26 am »
Hi Merli,

I found this problem is related with locale settings ($LC_ALL).

The temp solution is using following command to start Justreader:
Code: [Select]
# env LC_ALL=cs_CZ.cp1250 justreader
and then the document will be displayed fine
  [ Invalid Attachment ]