Author Topic: Making Angstrom Work On Tosa  (Read 40599 times)

radiochickenwax

  • Full Member
  • ***
  • Posts: 158
    • View Profile
Making Angstrom Work On Tosa
« on: April 13, 2007, 06:57:19 pm »
Trying to install from the following directions hasn't worked so far.  

http://www.angstrom-distribution.org/zaurus-c7x0-c8x0

I don't recall the errors.  If I find time, I'll post them here, but ideally they'll be working soon.  The following link is where I downloaded the images from.

http://www.angstrom-distribution.org/unsta.../tosa/20070401/

Trying to find a way to boot angstrom led me to the following page, which was simultaneously amusing, and frustrating, since as of yet, this issue is not resolved.

http://lists.linuxtogo.org/pipermail/angst...rch/000089.html

I'm assuming that we're currently working somewhere along the lines of this thread:

http://lists.linuxtogo.org/pipermail/angst...ril/000137.html


As of yet, I still haven't gotten Angstrom to boot.  Any help would be appreciated.
« Last Edit: April 13, 2007, 07:07:40 pm by radiochickenwax »
ZAURII:    sl-6000 : (temporarily) bricked pdaxrom b1   ||   sl-c3200 : yonggun/Debian-EABI
OTHERS:  htc-excalibur,  axim x5,  ipaq 4355, (still trying to find useable linux setups)
thinking about gumstix to replace/augment zaurus

xjqian

  • Sr. Member
  • ****
  • Posts: 497
    • View Profile
    • http://
Making Angstrom Work On Tosa
« Reply #1 on: April 13, 2007, 10:48:37 pm »
Quote
As of yet, I still haven't gotten Angstrom to boot.  Any help would be appreciated.
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

See my message here: [a href=\"http://lists.linuxtogo.org/pipermail/angstrom-distro-devel/2007-April/000156.html]http://lists.linuxtogo.org/pipermail/angst...ril/000156.html[/url]
My Blog | 6000L Tosa + sled | is: Angstrom | was: pdaXrom 1.1.0beta1 | was: stock 1.12 rom + no-ffpe fash kernel + X/Qt Debian |
CF GPS (FGPCFCD01) | USB "Prolific 2303" GPS (USB-UG-200) | Socket CF BT rev. H |  USB "Pegasus II" Ethernet (ADM8511) | PocketTop IR kbd | sip:527630@fwd.pulver.com
Todo: OESF wiki | stable VOIP app | usable GPS app |      Wishlist: VOIP + Bluetooth | GPS + Routing Calc

adf

  • Hero Member
  • *****
  • Posts: 2807
    • View Profile
    • http://
Making Angstrom Work On Tosa
« Reply #2 on: April 13, 2007, 11:05:15 pm »
Quote
Quote
As of yet, I still haven't gotten Angstrom to boot.  Any help would be appreciated.
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

See my message here: [a href=\"http://lists.linuxtogo.org/pipermail/angstrom-distro-devel/2007-April/000156.html]http://lists.linuxtogo.org/pipermail/angst...ril/000156.html[/url]
[div align=\"right\"][a href=\"index.php?act=findpost&pid=158781\"][{POST_SNAPBACK}][/a][/div]
Not entirely encouraging, but I still think this is a good way to go.
**3100 Zubuntu Jaunty,(working on Cacko dualboot), 16G A-Data internal CF, 4G SD, Ambicom WL-1100C Cf, linksys usb ethernet,  BelkinF8T020 BT card, Belkin F8U1500-E Ir kbd, mini targus usb mouse, rechargeble AC/DC powered USB hub, psp cables and battery extenders.

**6000l  Tetsuized Sharprom, installed on internal flash only 1G sd, 2G cf

koen

  • Hero Member
  • *****
  • Posts: 1008
    • View Profile
    • http://dominion.thruhere.net/koen/cms/
Making Angstrom Work On Tosa
« Reply #3 on: April 14, 2007, 06:31:58 am »
Try today's build and report/update bugs in the OE bugtracker
Forums are not bugtrackers!!! Smart questions
Ångström release team
iPAQ h2210, iPAQ h5550, iPAQ hx4700, Zaurus SL-C700, Nokia 770, all running some form of GPE
My blog

adf

  • Hero Member
  • *****
  • Posts: 2807
    • View Profile
    • http://
Making Angstrom Work On Tosa
« Reply #4 on: April 14, 2007, 02:17:49 pm »
Quote
Try today's build and report/update bugs in the OE bugtracker
[div align=\"right\"][a href=\"index.php?act=findpost&pid=158807\"][{POST_SNAPBACK}][/a][/div]
will do tonight or tomorrow. I've got a ton of work to do just now
**3100 Zubuntu Jaunty,(working on Cacko dualboot), 16G A-Data internal CF, 4G SD, Ambicom WL-1100C Cf, linksys usb ethernet,  BelkinF8T020 BT card, Belkin F8U1500-E Ir kbd, mini targus usb mouse, rechargeble AC/DC powered USB hub, psp cables and battery extenders.

**6000l  Tetsuized Sharprom, installed on internal flash only 1G sd, 2G cf

radiochickenwax

  • Full Member
  • ***
  • Posts: 158
    • View Profile
Making Angstrom Work On Tosa
« Reply #5 on: April 14, 2007, 02:44:15 pm »
EDIT:

Posted some pusillanimous "stream of conciousness" stuff here, which might make me look stupid, so here's the reader's digest version:

Make sure to flash OZ/Angstrom from a FAT formatted card, or you will end up with errors.  That was pretty much the source of my problems with getting angstrom to flash.  

The x11 image flashed without error when a FAT formatted card was used to flash.  However,  I'll state again, that GPE in it's current state is not really suitable for my current needs from my zaurus.
« Last Edit: April 22, 2007, 05:26:48 pm by radiochickenwax »
ZAURII:    sl-6000 : (temporarily) bricked pdaxrom b1   ||   sl-c3200 : yonggun/Debian-EABI
OTHERS:  htc-excalibur,  axim x5,  ipaq 4355, (still trying to find useable linux setups)
thinking about gumstix to replace/augment zaurus

xjqian

  • Sr. Member
  • ****
  • Posts: 497
    • View Profile
    • http://
Making Angstrom Work On Tosa
« Reply #6 on: April 22, 2007, 06:04:59 am »
Quote
Try today's build and report/update bugs in the OE bugtracker
[div align=\"right\"][a href=\"index.php?act=findpost&pid=158807\"][{POST_SNAPBACK}][/a][/div]

Angstrom Apr 14 build test image

console image: boots fine (thanks for getting rid of the OE splash screen)

upon resume:  mixed text from dmesg output, previous console input/output, and maybe some output from the suspend/resume scripts, then
...
power.c: device-level power management is not supported yet
power: requesting system suspend ...
power: requesting system suspend ...
usbcore: deregistering driver prism2_usb
_(underscore sign blinking here)

after pressing enter, device frozen (has to reset).

x11 image: boots fine
suspend/resume worked for the first time, then suspend stops working (see attached suspend.txt)
shutdown -r now has no effect or froze the device
 
btw: tested with: 4G SD, 512M CF in hda (socket 1), 8G Microdrive (partitioned as 4G vfat + 4G ext2) in hdc (socket 0). Seems all work fine.
« Last Edit: April 22, 2007, 06:07:53 am by xjqian »
My Blog | 6000L Tosa + sled | is: Angstrom | was: pdaXrom 1.1.0beta1 | was: stock 1.12 rom + no-ffpe fash kernel + X/Qt Debian |
CF GPS (FGPCFCD01) | USB "Prolific 2303" GPS (USB-UG-200) | Socket CF BT rev. H |  USB "Pegasus II" Ethernet (ADM8511) | PocketTop IR kbd | sip:527630@fwd.pulver.com
Todo: OESF wiki | stable VOIP app | usable GPS app |      Wishlist: VOIP + Bluetooth | GPS + Routing Calc

koen

  • Hero Member
  • *****
  • Posts: 1008
    • View Profile
    • http://dominion.thruhere.net/koen/cms/
Making Angstrom Work On Tosa
« Reply #7 on: April 22, 2007, 06:49:58 am »
Quote
Quote
Try today's build and report/update bugs in the OE bugtracker
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

<stuff>

[div align=\"right\"][a href=\"index.php?act=findpost&pid=159500\"][{POST_SNAPBACK}][/a][/div]

The OE bugtracker is at [a href=\"http://bugs.openembedded.org]http://bugs.openembedded.org[/url], not here
Forums are not bugtrackers!!! Smart questions
Ångström release team
iPAQ h2210, iPAQ h5550, iPAQ hx4700, Zaurus SL-C700, Nokia 770, all running some form of GPE
My blog

radiochickenwax

  • Full Member
  • ***
  • Posts: 158
    • View Profile
Making Angstrom Work On Tosa
« Reply #8 on: April 22, 2007, 05:17:10 pm »
Quote
Quote
Quote
Try today's build and report/update bugs in the OE bugtracker
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

<stuff>

[div align=\"right\"][a href=\"index.php?act=findpost&pid=159500\"][{POST_SNAPBACK}][/a][/div]

The OE bugtracker is at [a href=\"http://bugs.openembedded.org]http://bugs.openembedded.org[/url], not here
[div align=\"right\"][a href=\"index.php?act=findpost&pid=159502\"][{POST_SNAPBACK}][/a][/div]


Agreed, this thread is not a bugtracker.  Rather, it is a forum to do more than list bugs.

Would you prefer that no one discuss issues with the angstrom distro outside of the bugtracker and/or wiki?
« Last Edit: April 22, 2007, 05:24:37 pm by radiochickenwax »
ZAURII:    sl-6000 : (temporarily) bricked pdaxrom b1   ||   sl-c3200 : yonggun/Debian-EABI
OTHERS:  htc-excalibur,  axim x5,  ipaq 4355, (still trying to find useable linux setups)
thinking about gumstix to replace/augment zaurus

xjqian

  • Sr. Member
  • ****
  • Posts: 497
    • View Profile
    • http://
Making Angstrom Work On Tosa
« Reply #9 on: April 22, 2007, 07:37:01 pm »
Quote
The OE bugtracker is at http://bugs.openembedded.org, not here
[div align=\"right\"][a href=\"index.php?act=findpost&pid=159502\"][{POST_SNAPBACK}][/a][/div]
I did not have time to submit these bugs last night. I will do it tonight. Just wanted to give a heads up in the forum because looks like only few 6k user are subscribed to the OE mailing list or bugtracker.
My Blog | 6000L Tosa + sled | is: Angstrom | was: pdaXrom 1.1.0beta1 | was: stock 1.12 rom + no-ffpe fash kernel + X/Qt Debian |
CF GPS (FGPCFCD01) | USB "Prolific 2303" GPS (USB-UG-200) | Socket CF BT rev. H |  USB "Pegasus II" Ethernet (ADM8511) | PocketTop IR kbd | sip:527630@fwd.pulver.com
Todo: OESF wiki | stable VOIP app | usable GPS app |      Wishlist: VOIP + Bluetooth | GPS + Routing Calc

koen

  • Hero Member
  • *****
  • Posts: 1008
    • View Profile
    • http://dominion.thruhere.net/koen/cms/
Making Angstrom Work On Tosa
« Reply #10 on: April 23, 2007, 02:49:29 am »
Quote
Quote
Quote
Quote
Try today's build and report/update bugs in the OE bugtracker
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

<stuff>

[div align=\"right\"][a href=\"index.php?act=findpost&pid=159500\"][{POST_SNAPBACK}][/a][/div]

The OE bugtracker is at [a href=\"http://bugs.openembedded.org]http://bugs.openembedded.org[/url], not here
[div align=\"right\"][a href=\"index.php?act=findpost&pid=159502\"][{POST_SNAPBACK}][/a][/div]


Agreed, this thread is not a bugtracker.  Rather, it is a forum to do more than list bugs.

Would you prefer that no one discuss issues with the angstrom distro outside of the bugtracker and/or wiki?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=159523\"][{POST_SNAPBACK}][/a][/div]

I would prefer that people would at least

a) report issues to the bugtracker
 discuss issues at the mailinglists

if you want to summarize things at this forum after that, fine, but there are more *developers* following the bugtrackers and mailinglists than this forum.
Forums are not bugtrackers!!! Smart questions
Ångström release team
iPAQ h2210, iPAQ h5550, iPAQ hx4700, Zaurus SL-C700, Nokia 770, all running some form of GPE
My blog

xjqian

  • Sr. Member
  • ****
  • Posts: 497
    • View Profile
    • http://
Making Angstrom Work On Tosa
« Reply #11 on: April 23, 2007, 05:30:34 am »
bug report submitted: http://bugs.openembedded.org/show_bug.cgi?id=2134
a general report sent to the Angstrom-dev mailing list.
Will test the new image soon.
My Blog | 6000L Tosa + sled | is: Angstrom | was: pdaXrom 1.1.0beta1 | was: stock 1.12 rom + no-ffpe fash kernel + X/Qt Debian |
CF GPS (FGPCFCD01) | USB "Prolific 2303" GPS (USB-UG-200) | Socket CF BT rev. H |  USB "Pegasus II" Ethernet (ADM8511) | PocketTop IR kbd | sip:527630@fwd.pulver.com
Todo: OESF wiki | stable VOIP app | usable GPS app |      Wishlist: VOIP + Bluetooth | GPS + Routing Calc

xjqian

  • Sr. Member
  • ****
  • Posts: 497
    • View Profile
    • http://
Making Angstrom Work On Tosa
« Reply #12 on: April 24, 2007, 02:52:30 am »
just a quick heads-up for people not on the OE mailing/bug list. Right now, the single one stumbling block of Tosa Angstrom is the broken suspend/resume.
My Blog | 6000L Tosa + sled | is: Angstrom | was: pdaXrom 1.1.0beta1 | was: stock 1.12 rom + no-ffpe fash kernel + X/Qt Debian |
CF GPS (FGPCFCD01) | USB "Prolific 2303" GPS (USB-UG-200) | Socket CF BT rev. H |  USB "Pegasus II" Ethernet (ADM8511) | PocketTop IR kbd | sip:527630@fwd.pulver.com
Todo: OESF wiki | stable VOIP app | usable GPS app |      Wishlist: VOIP + Bluetooth | GPS + Routing Calc

undrwater

  • Full Member
  • ***
  • Posts: 232
    • View Profile
    • http://
Making Angstrom Work On Tosa
« Reply #13 on: October 19, 2007, 06:06:44 pm »
Has anyone tried the latest images for Tosa?   My battery should be arriving sometime early next week and I'm interested in flashing.

If not, I'll try and post my general results on the mailing lists, bug tracker, and here.

adf

  • Hero Member
  • *****
  • Posts: 2807
    • View Profile
    • http://
Making Angstrom Work On Tosa
« Reply #14 on: October 19, 2007, 08:18:33 pm »
Quote from: undrwater
Has anyone tried the latest images for Tosa?   My battery should be arriving sometime early next week and I'm interested in flashing.

If not, I'll try and post my general results on the mailing lists, bug tracker, and here.
No, but I'd love to hear how it works.  Is Angstrom anywhere near approaching stable?
**3100 Zubuntu Jaunty,(working on Cacko dualboot), 16G A-Data internal CF, 4G SD, Ambicom WL-1100C Cf, linksys usb ethernet,  BelkinF8T020 BT card, Belkin F8U1500-E Ir kbd, mini targus usb mouse, rechargeble AC/DC powered USB hub, psp cables and battery extenders.

**6000l  Tetsuized Sharprom, installed on internal flash only 1G sd, 2G cf