Author Topic: Spitz.xmodmap Non English  (Read 3146 times)

Raul

  • Full Member
  • ***
  • Posts: 133
    • View Profile
Spitz.xmodmap Non English
« on: July 16, 2007, 06:34:22 am »
I'm trying to change spitz.xmodmap to use polish special letters, but everytime I change keycodes to polish I have a problem.
In Abiword Fn with a letter pull down menu.
In other applications it looks as if I don't use Fn (I do) and there are normal english letters instead.
Any help will be appreciated.

Kind regards,
Raul

shula

  • Jr. Member
  • **
  • Posts: 95
    • View Profile
Spitz.xmodmap Non English
« Reply #1 on: July 16, 2007, 05:29:05 pm »
sorry i don't know.
what i did (hebrew and russian keyb layouts)
i changed the whole keyboard map to totally different letter set.

in case of polish key-set, only 6 or 8 keys need a modifier. hmmm.  
in the "standard" xmodmap there are already keys dedicated to nordic/latin accents, using the Fn. do they work normally for you (i don't have the Z here).

you can try to use them with "shift+..." if something else doesn't work, but then it's not easy to use capitalized letters.
did you try using Ctrl or Alt as modifiers? (like the real polish "programmers" keyboard) ?

i will try myself as well (poczebuje to tez) but it's not that urgent for me so it might take a while.

czesc
C860, pdaxrom rc8,
with Gnumeric as the perfect PIM :-)

Raul

  • Full Member
  • ***
  • Posts: 133
    • View Profile
Spitz.xmodmap Non English
« Reply #2 on: July 17, 2007, 05:33:11 pm »
Yes, latin letters ike german for exaple works. When I change those german letters to polish in spitz.xmodmap I cannot use them with fn. It's really strange. I haven't tried with alt or ctrl because I don't know how.

(Czesc  )

Kind regards,
Raul

Raul

  • Full Member
  • ***
  • Posts: 133
    • View Profile
Spitz.xmodmap Non English
« Reply #3 on: July 27, 2007, 02:58:17 am »
Please, no one is using non-standard letters?

yatza

  • Newbie
  • *
  • Posts: 12
    • View Profile
    • http://
Spitz.xmodmap Non English
« Reply #4 on: August 06, 2007, 03:37:52 pm »
Hi,
I'm using Polish "programmers layout" with pdaxii13 on Akita. Had to remap few symboks to free 'l' and 'e' up. Other than that no problems, Fn+key works ok.

Try to load the keymap manually. Open terminal in X and do 'xmodmap /etc/X11/kb/spitz.xmodmap' (if I remember the path correctly). That should give you Polish keyboard.
If that's the case, make sure your window manager setup calls xmodmap.

Regards,
Yatza

Raul

  • Full Member
  • ***
  • Posts: 133
    • View Profile
Spitz.xmodmap Non English
« Reply #5 on: August 06, 2007, 06:25:00 pm »
I will try that. If nt, could you send me yours xmdmap file to test it?

Thanks in advance.

yatza

  • Newbie
  • *
  • Posts: 12
    • View Profile
    • http://
Spitz.xmodmap Non English
« Reply #6 on: August 07, 2007, 04:30:56 pm »
Attached is the keymap I use. For example symlink it as "spitz.xmodmap" or whatever file your ~/.xinitrc is loading.
« Last Edit: August 07, 2007, 04:33:42 pm by yatza »

Raul

  • Full Member
  • ***
  • Posts: 133
    • View Profile
Spitz.xmodmap Non English
« Reply #7 on: August 08, 2007, 06:35:05 pm »
I wil check that. Maybe my problems are because of deinstalation of scim? I will tell you if it work for me
Thanks

Raul

  • Full Member
  • ***
  • Posts: 133
    • View Profile
Spitz.xmodmap Non English
« Reply #8 on: August 10, 2007, 05:09:47 am »
It doesn't work. I think I will reinstall pdaxii13 and check if it work.