Author Topic: Firefox Just Shuts Off After Several Links...  (Read 3625 times)

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
Firefox Just Shuts Off After Several Links...
« on: October 03, 2007, 04:31:38 pm »
I finally have a working/stable wifi connection in pdaxii13.
I've been using Firefox 1.5.0.2 for the last 3 hours, catching up on pdaxrom threads.
After clicking 3 or 4 threads, firefox will just shut down.
I'm trying to read the threads from pdaxrom page 9 to present, but with firefox shutting down so often, I"m tempted to use my other zaurus and use opera, (which rarely crashes).
Is there a fix for this? I have a swap partition, Is firefox running out of memory?

Thank you for reading this,
Jon
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers

InSearchOf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1144
    • View Profile
    • http://
Firefox Just Shuts Off After Several Links...
« Reply #1 on: October 03, 2007, 05:45:16 pm »
Firefox is VERY buggy... I experience the same when loading SEMI-intense pages.  I hope to make some changes and update it to the lasted for the  next release... but that is if time permits.

Late
Sharp Zaurus SL-C3100 and SL-6000L
pdaXrom Developer
Please visit pdaXrom.org for updates
My Blog
IRC #pdaxrom @ FreeNode

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
Firefox Just Shuts Off After Several Links...
« Reply #2 on: October 03, 2007, 06:06:21 pm »
It was my fault. The first thing I did after setting my preferences was to download and install "Littlefox" theme. This theme is buggy because it installed 2 entries in the theme GUI box. It installed a "real" entry and a "ghost" entry, (which looked different and had a different name).
I also had difficulty removing it because the theme GUI box started crashing firefox soon after this theme got installed. I could not remove the second (ghost) entry of the theme, so I ended up un-installing firefox and re-installing it. I also deleted /home/root/.mozilla and all firefox releted stuff on the drive which I first installed it, before re-installing it.
All seems fine with a fresh install of firefox.
this theme works fine on a desktop running windows.
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers

InSearchOf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1144
    • View Profile
    • http://
Firefox Just Shuts Off After Several Links...
« Reply #3 on: October 03, 2007, 08:51:56 pm »
I'm glad you were able to solve the issue...

But I still would like to update firefox :-)

Late
Sharp Zaurus SL-C3100 and SL-6000L
pdaXrom Developer
Please visit pdaXrom.org for updates
My Blog
IRC #pdaxrom @ FreeNode

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
Firefox Just Shuts Off After Several Links...
« Reply #4 on: October 03, 2007, 09:14:32 pm »
It did crash several more times, but not nearly as often when Littlefox theme was installed.
I would also like to see an update also.
I've used Opera in Cacko for 8 hours or more with no crashes. Too bad there wasn't any more upgrades to it.
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
Firefox Just Shuts Off After Several Links...
« Reply #5 on: October 13, 2007, 02:19:01 pm »
Before I uninstall and re-install firefox, I would like to find out why it crashes so often when reading these forums.
Are there any other versions floating around besides "firefox_1.5.0.2_armv5tel.ipk" ? (8.09 MB)
Is this the one everyone else uses?
When run in a console, I get this error at startup.
Code: [Select]
root-:) firefox
/usr/lib/firefox/bin/firefox: line 113: /bin/ls: No such file or directory

This is the error when firefox crashes.
I'm hoping my Epiphany crashes are also related to this one and if this one can be fixed, both browsers will stop crashing.
Code: [Select]
/usr/lib/firefox/lib/firefox-1.5.0.2/run-mozilla.sh: line 131:  5533 Segmentation fault "$prog" ${1+"$@"}
There is a thread where meanie found a bug in the startup shell script, and my second error is almost exactly as the one in the post below.
The only difference is the error in the post below is "firefox-1.57"
Code: [Select]
/usr/lib/firefox/lib/firefox-1.57run-mozilla.sh: line 131: XXXXX Segmentation fault "$prog" ${1+"$@"}https://www.oesf.org/forum/index.php?s=&...st&p=148079

Edit
I downloaded "firefox_1.5_arm.ipk" for meanie's pdaxqtrom and extracted "run-mozilla.sh" from it and compared this one with the one in "firefox_1.5.0.2_armv5tel.ipk" with a text editor that compares files, and they are identical. I was hoping to find meanie's fix in that older one...
« Last Edit: October 13, 2007, 02:58:37 pm by Jon_J »
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
Firefox Just Shuts Off After Several Links...
« Reply #6 on: October 14, 2007, 12:51:17 pm »
Since firefox and epiphany were giving me so many crashes, I decided to go back and re-flash my C3200 to pdaxii13-5.4.9 Akita on NAND.
I installed rox and firefox, then setup my wifi. I started browsing the forums here and was able to read several posts and browse for about 20 minutes. Then I selected page 30 of pdaxrom, (using the selector for specifying a page number), when the page opened, firefox crashed.
Then I re-opened firefox in a console, and when I clicked my bookmark for oesf forums, the page opened and firefox crashed.
I still get the same errors in the console as in my last post.
I went through a lot of trouble just to try to get firefox to work, and it still doesn't.
I really don't like the other browser selections for pdaxrom, and thought if epiphany worked, I would have the "best" browser for pdaxrom working for me.
Since firefox is crashing all the time, I really doubt that trying epiphany will be any better this time around. (Newly reflashed pdaxii13).
As I have said previously, Opera can be used in cacko for hours and hours without crashing.

Does anyone else experience crashes when using firefox when browsing these forums?
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers

adf

  • Hero Member
  • *****
  • Posts: 2807
    • View Profile
    • http://
Firefox Just Shuts Off After Several Links...
« Reply #7 on: October 14, 2007, 02:18:20 pm »
Quote from: Jon_J
Since firefox and epiphany were giving me so many crashes, I decided to go back and re-flash my C3200 to pdaxii13-5.4.9 Akita on NAND.
I installed rox and firefox, then setup my wifi. I started browsing the forums here and was able to read several posts and browse for about 20 minutes. Then I selected page 30 of pdaxrom, (using the selector for specifying a page number), when the page opened, firefox crashed.
Then I re-opened firefox in a console, and when I clicked my bookmark for oesf forums, the page opened and firefox crashed.
I still get the same errors in the console as in my last post.
I went through a lot of trouble just to try to get firefox to work, and it still doesn't.
I really don't like the other browser selections for pdaxrom, and thought if epiphany worked, I would have the "best" browser for pdaxrom working for me.
Since firefox is crashing all the time, I really doubt that trying epiphany will be any better this time around. (Newly reflashed pdaxii13).
As I have said previously, Opera can be used in cacko for hours and hours without crashing.

Does anyone else experience crashes when using firefox when browsing these forums?
Not that bad, no.

But-- you might try installing Mozilla (it is stable, right?) and using the mozlibs from there instead of firefox to run epiphany.
**3100 Zubuntu Jaunty,(working on Cacko dualboot), 16G A-Data internal CF, 4G SD, Ambicom WL-1100C Cf, linksys usb ethernet,  BelkinF8T020 BT card, Belkin F8U1500-E Ir kbd, mini targus usb mouse, rechargeble AC/DC powered USB hub, psp cables and battery extenders.

**6000l  Tetsuized Sharprom, installed on internal flash only 1G sd, 2G cf

walkman

  • Jr. Member
  • **
  • Posts: 76
    • View Profile
Firefox Just Shuts Off After Several Links...
« Reply #8 on: October 14, 2007, 02:24:26 pm »
Actually, I observed the same problem. What solved it for me was to use swapfile. Try to switch swapfile (using e.g. powerctrl applet, or pdaxii config tool) on and then you FF was quite stable.
Sharp SL-C1000 Akita + D-Link 660W

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
Firefox Just Shuts Off After Several Links...
« Reply #9 on: October 14, 2007, 02:34:07 pm »
I have a 250 MB swap partition, pdaxii13 sets this up for you when installing pdaxii13. I always observe my hard drive light flashing when using firefox.
I looked at the powerctl applet and it looks like it's enabled, but it doesn't seem to be getting used at the moment, I'm going to reboot and see if it's mounting.
When it boots it says "enabling" 2nd partition as swap. It doesn't say "mounting"
-------------------------------------
internal microdrive is /dev/hdc
mounting first partition as /mnt/ide
enabling secod partition as swap
mounting third partition as /data
-------------------------------------

I'll try the pdaxii config tool next.
It shows total swap as 250480kb, but it also shows /mnt/card/swapfile on the panel (I don't have a swapfile on my card, it's on a partition on the HDD)
Maybe with all the different locations for setting up swap (swapfile or swap partition), something is getting confused.
Edit
I was browsing the forums with firefox and looked at my swap in powerctrl. It was at 5%, so this means it was using about 12.5 MB
I clicked a link to a new post and it just shut down, again as usual.
« Last Edit: October 14, 2007, 03:15:56 pm by Jon_J »
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers

desertrat

  • Hero Member
  • *****
  • Posts: 743
    • View Profile
    • http://
Firefox Just Shuts Off After Several Links...
« Reply #10 on: October 14, 2007, 03:42:55 pm »
Quote from: Jon_J
This is the error when firefox crashes.
I'm hoping my Epiphany crashes are also related to this one and if this one can be fixed, both browsers will stop crashing.
Code: [Select]
/usr/lib/firefox/lib/firefox-1.5.0.2/run-mozilla.sh: line 131:  5533 Segmentation fault "$prog" ${1+"$@"}
FWIW whenever I get this error it is usually time to reboot. Sometimes closing down other programs would get rid of that error - I think it might have something to do with shared memory (shm?). I doubt whether it has anything to do with swap (I have plenty of swap).

Sometimes switching between Mozilla (Communicator) and Firefox staves off reboot for a while - both Mozilla and Firefox are prone to that error.
SL-C3100 / Ambicon WL1100C-CF / pdaXrom 1.1.0beta3 / IceWM

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
Firefox Just Shuts Off After Several Links...
« Reply #11 on: October 14, 2007, 08:08:43 pm »
Quote from: adf
Not that bad, no.

But-- you might try installing Mozilla (it is stable, right?) and using the mozlibs from there instead of firefox to run epiphany.
I never heard of mozilla as a browser, I thought mozilla was firefox's parent company, like GM makes chevrolet.
You learn something new every day.
I completely removed all traces of firefox from my Z and installed mozilla 1.7.12
I have been searching and reading posts about mozilla for over an hour here on the forum without one single crash!
Mozilla browser is more like a real browser, in that you can store the cache anywhere you want. When going back to a previous page, mozilla browser uses a real cache and doesn't need to re-download the page thru my slow 'b' wifi connection.
It also has a mail client and you can store your mail data annywhere you want, just like the browser cache.
Compaired to firefox, installed size is 33 MB, firefox is 25 MB
Mozilla includes mail/newsgroups, chat, composer, address book, and a browser. cool.
I don't know why anyone would not want to use it on pdaxrom.
Page loading seems a bit slower than newer browsers, but I think it's much faster to surf with a browser that doesn't crash every 4-5 minutes, and needs to be re-launched.
I posted this in mozilla browser.
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers

desertrat

  • Hero Member
  • *****
  • Posts: 743
    • View Profile
    • http://
Firefox Just Shuts Off After Several Links...
« Reply #12 on: October 14, 2007, 11:31:50 pm »
Quote from: Jon_J
I never heard of mozilla as a browser, I thought mozilla was firefox's parent company, like GM makes chevrolet.
You must have joined the party late  Mozilla Communicator is based off the old Netscape Communicator - AOL bought Netscape and after several years of neglect decided to setup the Mozilla Foundation and open up the Communicator code. Netscape was one of the unwilling participants in the so-called "browser wars" in which M$ used its illegally gotten and maintained monopoly to force an inferior browser and the greatest cause of malware onto the desktops of the mindless windoze using sheep. This led to the trial in which M$ was convicted of illegally abusing its monopoly and one of the proposed punishments was the breaking up of M$. Unfortunately the Bush dictatorship came along and the "Justice" Department, flush with campaign funds from M$, decided that M$ could instead extend its monopoly even further by "giving" away "millions of dollars" worth of software to schools and other institutes.

Quote
... but I think it's much faster to surf with a browser that doesn't crash every 4-5 minutes, and needs to be re-launched.
Just so you know, you will run into the segfault problem sooner or later
SL-C3100 / Ambicon WL1100C-CF / pdaXrom 1.1.0beta3 / IceWM

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
Firefox Just Shuts Off After Several Links...
« Reply #13 on: October 15, 2007, 02:39:08 am »
I noticed that mozilla 1.7.12 is too old to utilize "my.yahoo" page. it won't even allow me to use the older version of "my.yahoo"
I usually check this page for news and TV listings.

Edit Update:
I think I may have firefox working now, but I haven't launched it since I re-installed it in this thread.
I'm more concerned with having a "working" Epiphany browser, and don't want to "first launch" firefox because it writes to some files and sets itself up.
https://www.oesf.org/forum/index.php?showtopic=24858
See post 9
https://www.oesf.org/forum/index.php?s=&...st&p=169178
« Last Edit: October 17, 2007, 11:24:56 am by Jon_J »
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers