Author Topic: Abicom Vs Hostap [solved]  (Read 3552 times)

e.stoiber

  • Newbie
  • *
  • Posts: 9
    • View Profile
Abicom Vs Hostap [solved]
« on: October 14, 2007, 04:35:37 pm »
hi,

I followed the guide for installing without a network connection.

Now i fail at my wireless setup !

Everytime i insert my ambicom card the hostap driver gets loaded even after i put them into
/etc/modprobe.d/blacklist

I tried this with kernel 2.6.17 and 2.6.22.

could someone with a working ambicom card post his configuration please ??

TIA holger

p.s. at boot i get errors about mounting local filesystems, but all is working ????
p.p.s. How do we set the hw clock the machine is complaining about this at shutdown ????
« Last Edit: October 15, 2007, 12:24:22 pm by e.stoiber »

ZDevil

  • Hero Member
  • *****
  • Posts: 1998
    • View Profile
    • http://
Abicom Vs Hostap [solved]
« Reply #1 on: October 14, 2007, 04:42:32 pm »
Hey, first you need to provide more information:

1) Which model are you running Debian on?

2) What kind of filesystem error did you see? Could you post/type it here?

3) What does dmesg say when you plug the Ambicom card in? And what does "pccardctl status" say about the card?

4) Have you set up the profile for the Ambicom card properly? And how about the files /etc/network/interfaces, /etc/resolv.conf?

5) There are some discussions already about issues concerning the Ambicom card in the recent threads. Have you tried those suggestions?
(Actually I got both the Ambicom and the Symbol Spectrum 24, but I can only get the latter working after upgrading to Lenny. Both cards work under Etch, though.)
« Last Edit: October 14, 2007, 04:44:38 pm by ZDevil »

Life is too precious for hacking *too much*
Visit my Z screencap gallery[/color]
My EeePC 701 Black = Debian (Lenny) on IceRocks + Transcend SDHC Class6 8GB + 2GB RAM
My Zaurus SL-C3200 = Debian EABI (kernel 2.6.24.3-yonggun) on a swapped internal Sandisk Extreme III CF 16gb
My Debian EABI feed: http://matrixmen.free.fr/zaurus/debian/
My OpenBSD/Zaurus feeds:  Link1, Link2
[/i][/font][/color][/size]

e.stoiber

  • Newbie
  • *
  • Posts: 9
    • View Profile
Abicom Vs Hostap [solved]
« Reply #2 on: October 15, 2007, 12:51:09 pm »
My Ambicom is finally up and running, with hostap_cs drivers !

I had to do all configuring on the shell,......wrote a little script and now i'm upgrading.

Don't know yet why the interfaces file does not work, but it really doesn't matter to me.

The mount error on startup was from an entry in fstab.

The only thing left is the complaining about not beeing able to set the hw clock.

ZDevil

  • Hero Member
  • *****
  • Posts: 1998
    • View Profile
    • http://
Abicom Vs Hostap [solved]
« Reply #3 on: October 15, 2007, 02:28:43 pm »
That's interesting. I was thinking that the Ambicom card can only use the orinoco but not hostap driver?

Could you share the script here? Thanks.

Life is too precious for hacking *too much*
Visit my Z screencap gallery[/color]
My EeePC 701 Black = Debian (Lenny) on IceRocks + Transcend SDHC Class6 8GB + 2GB RAM
My Zaurus SL-C3200 = Debian EABI (kernel 2.6.24.3-yonggun) on a swapped internal Sandisk Extreme III CF 16gb
My Debian EABI feed: http://matrixmen.free.fr/zaurus/debian/
My OpenBSD/Zaurus feeds:  Link1, Link2
[/i][/font][/color][/size]

dlj0

  • Full Member
  • ***
  • Posts: 218
    • View Profile
Abicom Vs Hostap [solved]
« Reply #4 on: October 15, 2007, 09:17:04 pm »
Quote from: ZDevil
That's interesting. I was thinking that the Ambicom card can only use the orinoco but not hostap driver?

Could you share the script here? Thanks.

This is true for my Ambicom card, but I think it depends upon the age of the firmware.
Zaurus:  SL C3100
ROM:  eabi debian/sid

Raul

  • Full Member
  • ***
  • Posts: 133
    • View Profile
Abicom Vs Hostap [solved]
« Reply #5 on: August 16, 2008, 07:40:00 pm »
My card (ambicom wl1100c) firmware is old and I cannot get it to work either with orinoco (it worked before upgrade) nor hostap drivers. I have to find somebody with laptop and pcmcia port (I have a macbook which doesn't come with one).
I've tried most of the solution on the forum and googled for some but it didn't work.

maemorandum

  • Jr. Member
  • **
  • Posts: 55
    • View Profile
    • http://
Abicom Vs Hostap [solved]
« Reply #6 on: August 19, 2008, 02:54:48 pm »
Quote from: Raul
My card (ambicom wl1100c) firmware is old and I cannot get it to work either with orinoco (it worked before upgrade) nor hostap drivers. I have to find somebody with laptop and pcmcia port (I have a macbook which doesn't come with one).
I've tried most of the solution on the forum and googled for some but it didn't work.

The AmbiCom Card works perfect with the hostap drivers of the 2.6.23 kernel.
I had many problems using the hostap drivers with the 2.6.24 kernel.
Strange: they seemed to overkill the transmit-power and then broke down. So i guess, getting hostap to work might be a problem of the 2.6.24 kernel.

Nevertheless, hostap is the better solution than orinoco and now i am able to connect to wpa with tkip encrypted networks out of the box, but had to blacklist orinoco and hermes first. This card has a very low power-consumption, which was the usp for me.

If you decide a firmware-upgrade, you have to apt-get the hostap-utils and flash the firmware-files with the prism2.srec command.
SL-C3200 with opened 2nd CF-Slot, Debian EABI 2.6.23.9-yonggun on 2 GB High-Speed-CF
SL-C1000, Cacko-ROM

ASUS WL-110, hacked with external SMA Antenna Jack
AmbiComWL 1100C-CF, Buffalo Airstation-CF

Raul

  • Full Member
  • ***
  • Posts: 133
    • View Profile
Abicom Vs Hostap [solved]
« Reply #7 on: August 19, 2008, 05:21:17 pm »
>>The AmbiCom Card works perfect with the hostap drivers of the 2.6.23 kernel.
Question is if the andromeda will work with 2.6.23 kernel and modules.

>>If you decide a firmware-upgrade, you have to apt-get the hostap-utils and flash the firmware-files with the prism2.srec command.
I've tried but without succes - the problem is with renamed card name - it's wifi0_rename.

band-aid

  • Newbie
  • *
  • Posts: 35
    • View Profile
Abicom Vs Hostap [solved]
« Reply #8 on: August 24, 2008, 04:12:04 pm »
I too have tried to flash my card but it appears the hostap driver that are installed by default do not have firmware download support enabled. My attempts to get new drivers compiled have failed miserably. Any suggestions?

Raul

  • Full Member
  • ***
  • Posts: 133
    • View Profile
Abicom Vs Hostap [solved]
« Reply #9 on: September 20, 2008, 06:43:26 pm »
I've done the firmware upgrade on Windows (I could make card to work with prism2_srec, the same firmware flashed on Windows instatly).
Now I will try to make it work with hostap.