Author Topic: "couldn't Find Matching Glx Visual"  (Read 3565 times)

Capn_Fish

  • Hero Member
  • *****
  • Posts: 2342
    • View Profile
    • http://
"couldn't Find Matching Glx Visual"
« on: June 27, 2008, 10:43:04 pm »
I wrote a small OpenGL/SDL app that I compiled on my Z. It build without complaint, but when I tried to run it, it said

Code: [Select]
Couldn't find matching GLX visual
Am I missing a package? Or is a package already installed just not configured with OpenGL?

Thanks.
SL-C750- pdaXrom beta 1 (mostly unused)
Current distro: Gentoo

cortez

  • Sr. Member
  • ****
  • Posts: 375
    • View Profile
    • http://www.omegamoon.com
"couldn't Find Matching Glx Visual"
« Reply #1 on: June 28, 2008, 01:50:39 pm »
I had the same problem with the Ubuntu UME launcher. I replaced the xserver-kdrive by xserver-xorg and used the glx module.
At least that works. I don't know of any other options
[div align=\"center\"]== == == == == == == == == == == == == ==
www.omegamoon.com
Zaurus SL-C750 - Died in a dreadful coffee experiment, has a second life somewhere in the Czech Republic
Zaurus SL-C1000 - Multiboot Zubuntu, Debian, Fedora, Poky, Android and others
Zaurus SL-C3100 - Development device, currently Zubuntu 2.0
Zaurus SL-6000L - The fridge is running Zubuntu 1.0
Zaurus SL-C860 - Cacko, untouched since kindly donated, waiting for Zubuntu
== == == == == == == == == == == == == ==[/div]

Capn_Fish

  • Hero Member
  • *****
  • Posts: 2342
    • View Profile
    • http://
"couldn't Find Matching Glx Visual"
« Reply #2 on: June 28, 2008, 04:57:44 pm »
I kind of figured that that was the case. Oh, well...
SL-C750- pdaXrom beta 1 (mostly unused)
Current distro: Gentoo

canguy247

  • Jr. Member
  • **
  • Posts: 68
    • View Profile
"couldn't Find Matching Glx Visual"
« Reply #3 on: June 28, 2008, 09:15:25 pm »
How much slower do things run with xorg?

Canguy
SL-C1000 - Debian 2.6.24.4-yonggun (from SD)
Pandora preordered
4GB Transcend 150X SD
16GB AData CF
USB Host cable
Bluetooth USB Dongle/Linksys WCF12 CF Wifi
TRENDnet TE-CF100 10/100 Wired ethernet CF / DM9601 usb ethernet
Palm III keyboard neoprene case

Capn_Fish

  • Hero Member
  • *****
  • Posts: 2342
    • View Profile
    • http://
"couldn't Find Matching Glx Visual"
« Reply #4 on: October 05, 2008, 04:02:48 pm »
I just installed Xorg (apt-get install xorg-core, I believe), but it doesn't work correctly:

-The mouse is weird (you tap 50% off center of the screen, and it registers as being tapped on the very edge)
-I can't get it to start with "startx," even after linking it to /usr/bin/X, Xfbdev still loads
-When I try to run "/usr/bin/Xorg & sh ~/.xinitrc," it crashes saying "FBIOPUT_VSCREENINFO succeeded but modified mode" and "mode initialization failed"

Could somebody post a how-to?

Thanks.

EDIT: It also says "Xlib: extension "RANDR" missing on display ":0.0"
« Last Edit: October 05, 2008, 04:03:57 pm by Capn_Fish »
SL-C750- pdaXrom beta 1 (mostly unused)
Current distro: Gentoo

radiochickenwax

  • Full Member
  • ***
  • Posts: 158
    • View Profile
"couldn't Find Matching Glx Visual"
« Reply #5 on: November 29, 2008, 09:39:28 am »
Quote from: Capn_Fish
I just installed Xorg (apt-get install xorg-core, I believe), but it doesn't work correctly:
-I can't get it to start with "startx," even after linking it to /usr/bin/X, Xfbdev still loads

I had the above problem.  

Changed ~/.xserverrc

to exec "Xorg"  instead of "Xfbdev" and Xorg works instead.  Much nicer,and much much heavier.  Fonts are nicer, opengl/mesa works, but really slow.

glxgears gives about 15 fps max, and more like 4 fps average at a guess. Everything is prettier though.  This works a lot smoother than debian's prebuilt binary in pdaxrom and probably angstrom too.  How did they do it?

Quote from: Capn_Fish
Could somebody post a how-to?

I second this. A how-to would be nice. A rebuilt xserver/drivers would be very nice.  

http://www.linuxfromscratch.org/blfs/view/svn/x/x-setup.html

http://www.linuxfromscratch.org/blfs/view/...installing.html

The 2 links above have some info on rebuilding, but I can't afford to tie my machine up that long.
« Last Edit: November 29, 2008, 09:41:28 am by radiochickenwax »
ZAURII:    sl-6000 : (temporarily) bricked pdaxrom b1   ||   sl-c3200 : yonggun/Debian-EABI
OTHERS:  htc-excalibur,  axim x5,  ipaq 4355, (still trying to find useable linux setups)
thinking about gumstix to replace/augment zaurus