Author Topic: Zubuntu And Cacko?how?  (Read 8402 times)

adf

  • Hero Member
  • *****
  • Posts: 2807
    • View Profile
    • http://
Zubuntu And Cacko?how?
« Reply #15 on: April 12, 2009, 08:50:00 pm »
Quote from: thebaz67
This is how I configured my C3100.

I installed cacko normally to the NAND.

I installed the patch avail here to remove the need for the part hard drive partitions:

https://www.oesf.org/forum/index.php?s=&...st&p=176430

Then I created a couple of partitions on an SD card, one to hold the Zubuntu OS and one to point to the install of cacko on the NAND.

All I did to get cacko working is in the /boot partition on the sd card was place the zImage file and the kerel-cmdline containing the text below

console=ttyS0 root=/dev/mtdblock2 mtdparts=sharpsl-nand:7168k@0k(smf),32768k@7168k(root),-(home) jffs2_orphaned_inodes=delete EQUIPMENT=0 LOGOLANG=1 DEFYEAR=2006 LOGO=1 LAUNCH=q


what this does is load the zImage file from SD then loads the rest of cacko from the internal memory.
 Ok..I'm missing something. All I can manage following these directions is to hanf on the cacko blue loading screen. I bet I entered the kernel_cmdline wrong.  What should it look like in the text editor?

Also, did you resize the cacko root partition to 32 as the cacko directions call for?
**3100 Zubuntu Jaunty,(working on Cacko dualboot), 16G A-Data internal CF, 4G SD, Ambicom WL-1100C Cf, linksys usb ethernet,  BelkinF8T020 BT card, Belkin F8U1500-E Ir kbd, mini targus usb mouse, rechargeble AC/DC powered USB hub, psp cables and battery extenders.

**6000l  Tetsuized Sharprom, installed on internal flash only 1G sd, 2G cf

mjiba

  • Newbie
  • *
  • Posts: 14
    • View Profile
Zubuntu And Cacko?how?
« Reply #16 on: April 12, 2009, 11:06:24 pm »
When you boot Cacko the first time, before flashing the Zubuntu-kexec kernal, you can use:

cat /proc/cmdline > [location of kernal-cmdline file on SD]

to have the correct cmdline info on your SD partition.  It may be different depending on your Z model.  

Hope this helps...
C1000 dual boot cacko 1.23-full on NAND and Zubuntu v1 on SD
C1000 pdaxii13 V2 Full hd image on SD
5500 tkc rom-1.0 with home on SD

adf

  • Hero Member
  • *****
  • Posts: 2807
    • View Profile
    • http://
Zubuntu And Cacko?how?
« Reply #17 on: April 20, 2009, 11:17:55 pm »
Quote from: mjiba
When you boot Cacko the first time, before flashing the Zubuntu-kexec kernal, you can use:

cat /proc/cmdline > [location of kernal-cmdline file on SD]

to have the correct cmdline info on your SD partition.  It may be different depending on your Z model.  

Hope this helps...


I had to reflash and install evil jazz's kernel and modules before I did cat /proc/cmdline, etc.. but it worked great.

Now I just have to get sound in zubuntu and make cacko use my ambicom wifi
**3100 Zubuntu Jaunty,(working on Cacko dualboot), 16G A-Data internal CF, 4G SD, Ambicom WL-1100C Cf, linksys usb ethernet,  BelkinF8T020 BT card, Belkin F8U1500-E Ir kbd, mini targus usb mouse, rechargeble AC/DC powered USB hub, psp cables and battery extenders.

**6000l  Tetsuized Sharprom, installed on internal flash only 1G sd, 2G cf

mjiba

  • Newbie
  • *
  • Posts: 14
    • View Profile
Zubuntu And Cacko?how?
« Reply #18 on: April 21, 2009, 05:54:57 pm »
Just out of curiosity, which Cacko kernal did you wind up using?  I could not get eviljazz's kernel to work with this, no matter what I tried.  
Glad you got it working though.
C1000 dual boot cacko 1.23-full on NAND and Zubuntu v1 on SD
C1000 pdaxii13 V2 Full hd image on SD
5500 tkc rom-1.0 with home on SD

adf

  • Hero Member
  • *****
  • Posts: 2807
    • View Profile
    • http://
Zubuntu And Cacko?how?
« Reply #19 on: April 21, 2009, 11:40:54 pm »
Quote from: mjiba
Just out of curiosity, which Cacko kernal did you wind up using?  I could not get eviljazz's kernel to work with this, no matter what I tried.  
Glad you got it working though.
I did a restore form trisoft's image, flashed cacko..had issues for a bit. what I ended up doing was flashing cacko, doing the no hd patch (which I suspect of having side effects) installing eviljazz's fastfpe cahchedfb kernel AND the modules, catting the cmdline over to the /boot/kernel_cmd and adding the same eviljazz zImage to the /boot dir. It seems to work, but I am having wifi issues..sadly now I am having them on both cacko and zubuntu because I installed connman and can no longer get dhc to work, but that is a story for another thread, and I can use the cacko boot to install a new zubuntu image if necessary
**3100 Zubuntu Jaunty,(working on Cacko dualboot), 16G A-Data internal CF, 4G SD, Ambicom WL-1100C Cf, linksys usb ethernet,  BelkinF8T020 BT card, Belkin F8U1500-E Ir kbd, mini targus usb mouse, rechargeble AC/DC powered USB hub, psp cables and battery extenders.

**6000l  Tetsuized Sharprom, installed on internal flash only 1G sd, 2G cf