Author Topic: Special kernel install woes...  (Read 5818 times)

Joeboo

  • Newbie
  • *
  • Posts: 24
    • View Profile
    • http://
Special kernel install woes...
« on: April 07, 2004, 10:24:19 pm »
Help,
  I\'m trying to install the special kernel into my 5600 and I can\'t get it to work.  The rom updated to 1.32 fine using the PC software.  I managed to rogue a 20mb sandisk CF card from work to install the kernel update, but when I follow the instructions here (turn off, remove battery cover, reset, ok/cancel button, update, cf, etc...) I get the sharp screen, and at the bottom it says modprobe: can\'t locate devinfo then screen says --Sharp Updater-- and something about not finding or being able to create some directories (tmp/something/updater.sh etc.)  

The card has two files: updater.sh from the ROM upgrade, and zImage.bin which I renamed from this site.  The Documents and QtPalmtop folders which are loaded automatically are there as well.

I\'ve tried formated the card in the Z, and formating it using windows and a card reader at work.  Niether made any difference.

What am I doing wrong?  This card works fine for moving and using files, but could there be something wrong with it?

thanks

egn

  • Newbie
  • *
  • Posts: 3
    • View Profile
    • http://
Special kernel install woes...
« Reply #1 on: April 08, 2004, 09:14:14 pm »
Did this last night.  Both files have to be on the root (/) directory of the card.  My mistake was I was putting them in InstallFiles.  If you follow the same procedure as with the ROM update you should get the new kernel to work.  Hope this helps.

HydroWVU

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • http://
Special kernel install woes...
« Reply #2 on: April 29, 2004, 11:08:31 pm »
I am having the exact same problem, but updater.sh and zImage.bin are in the / directory on my SD or CF cards. I get the same error as above, and on the Sharp Updater screen I can see can\'t create directory /etc/update/control/next

What is causing this problem?

Other facts,
I moved the files with the Zaurus file transfer utility.
Both files are owned by root with file permissions of 666
I flash 1.32 earlier but that was succesful

TIA

John

tumnus

  • Hero Member
  • *****
  • Posts: 1176
    • View Profile
    • http://www.cpinkney.org.uk
Special kernel install woes...
« Reply #3 on: April 30, 2004, 03:15:44 am »
The CF/SD card must be FAT16 (DOS FAT) formatted using fdisk to set the correct partition type and mkfs.msdos on the Zaurus to make sure it is formatted properly. With FAT there are no permissions to set for the files and while FAT is technically not supposed to be case sensitive, the Zaurus might be case sensitive with regards to these files.
# Search the Zaurus Howtos ## Search the Zaurus FAQs ## Find Z software at ELSI #
--------------------
UK SL5500 with Sharp ROM 3.13, SL5600 with Sharp ROM 1.32 - SuSE 9.0 Pro, Windows XP Home
Qualendar for Calendar and Todo
Socket Bluetooth CF Card (Rev F), Kingmax 512MB MMC Card, Palm Tungsten T Stylus,
Pretec CF->Smartmedia Adapter, Semsons Universal Battery Extender

cgrieves

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
    • http://
Special kernel install woes...
« Reply #4 on: April 30, 2004, 10:52:26 am »
I\'ve got the same problem- 1.32 flashed perfectly well via USB. Trying to install the special kernel though- the zImage.bin and updater.sh are on the root of my CF. The updater bombs out saying it can\'t create a directory then reboots.

I formatted the card with FAT16 from windows though- being a bit of a Linux newb has anyone got step-by-steps on how to format a CF on the Z?

Greg2

  • Hero Member
  • *****
  • Posts: 790
    • View Profile
    • http://
Special kernel install woes...
« Reply #5 on: April 30, 2004, 11:15:32 am »
Quote
I formatted the card with FAT16 from windows though- being a bit of a Linux newb has anyone got step-by-steps on how to format a CF on the Z?
cgrieves

Insert cf-card, open terminal and:

# su
# umount /dev/hda1
# mkfs.vfat /dev/hda1
# mount /dev/hda1
# exit

Greg

cgrieves

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
    • http://
Special kernel install woes...
« Reply #6 on: April 30, 2004, 12:08:18 pm »
OK that seemed to work but I can\'t copy to the CF card now (from File Transer or Cut/Paste on the Z). Weird....

Joeboo

  • Newbie
  • *
  • Posts: 24
    • View Profile
    • http://
Special kernel install woes...
« Reply #7 on: April 30, 2004, 01:17:42 pm »
Still no luck for me yet...

Were you able to install the kernel?

I think my problem may be the card, it an old sandisk card that we use in a 6 year old digital camera at work.  When I can afford it, I will probably pick up a new SD card and try it from there.

Caena

  • Newbie
  • *
  • Posts: 1
    • View Profile
Special kernel install woes...
« Reply #8 on: April 30, 2004, 03:43:16 pm »
I had the same problems until I realized I was using the wrong updater.sh script.  You need the one thats from the 560v132c.zip file.

cgrieves

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
    • http://
Special kernel install woes...
« Reply #9 on: April 30, 2004, 04:55:39 pm »
Wonderful thankyou, that fixed it for me

My Z seems much more responsive already. Hopefully stability won\'t be affected....

Joeboo

  • Newbie
  • *
  • Posts: 24
    • View Profile
    • http://
Special kernel install woes...
« Reply #10 on: May 01, 2004, 05:33:40 pm »
(ding..ding..ding)  We Have A Winner.    It finally worked.  Thanks for the help.  Is this in the FAQ? If it isn\'t it needs to be.  I was using the \'u\' version of the ROM, not the \'c\' version that I needed.  Thanks

Keola

  • Newbie
  • *
  • Posts: 48
    • View Profile
    • http://fruitwerks.us
Special kernel install woes...
« Reply #11 on: May 02, 2004, 08:08:43 pm »
I know there are the patches in the download section and roms and such... but does anyone host these special roms anywhere? I really don\'t have anywhere to compile these.

Thanks

HydroWVU

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • http://
Special kernel install woes...
« Reply #12 on: May 03, 2004, 11:07:12 pm »
Awesome, that fixed it.  And now my Zaurus is functional... I can surf the web with out it complaining about memory.  Thanks

John

cmisip

  • Sr. Member
  • ****
  • Posts: 256
    • View Profile
    • http://home.mchsi.com/~cmisip/index.htm
Special kernel install woes...
« Reply #13 on: May 04, 2004, 12:31:06 am »
If you still run into problems with memory and such on your 5600 during surfing, you can try nfs swapping using a virtual ramdisk as swap device.  This is what I am using as some sites are not pda friendly.  This plus raising the memory limit of Opera.
Zaurus 5600
Zynergy Rootfs 1.1
Custom zImage

How Do You Do That in Linux

tumnus

  • Hero Member
  • *****
  • Posts: 1176
    • View Profile
    • http://www.cpinkney.org.uk
Special kernel install woes...
« Reply #14 on: May 04, 2004, 04:16:46 am »
Quote
I know there are the patches in the download section and roms and such... but does anyone host these special roms anywhere? I really don\'t have anywhere to compile these.


Just click the patch title on the downloads page: http://www.zaurususergroup.com/modules.php...q=getit&lid=188
# Search the Zaurus Howtos ## Search the Zaurus FAQs ## Find Z software at ELSI #
--------------------
UK SL5500 with Sharp ROM 3.13, SL5600 with Sharp ROM 1.32 - SuSE 9.0 Pro, Windows XP Home
Qualendar for Calendar and Todo
Socket Bluetooth CF Card (Rev F), Kingmax 512MB MMC Card, Palm Tungsten T Stylus,
Pretec CF->Smartmedia Adapter, Semsons Universal Battery Extender