Author Topic: Live Distros That Work  (Read 12488 times)

ArchiMark

  • Administrator
  • Hero Member
  • *****
  • Posts: 1772
    • View Profile
Live Distros That Work
« Reply #15 on: November 18, 2016, 11:31:31 am »
Thanks for the cable info, varti

Any simple way to get connected since the live Linux Mint does not have a password which ssh is asking me to enter?

It just occurred to me that maybe it would improve situation if I installed Linux Mint onto my WIN instead of using the live version.

This way I would have normal user setup with password, etc, etc...and maybe avoid some of the issues I have run into with using the live version.

Agree?
« Last Edit: November 18, 2016, 12:02:56 pm by ArchiMark »
Silicon Valley Digerati - * Please see my Mini Laptops For Sale Listing *
Cosmo Communicator / One-Netbook One Mix Yoga 3S (Win 10/Manjaro 18)
Banana Pi Zero UMPC/Armbian
MacBookPro
Sold: C3200/N900/OQO/N5/Dell Mini9/Netwalker/UMID M1/

Varti

  • Administrator
  • Hero Member
  • *****
  • Posts: 1088
    • View Profile
Live Distros That Work
« Reply #16 on: November 18, 2016, 12:06:54 pm »
Quote from: ArchiMark
Thanks for the cable info, varti

Any simple way to get connected since the live Linux Mint does not have a password which ssh is asking me to enter?

It just occurred to me that maybe it would improve situation if I installed Linux Mint onto my WIN instead of using the live version.

This way I would have normal user setup with password, etc, etc...and maybe avoid some of the issues I have run into with using the live version.

Agree?
The Linux Mint live version default user has no password, so if ssh is rejecting the connection when pressing Return at the password prompt (probably it does this for security reasons), I believe the only remaining option is to install it on the Win, as you suggested.

Varti
Planet Gemini PDA WiFi/LTE with Mediatek x27
SL-C1000 running Arch Linux ARM May2017, K30225 Wi-Fi CF Card, 64GB SDXC card
and many other Zauruses!

ArchiMark

  • Administrator
  • Hero Member
  • *****
  • Posts: 1772
    • View Profile
Live Distros That Work
« Reply #17 on: November 18, 2016, 12:47:19 pm »
Quote from: Varti
Quote from: ArchiMark
Thanks for the cable info, varti

Any simple way to get connected since the live Linux Mint does not have a password which ssh is asking me to enter?

It just occurred to me that maybe it would improve situation if I installed Linux Mint onto my WIN instead of using the live version.

This way I would have normal user setup with password, etc, etc...and maybe avoid some of the issues I have run into with using the live version.

Agree?
The Linux Mint live version default user has no password, so if ssh is rejecting the connection when pressing Return at the password prompt (probably it does this for security reasons), I believe the only remaining option is to install it on the Win, as you suggested.

Varti

Thanks, Varti.....

Just have a feeling installing LM will likely eliminate various issues including the ssh login.....

Will report back after I've installed and have the Xorg log and dmesg info as Greg requested...

Mark
Silicon Valley Digerati - * Please see my Mini Laptops For Sale Listing *
Cosmo Communicator / One-Netbook One Mix Yoga 3S (Win 10/Manjaro 18)
Banana Pi Zero UMPC/Armbian
MacBookPro
Sold: C3200/N900/OQO/N5/Dell Mini9/Netwalker/UMID M1/

ArchiMark

  • Administrator
  • Hero Member
  • *****
  • Posts: 1772
    • View Profile
Live Distros That Work
« Reply #18 on: November 21, 2016, 01:37:52 pm »
Had some issues LM installer...would not install grub.....

So, installed Manjaro instead. Install went OK.

Now, trying to ssh from my Fujitsu UG/90 laptop into the WIN. Still having issues...

I'm connecting the two laptops via ethernet cables.

I did ip addr on WIN and get:

Code: [Select]
$ ip addr

lo:

inet 127.0.0.1/8

inet6::1/128

enp0s20u4u4:

link/ether  00:05:1b:d0:42:c9

inet6  fe80::292:d5fe:3381:3de0:/64

So I did:

Code: [Select]
$ ssh marks-win@127.0.0.1

marks-win@127.0.0.1's password:
Permission denied, please try again.

marks-win@127.0.0.1's password:
Permission denied, please try again.

marks-win@127.0.0.1's password:
Permission denied (publickey password).

Each time I entered the password I created when I installed Manjaro.

What am I doing wrong?

Thanks!

Mark
Silicon Valley Digerati - * Please see my Mini Laptops For Sale Listing *
Cosmo Communicator / One-Netbook One Mix Yoga 3S (Win 10/Manjaro 18)
Banana Pi Zero UMPC/Armbian
MacBookPro
Sold: C3200/N900/OQO/N5/Dell Mini9/Netwalker/UMID M1/

greguu

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 393
    • View Profile
    • http://github.com/greguu
Live Distros That Work
« Reply #19 on: November 21, 2016, 11:22:28 pm »
Quote from: ArchiMark
Had some issues LM installer...would not install grub.....

So, installed Manjaro instead. Install went OK.

Now, trying to ssh from my Fujitsu UG/90 laptop into the WIN. Still having issues...

I'm connecting the two laptops via ethernet cables.

I did ip addr on WIN and get:

Code: [Select]
$ ip addr

lo:

inet 127.0.0.1/8

inet6::1/128

enp0s20u4u4:

link/ether  00:05:1b:d0:42:c9

inet6  fe80::292:d5fe:3381:3de0:/64

So I did:

Code: [Select]
$ ssh marks-win@127.0.0.1

marks-win@127.0.0.1's password:
Permission denied, please try again.

marks-win@127.0.0.1's password:
Permission denied, please try again.

marks-win@127.0.0.1's password:
Permission denied (publickey password).

Each time I entered the password I created when I installed Manjaro.

What am I doing wrong?

Thanks!

Mark

Hi Mark,

127.0.0.1 is localhost and not a outward facing IP address. This does not work.

You can set both, the WIN and the Fujisu, to a fixed IP for this to work.

I think Manajro is Arch based so netctl should be installed. This is just an example :

Set your IP from DHCP to static on the Fujisu:

IP : 10.1.10.1
MASK : 255.255.255.0

on the WIN create a file as root /etc/netctl/static with the following contents

Code: [Select]
Interface=enp0s20u4u4
Connection=ethernet
IP=static
Address=('10.1.10.2/24')
Gateway=('10.1.10.1')
DNS=('10.1.10.1')

Then start the network with "netctl start static"

Now you should be able to SSH from the Fujisu by doing "ssh -l marks-win 10.1.10.2"

Greg
Gemini-PDA (Stock Android) / LG Nexus 5 (Sailfish OS) / Nokia N9 (MeeGo/Harmattan)
Sharp Zaurus C3100 (Borzoi) - Void Linux (voidz) Kernel 5.0.0 - Hardware (Buffalo CF LAN, DLink 660 CF WiFi, ASIX AX88772 USB Ethernet)

ArchiMark

  • Administrator
  • Hero Member
  • *****
  • Posts: 1772
    • View Profile
Live Distros That Work
« Reply #20 on: November 22, 2016, 12:53:55 am »
THANK YOU, Greg!

Will give that a try tomorrow Tuesday here.....

And hopefully (finally....) report back with Xorg log and dmesg info you asked to see.....
Silicon Valley Digerati - * Please see my Mini Laptops For Sale Listing *
Cosmo Communicator / One-Netbook One Mix Yoga 3S (Win 10/Manjaro 18)
Banana Pi Zero UMPC/Armbian
MacBookPro
Sold: C3200/N900/OQO/N5/Dell Mini9/Netwalker/UMID M1/

ArchiMark

  • Administrator
  • Hero Member
  • *****
  • Posts: 1772
    • View Profile
Live Distros That Work
« Reply #21 on: November 22, 2016, 02:11:18 pm »
Tried setting up static ip on WIN.....

But get the following:

Code: [Select]
# netctl start static

netctl@static.service failed because the control process exited with error code.
See "systemctl status netctl@static.service" and journalctl -xe for details.

# systemctl status netctl@static.service

‚óŹ netctl@static.service - enp0s20u4u4
   Loaded: loaded (/etc/systemd/system/netctl@static.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2016-11-22 02:59:38 PST; 1min 17s ago
     Docs: man:netctl.profile(5)
 Process: 2582 ExecStart=/usr/lib/network/network start %I (code=exited, status=1/FAILURE)
 Main PID: 2582 (code=exited, status=1/FAILURE)

Nov 22 02:59:38 mark-win systemd[1]: Starting enp0s20u4u4...
Nov 22 02:59:38 mark-win network[2582]: Starting network profile 'static'...
Nov 22 02:59:38 mark-win network[2582]: The interface of network profile 'static' is already up
Nov 22 02:59:38 mark-win systemd[1]: netctl@static.service: Main process exited, code=exited, status=1/FAILURE
Nov 22 02:59:38 mark-win systemd[1]: Failed to start enp0s20u4u4.
Nov 22 02:59:38 mark-win systemd[1]: netctl@static.service: Unit entered failed state.
Nov 22 02:59:38 mark-win systemd[1]: netctl@static.service: Failed with result 'exit-code'.

Please note that I followed your instructions as well some of the Manjaro wiki on static IP:

https://wiki.manjaro.org/index.php?title=Setup_Static_IP


Any suggestion?

Thanks.
Silicon Valley Digerati - * Please see my Mini Laptops For Sale Listing *
Cosmo Communicator / One-Netbook One Mix Yoga 3S (Win 10/Manjaro 18)
Banana Pi Zero UMPC/Armbian
MacBookPro
Sold: C3200/N900/OQO/N5/Dell Mini9/Netwalker/UMID M1/

ArchiMark

  • Administrator
  • Hero Member
  • *****
  • Posts: 1772
    • View Profile
Live Distros That Work
« Reply #22 on: November 22, 2016, 05:26:26 pm »
UPDATE

Fiddled around with things a bit more and think I made some progress...at least I think so.....on the WIN.....

After tweaking a few things, I rebooted again....

Now when I check network connections, I see:

Code: [Select]
$ ifconfig

enp0s20u4u4:  flags=4163 mtu 1500
   inet 10.1.10.2 netmask 255.255.255.0 broadcast 255.255.255.0
   blah, blah, blah......................

However, on my Fujitsu, when I try to connect, I see:

Code: [Select]
$ ssh -l marks-win 10.1.10.2

ssh: connect to host 10.1.10.2 port 22: No route to host


????

Thanks.
Silicon Valley Digerati - * Please see my Mini Laptops For Sale Listing *
Cosmo Communicator / One-Netbook One Mix Yoga 3S (Win 10/Manjaro 18)
Banana Pi Zero UMPC/Armbian
MacBookPro
Sold: C3200/N900/OQO/N5/Dell Mini9/Netwalker/UMID M1/

greguu

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 393
    • View Profile
    • http://github.com/greguu
Live Distros That Work
« Reply #23 on: November 22, 2016, 11:46:40 pm »
Quote from: ArchiMark
UPDATE

Fiddled around with things a bit more and think I made some progress...at least I think so.....on the WIN.....

After tweaking a few things, I rebooted again....

Now when I check network connections, I see:

Code: [Select]
$ ifconfig

enp0s20u4u4:  flags=4163 mtu 1500
   inet 10.1.10.2 netmask 255.255.255.0 broadcast 255.255.255.0
   blah, blah, blah......................

However, on my Fujitsu, when I try to connect, I see:

Code: [Select]
$ ssh -l marks-win 10.1.10.2

ssh: connect to host 10.1.10.2 port 22: No route to host


????

Thanks.

Hi Mark, you need to set the Fujitsu also to a static IP (eg 10.1.10.1) then it should work.
« Last Edit: November 22, 2016, 11:46:58 pm by greguu »
Gemini-PDA (Stock Android) / LG Nexus 5 (Sailfish OS) / Nokia N9 (MeeGo/Harmattan)
Sharp Zaurus C3100 (Borzoi) - Void Linux (voidz) Kernel 5.0.0 - Hardware (Buffalo CF LAN, DLink 660 CF WiFi, ASIX AX88772 USB Ethernet)

ArchiMark

  • Administrator
  • Hero Member
  • *****
  • Posts: 1772
    • View Profile
Live Distros That Work
« Reply #24 on: November 23, 2016, 12:11:45 am »
Quote from: greguu
Quote from: ArchiMark
UPDATE

Fiddled around with things a bit more and think I made some progress...at least I think so.....on the WIN.....

After tweaking a few things, I rebooted again....

Now when I check network connections, I see:

Code: [Select]
$ ifconfig

enp0s20u4u4:  flags=4163 mtu 1500
   inet 10.1.10.2 netmask 255.255.255.0 broadcast 255.255.255.0
   blah, blah, blah......................

However, on my Fujitsu, when I try to connect, I see:

Code: [Select]
$ ssh -l marks-win 10.1.10.2

ssh: connect to host 10.1.10.2 port 22: No route to host


????

Thanks.

Hi Mark, you need to set the Fujitsu also to a static IP (eg 10.1.10.1) then it should work.

Thanks, Greg......but I did that as you instructed and checked what was needed per a webpage on the subject for doing this with Linux Mint which I have on the Fujitsu.

Can check it again, to see that the static IP took effect.....

btw, I tried pinging WIN from the Fujitsu too....but it didn't work....

Will report back again.....
Silicon Valley Digerati - * Please see my Mini Laptops For Sale Listing *
Cosmo Communicator / One-Netbook One Mix Yoga 3S (Win 10/Manjaro 18)
Banana Pi Zero UMPC/Armbian
MacBookPro
Sold: C3200/N900/OQO/N5/Dell Mini9/Netwalker/UMID M1/

ArchiMark

  • Administrator
  • Hero Member
  • *****
  • Posts: 1772
    • View Profile
Live Distros That Work
« Reply #25 on: November 24, 2016, 12:03:29 am »
Checked setup again.....

I've got the static IP addresses showing correctly on each device.

I even got a little pop-up saying that device is connected on each device.

Yet, when I try to ssh as instructed, I get the same error message as before:

Code: [Select]
$ ssh -l marks-win 10.1.10.2

ssh: connect to host 10.1.10.2 port 22: No route to host


Any other suggestions?????

 
Silicon Valley Digerati - * Please see my Mini Laptops For Sale Listing *
Cosmo Communicator / One-Netbook One Mix Yoga 3S (Win 10/Manjaro 18)
Banana Pi Zero UMPC/Armbian
MacBookPro
Sold: C3200/N900/OQO/N5/Dell Mini9/Netwalker/UMID M1/

greguu

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 393
    • View Profile
    • http://github.com/greguu
Live Distros That Work
« Reply #26 on: November 24, 2016, 01:54:38 am »
Quote from: ArchiMark
Checked setup again.....

I've got the static IP addresses showing correctly on each device.

I even got a little pop-up saying that device is connected on each device.

Yet, when I try to ssh as instructed, I get the same error message as before:

Code: [Select]
$ ssh -l marks-win 10.1.10.2

ssh: connect to host 10.1.10.2 port 22: No route to host


Any other suggestions?????

 



Do you have a switch you can use ? Maybe the network ports can not work without a cross-over cable. Do you have LED's indicating a connection on the Ethernet port ?

Check on both "ip addr" and "ipconfig" and try to ping each other.

Try another ethernet cable.

Most easy would be to have both connected to a modem/router/switch with DHCP enabled.
Gemini-PDA (Stock Android) / LG Nexus 5 (Sailfish OS) / Nokia N9 (MeeGo/Harmattan)
Sharp Zaurus C3100 (Borzoi) - Void Linux (voidz) Kernel 5.0.0 - Hardware (Buffalo CF LAN, DLink 660 CF WiFi, ASIX AX88772 USB Ethernet)

ArchiMark

  • Administrator
  • Hero Member
  • *****
  • Posts: 1772
    • View Profile
Live Distros That Work
« Reply #27 on: November 24, 2016, 02:16:47 am »
Quote from: greguu
Quote from: ArchiMark
Checked setup again.....

I've got the static IP addresses showing correctly on each device.

I even got a little pop-up saying that device is connected on each device.

Yet, when I try to ssh as instructed, I get the same error message as before:

Code: [Select]
$ ssh -l marks-win 10.1.10.2

ssh: connect to host 10.1.10.2 port 22: No route to host


Any other suggestions?????

 


Do you have a switch you can use ?

Maybe the network ports can not work without a cross-over cable. Do you have LED's indicating a connection on the Ethernet port ?

Check on both "ip addr" and "ipconfig" and try to ping each other.

Try another ethernet cable.

Most easy would be to have both connected to a modem/router/switch with DHCP enabled.

Thanks, Greg....

I have a Netgear combo DSL modem/router.....

So, just tried connecting the 2 laptops to the network....

Lights for WIN are green.....but lights for Fujitsu are orange......hmmmm.........

Tried another cable with Fujitsu, but lights are still orange.....maybe the USB ethernet adapter is having issues?

[UPDATE: Found out orange means speed is slower; 10/100....so, working but slow, need a different adapter for higher speed...]

As for DHCP, that's what I tried at first.....but didn't work.....

Hmmmm...............

I did ip addr before it only shows connections for the device I'm using, not the other one.

Also, tried pinging WIN, but couldn't.

Maybe will try to use wifi connection.....if I can get them connected to it...
« Last Edit: November 24, 2016, 09:40:43 pm by ArchiMark »
Silicon Valley Digerati - * Please see my Mini Laptops For Sale Listing *
Cosmo Communicator / One-Netbook One Mix Yoga 3S (Win 10/Manjaro 18)
Banana Pi Zero UMPC/Armbian
MacBookPro
Sold: C3200/N900/OQO/N5/Dell Mini9/Netwalker/UMID M1/

ArchiMark

  • Administrator
  • Hero Member
  • *****
  • Posts: 1772
    • View Profile
Live Distros That Work
« Reply #28 on: November 28, 2016, 11:09:28 pm »
Finally had some time to deal with ssh into WIN issue again....

Was reading about /etc/ssh/sshd_config file.....

Checked mine out and all the lines are commented out I assume as they have a '#' at start of each line.

Here's a copy of it:

Code: [Select]
#    $OpenBSD: sshd_config,v 1.99 2016/07/11 03:19:44 tedu Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options override the
# default value.

#Port 22
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

# The default requires explicit activation of protocol 1
#Protocol 2
ccccccc
# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key
#HostKey /etc/ssh/ssh_host_ecdsa_key
#HostKey /etc/ssh/ssh_host_ed25519_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 1024

# Ciphers and keying
#RekeyLimit default none

# Logging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
#PermitRootLogin prohibit-password
#StrictModes yes
#MaxAuthTries 6
#MaxSessions 10

#RSAAuthentication yes
#PubkeyAuthentication yes

# The default is to check both .ssh/authorized_keys and .ssh/authorized_keys2
# but this is overridden so installations will only check .ssh/authorized_keys
AuthorizedKeysFile    .ssh/authorized_keys

#AuthorizedPrincipalsFile none

#AuthorizedKeysCommand none
#AuthorizedKeysCommandUser nobody

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
ChallengeResponseAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

#AllowAgentForwarding yes
#AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding no
#X11DisplayOffset 10
#X11UseLocalhost yes
#PermitTTY yes
PrintMotd no # pam does that
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation sandbox
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS no
#PidFile /run/sshd.pid
#MaxStartups 10:30:100
#PermitTunnel no
#ChrootDirectory none
#VersionAddendum none

# no default banner path
#Banner none

# override default of no subsystems
Subsystem    sftp    /usr/lib/ssh/sftp-server

# Example of overriding settings on a per-user basis
#Match User anoncvs
#    X11Forwarding no
#    AllowTcpForwarding no
#    PermitTTY no
#    ForceCommand cvs server

Would greatly appreciate input as to which lines to uncomment and if any need editing.

Thanks!
Silicon Valley Digerati - * Please see my Mini Laptops For Sale Listing *
Cosmo Communicator / One-Netbook One Mix Yoga 3S (Win 10/Manjaro 18)
Banana Pi Zero UMPC/Armbian
MacBookPro
Sold: C3200/N900/OQO/N5/Dell Mini9/Netwalker/UMID M1/

linx

  • Newbie
  • *
  • Posts: 13
    • View Profile
Live Distros That Work
« Reply #29 on: December 07, 2016, 09:50:18 am »
I installed Xubuntu the version from the site not the customized one which would start booting from a live USB but then showed a black screen only. I could bypass that blackscreen and boot to the live distro with nomodeset as a kernel parameter. Yes display is on portrait and in the settings in rotation in Xfce there was no option to rotate it. I haven't tried any other boot parameters but I installed it in a USB and I am currently dual booting. I am going to find that WIFI file that is needed to make wifi working again and then I'll try updating etc. I will try later on the custom Xubuntu iso from http://linuxiumcomau.blogspot.com/2016/10/...-trail-and.html . I will keep you updated.