Author Topic: Debian TP2: no Italian kbd  (Read 3320 times)

Adam Boardman

  • Full Member
  • ***
  • Posts: 191
    • View Profile
Debian TP2: no Italian kbd
« Reply #15 on: October 26, 2018, 08:16:24 am »
Keyboard maps and locales are entirely separate. For me the Layout dropdown on sddm login screen has Italian listed, that is the simplest way of picking a keyboard, any other persistent keyboard config eg in lxqt keyboard settings will conflict and get in the way of that setting working beyond the login screen.

For your one off test a keyboard for this session (setxkbmap command) you would only want to be giving it a two letter keyboard code rather than a locale (keyboard+language) style code.

salvomic

  • Sr. Member
  • ****
  • Posts: 290
    • View Profile
Debian TP2: no Italian kbd
« Reply #16 on: October 26, 2018, 08:51:58 am »
Quote from: Adam Boardman
Keyboard maps and locales are entirely separate. For me the Layout dropdown on sddm login screen has Italian listed, that is the simplest way of picking a keyboard, any other persistent keyboard config eg in lxqt keyboard settings will conflict and get in the way of that setting working beyond the login screen.

For your one off test a keyboard for this session (setxkbmap command) you would only want to be giving it a two letter keyboard code rather than a locale (keyboard+language) style code.

yes, I agree with you.
The problem was, as I wrote in another post, the incorrect upgrade process (I got "unmet dependencies" for other reasons) solving that all went gone and at the restart I can see the Italian flag again!

Now I'm on Debian 9.5: are there new version installable (with apt distance-upgrade) or not?

Salvo


EDIT:
some little issue with Perl and Locale.
After some program like Cowsay I get
Code: [Select]
perl: warning: Setting locale failed
perl: warning: Please check that your locale settings:
LANGUAGE = "",
LC_ALL = (unset),
LC_MEASUREMENT = "it_IT.US-ASCII",
...
are supported and installed on your system.
perl: warning: Failing back to the standard locale ("C").
Also if Italian seems correctly set in LXQT.
Any help?
« Last Edit: October 26, 2018, 09:17:19 am by salvomic »
Gemini, Psion S5 and S5mx, iPhone, iPad, Huawei MediaPad M5, some HP calculators.
Psion Fans Italia moderator