Author Topic: Debian TP2: no Italian kbd  (Read 3090 times)

salvomic

  • Sr. Member
  • ****
  • Posts: 290
    • View Profile
Debian TP2: no Italian kbd
« on: June 27, 2018, 01:01:14 pm »
there is no Italian Keyboard starting Debian (Flag menu)?
With US kbd to get - I must press * (FN-o) and to get / I must press Shift-;

I set locale, now lxqt is set in Italian, but every Italian keyboard have wrong key mapping for those chars, or not at all...

Any help?
salvo
Gemini, Psion S5 and S5mx, iPhone, iPad, Huawei MediaPad M5, some HP calculators.
Psion Fans Italia moderator

Adam Boardman

  • Full Member
  • ***
  • Posts: 191
    • View Profile
Debian TP2: no Italian kbd
« Reply #1 on: June 27, 2018, 01:18:46 pm »
Someone has to add a block for your keyboard to this file:
https://github.com/gemian/xkeyboard-config/...net_vndr/gemini

It lives in /usr/share/X11/xkb/symbols/planet_vndr/ on your device.

Once you've added it there (and tested it with 'setxkbmap -v **', where ** is the country code you've just added) then you'll need to get it added to the xkeyboard-config and to add the new country to this list so that it will appear on the login screen.

You can ask me to do the github stuff if you want to just make and test the layout?

salvomic

  • Sr. Member
  • ****
  • Posts: 290
    • View Profile
Debian TP2: no Italian kbd
« Reply #2 on: June 27, 2018, 01:21:55 pm »
Quote from: Adam Boardman
Someone has to add a block for your keyboard to this file:
https://github.com/gemian/xkeyboard-config/...net_vndr/gemini

It lives in /usr/share/X11/xkb/symbols/planet_vndr/ on your device.

Once you've added it there (and tested it with 'setxkbmap -v **', where ** is the country code you've just added) then you'll need to get it added to the xkeyboard-config and to add the new country to this list so that it will appear on the login screen.

You can ask me to do the github stuff if you want to just make and test the layout?

yes Adam, please, be kind to do it, I want test and help to debug, if needed
Salvo
Gemini, Psion S5 and S5mx, iPhone, iPad, Huawei MediaPad M5, some HP calculators.
Psion Fans Italia moderator

Adam Boardman

  • Full Member
  • ***
  • Posts: 191
    • View Profile
Debian TP2: no Italian kbd
« Reply #3 on: June 29, 2018, 04:26:38 am »
Building just now, should be ready to test in 30mins.

salvomic

  • Sr. Member
  • ****
  • Posts: 290
    • View Profile
Debian TP2: no Italian kbd
« Reply #4 on: June 29, 2018, 04:31:48 am »
Quote from: Adam Boardman
Building just now, should be ready to test in 30mins.

thanks a lot!
I'll try later

salvo
Gemini, Psion S5 and S5mx, iPhone, iPad, Huawei MediaPad M5, some HP calculators.
Psion Fans Italia moderator

salvomic

  • Sr. Member
  • ****
  • Posts: 290
    • View Profile
Debian TP2: no Italian kbd
« Reply #5 on: June 29, 2018, 05:38:40 am »
I would try,
but with Italian locale in lxqt Terminal (both layout it or us) I get / but not - that is nowhere and I cannot use the combination FN-key with the Gemini keyboard layout...
So, help, please

Should I revert to US locale?

salvo
Gemini, Psion S5 and S5mx, iPhone, iPad, Huawei MediaPad M5, some HP calculators.
Psion Fans Italia moderator

Adam Boardman

  • Full Member
  • ***
  • Posts: 191
    • View Profile
Debian TP2: no Italian kbd
« Reply #6 on: June 29, 2018, 05:47:08 am »
So just to check, you've upgraded (apt update 'n' upgrade). Then you logged out and picked from the SDDM menu (Italian flag). Then for example if you went into lxqt keyboard layout selection you'd find it says Planet Computers Gemini as the keyboard model? If not then you've set some custom config that is overriding things, you need to first remove those and then try again.

salvomic

  • Sr. Member
  • ****
  • Posts: 290
    • View Profile
Debian TP2: no Italian kbd
« Reply #7 on: June 29, 2018, 06:19:42 am »
Quote from: Adam Boardman
So just to check, you've upgraded (apt update 'n' upgrade). Then you logged out and picked from the SDDM menu (Italian flag). Then for example if you went into lxqt keyboard layout selection you'd find it says Planet Computers Gemini as the keyboard model? If not then you've set some custom config that is overriding things, you need to first remove those and then try again.

ok!
after apt update upgrade, there is now the Italian flag! I choose it,
Then I choose mapping for Italian Planet Computers Gemini, but now I've / (shift-7) but not -  (dash) that in Italian Android Gemini is on FN-. (the key .  with FN pressed...
How can I use the Gemini combination FN-key?
Otherwise how can I input
setxkbmap -v ?

salvo

EDIT: wow!
I used a tip: input man or other command, select -, then middle key, so I could type
setxkbmap -v
And then I have - also (with FN-.) and all other keys with FN
Thanks!
salvo
« Last Edit: June 29, 2018, 06:30:20 am by salvomic »
Gemini, Psion S5 and S5mx, iPhone, iPad, Huawei MediaPad M5, some HP calculators.
Psion Fans Italia moderator

Adam Boardman

  • Full Member
  • ***
  • Posts: 191
    • View Profile
Debian TP2: no Italian kbd
« Reply #8 on: June 29, 2018, 06:30:50 am »
I think I've muddled you up.

The 'setxkbmap it' is a for this session only way of testing a keyboard layout, so if you were editing the layout locally and then wanted to test your changes you'd run that after each edit of the file.

Once your happy with it you then pick the flag from the sddm login screen once and it sets your system to use that all the time. Next login you just leave it at the 'set by x' or whatever the default is. Remember that you have to press a key on the keyboard for it to know which keyboard its using so the US flag will show until you start typing.

There should be no other keyboard fiddling needed. And any other keyboard fiddling you've done will need undoing before the above will work.
« Last Edit: June 29, 2018, 06:36:22 am by Adam Boardman »

salvomic

  • Sr. Member
  • ****
  • Posts: 290
    • View Profile
Debian TP2: no Italian kbd
« Reply #9 on: June 29, 2018, 06:42:02 am »
Quote from: Adam Boardman
I think I've muddled you up.

The 'setxkbmap it' is a for this session only way of testing a keyboard layout, so if you were editing the layout locally and then wanted to test your changes you'd run that after each edit of the file.

Once your happy with it you then pick the flag from the sddm login screen once and it sets your system to use that all the time. Next login you just leave it at the 'set by x' or whatever the default is. Remember that you have to press a key on the keyboard for it to know which keyboard its using so the US flag will show until you start typing.

There should be no other keyboard fiddling needed. And any other keyboard fiddling you've done will need undoing before the above will work.

thanks again!
it works for the session.
I'm trying doing as you say, but after closing session and open again I cannot see the mod... maybe I've to add it to the keyboard-config. Please, a last help for this
« Last Edit: June 29, 2018, 06:50:08 am by salvomic »
Gemini, Psion S5 and S5mx, iPhone, iPad, Huawei MediaPad M5, some HP calculators.
Psion Fans Italia moderator

Adam Boardman

  • Full Member
  • ***
  • Posts: 191
    • View Profile
Debian TP2: no Italian kbd
« Reply #10 on: June 29, 2018, 09:17:49 am »
As I say, you have to remove whatever fiddling you'd done previously with keyboard configs, eg in lxqt delete any keyboard settings you put in there.

Possibly clear things out by making a new user account ('adduser newusername'), then compare the config files from that to the user your currently using.

Why?:
 - sddm login screen picking keyboard map will set a system wide keyboard (can be confirmed by flag changing as you type your password)
 - lxqt config will override that for a specific user
 - setxkbmap will override that for this session (and mess up if USB/BT keyboards have been used)
« Last Edit: June 29, 2018, 09:20:44 am by Adam Boardman »

salvomic

  • Sr. Member
  • ****
  • Posts: 290
    • View Profile
Debian TP2: no Italian kbd
« Reply #11 on: June 29, 2018, 09:45:00 am »
Quote from: Adam Boardman
As I say, you have to remove whatever fiddling you'd done previously with keyboard configs, eg in lxqt delete any keyboard settings you put in there.

Possibly clear things out by making a new user account ('adduser newusername'), then compare the config files from that to the user your currently using.

Why?:
 - sddm login screen picking keyboard map will set a system wide keyboard (can be confirmed by flag changing as you type your password)
 - lxqt config will override that for a specific user
 - setxkbmap will override that for this session (and mess up if USB/BT keyboards have been used)

Well!
I did it and now all went ok!
If only there were the same into GNURoot Debian (now userLAnd) + XSDL inside Android... There I've also troubles with - and /

Thanks Adam, very kind of you.

salvo

 [ Invalid Attachment ]

Now I must correct that message from Perl: "please check that your locale settings are supported..."
« Last Edit: June 29, 2018, 09:47:07 am by salvomic »
Gemini, Psion S5 and S5mx, iPhone, iPad, Huawei MediaPad M5, some HP calculators.
Psion Fans Italia moderator

Adam Boardman

  • Full Member
  • ***
  • Posts: 191
    • View Profile
Debian TP2: no Italian kbd
« Reply #12 on: June 29, 2018, 10:26:03 am »
Fairly certain that you should be able to add your locales? (remember to pick UTF8)

https://github.com/gemian/gemini-keyboard-a...bianTP2#locales
« Last Edit: June 29, 2018, 10:37:12 am by Adam Boardman »

salvomic

  • Sr. Member
  • ****
  • Posts: 290
    • View Profile
Debian TP2: no Italian kbd
« Reply #13 on: June 29, 2018, 11:20:37 am »
Quote from: Adam Boardman
Fairly certain that you should be able to add your locales? (remember to pick UTF8)

https://github.com/gemian/gemini-keyboard-a...bianTP2#locales

yes, I'll do it, controlling all later.
thanks

salvo
Gemini, Psion S5 and S5mx, iPhone, iPad, Huawei MediaPad M5, some HP calculators.
Psion Fans Italia moderator

salvomic

  • Sr. Member
  • ****
  • Posts: 290
    • View Profile
Debian TP2: no Italian kbd
« Reply #14 on: October 26, 2018, 05:45:22 am »
please, Adam, help: after the installation of the new firmware (here triple boot), I overwrote Linux and again I cannot see the Italian flag (there is more that configuration in this link?).
I made
Code: [Select]
apt update; apt upgrade then input
Code: [Select]
setxkbmap -v it-IT but I get some errors ("error loading the new keyboard description" or also "duplication...") and after reboot I cannot see the Italian flag in the list...

Salvo
« Last Edit: October 26, 2018, 06:08:21 am by salvomic »
Gemini, Psion S5 and S5mx, iPhone, iPad, Huawei MediaPad M5, some HP calculators.
Psion Fans Italia moderator