Author Topic: Double Backspace  (Read 1775 times)

kc853

  • Newbie
  • *
  • Posts: 6
    • View Profile
Double Backspace
« on: October 04, 2018, 07:44:30 am »
Hi,
can someone confirm that the Gemini is performing double Backspace strokes within the great anWriter text editor app?
For me it's just that key. In combination with Ctrl or Alt it's a single stroke as expected.
 
Regards.

jakfish

  • Sr. Member
  • ****
  • Posts: 364
    • View Profile
Double Backspace
« Reply #1 on: October 04, 2018, 04:08:11 pm »
This double key action with a single press can be replicated in TextMaker, though not with the backspace. With TM, it's the arrow keys that work twice with one press. SoftMaker support was at a loss as to why.

Your success with backspace and Ctrl or Alt makes me wonder if I could use the same workaround by adding a Ctrl/Alt to the arrow keys.

Sorry about your hassle but thank you for your troubleshooting ideas,
Jake

gymbo

  • Sr. Member
  • ****
  • Posts: 262
    • View Profile
Double Backspace
« Reply #2 on: October 05, 2018, 01:46:03 pm »
Quote from: jakfish
This double key action with a single press can be replicated in TextMaker, though not with the backspace. With TM, it's the arrow keys that work twice with one press. SoftMaker support was at a loss as to why.

Your success with backspace and Ctrl or Alt makes me wonder if I could use the same workaround by adding a Ctrl/Alt to the arrow keys.

Sorry about your hassle but thank you for your troubleshooting ideas,
Jake
Please report back on wether or not it works in Textmaker (and the spreadsheet-program) as I am not completely satisfied with my current office-applications. (But as I've stated earlier, that bug/problem is a no-go for me).

kc853

  • Newbie
  • *
  • Posts: 6
    • View Profile
Double Backspace
« Reply #3 on: October 06, 2018, 11:09:34 am »
Quote from: gymbo
Please report back on wether or not it works in Textmaker (and the spreadsheet-program) as I am not completely satisfied with my current office-applications. (But as I've stated earlier, that bug/problem is a no-go for me).

I couldn't find any combination for the cursor problem in Textmaker. Too bad.

gymbo

  • Sr. Member
  • ****
  • Posts: 262
    • View Profile
Double Backspace
« Reply #4 on: October 06, 2018, 04:53:02 pm »
Quote from: kc853
I couldn't find any combination for the cursor problem in Textmaker. Too bad.
Thanks for replying! (Although it wasn't what I hoped for... And not really surprising as alt- and ctrl-combinations with arrow keys in other applications gives things like word-jump and home/end for left/right arrow  )

jakfish

  • Sr. Member
  • ****
  • Posts: 364
    • View Profile
Double Backspace
« Reply #5 on: October 06, 2018, 06:33:54 pm »
I edited the *.kcm file, and made an apk, but I didn't have any luck. I programmed the fn-left arrow to move one space rather than "Home," but it still moved two spaces.

The left arrow command is "fallback DPAD_LEFT", which appears to be two commands, and if one isn't necessary, it defaults to the second throughout the Gemini. Somehow, TextMaker recognizes both commands, fails to default, which turns into two key presses. The .kcm crashed when I tried using "DPAD_LEFT" instead of "fallback DPAD_LEFT".

There is a fallback command in the Delete key as well, which may account for the anWriter backspace issue, though perhaps not, given that the user can employ a control-backspace to generate one backspace. There were some fallback problems with Termux and I saw the git and they were able to fix it with a patch. But TM isn't exactly open source.

Jake
« Last Edit: October 06, 2018, 06:35:45 pm by jakfish »

jakfish

  • Sr. Member
  • ****
  • Posts: 364
    • View Profile
Double Backspace
« Reply #6 on: October 07, 2018, 10:53:02 am »
Okay, folks, here's the workaround for the double-press cursor in TextMaker HD.

Go Tools/Customize/Keyboard Mappings

With Default highlighted, click Edit

Under Group, go to Editing

In Editing, under Command, click on "Character left"

In the Shortcut box ("Please press accelerator"), I chose Ctrl+Left (Control with left arrow)

Hit OK

Then hit Apply

There are also keyboard mappings available for Line up, Line down, and Character right.

I chose Control for the accelerator since my Alt key is already heavily keystroked and the Control key (at least on the US keyboard) is easily found (furthest left key on the fifth row).

[I have not yet figured out how to make the keystroke repeat when by holding it down. EDIT: it seems to be an issue with Control as choice of accelerator. If Alt is chosen instead, there is repeat upon holding down keystroke]

Thank you, kc853, for pointing us in the right direction, and I hope you find a solution to your backspace issue.

Jake
« Last Edit: October 07, 2018, 11:37:11 am by jakfish »

gymbo

  • Sr. Member
  • ****
  • Posts: 262
    • View Profile
Double Backspace
« Reply #7 on: October 07, 2018, 11:37:58 am »
Quote from: jakfish
Okay, folks, here's the workaround for the double-press cursor in TextMaker HD.

Go Tools/Customize/Keyboard Mappings
.....
Is this inside TextMaker? I just downloaded the free version to try it out, and it doesn't seem to have this setting/feature...

(I didn't want to start a trial just for testing this, and although I don't MIND paying for apps I need, I certainly think it would be a bit too much to pay to try this fix...)

And more importantly: Is there a similar setting/feature for the spreadsheet program?

I don't really know which "accelerator" I would pick either; all of Ctrl-, Fn- and ALt- already has their "use" in TextMaker, maybe a combination of two of them, if possible??

Thanks for figuring this out, and bringing it to my attention with the PM!

jakfish

  • Sr. Member
  • ****
  • Posts: 364
    • View Profile
Double Backspace
« Reply #8 on: October 07, 2018, 11:53:14 am »
You're very welcome, and yes, this workaround takes place in TextMaker itself.

I don't own the PlanMaker HD for Android, but I do have PlanMaker for Windows and under Keyboard (not Editing) in Keyboard Mappings, there does appear to be a Left, Right, Up, and Down commands available for keystroke.

And if I'm not mistaken, TM allows a combination of accelerators.

SoftMaker often runs specials on their apps--today, it seems that TextMaker HD and PlanMaker HD together costs $11USD.

Doesn't the Play Store give you 30 minutes to play with the app before sale becomes final? I seem to remember that...

That's not too bad,
Jake
« Last Edit: October 07, 2018, 11:56:48 am by jakfish »

gymbo

  • Sr. Member
  • ****
  • Posts: 262
    • View Profile
Double Backspace
« Reply #9 on: October 07, 2018, 01:03:58 pm »
Quote from: jakfish
You're very welcome, and yes, this workaround takes place in TextMaker itself.

I don't own the PlanMaker HD for Android, but I do have PlanMaker for Windows and under Keyboard (not Editing) in Keyboard Mappings, there does appear to be a Left, Right, Up, and Down commands available for keystroke.

And if I'm not mistaken, TM allows a combination of accelerators.

SoftMaker often runs specials on their apps--today, it seems that TextMaker HD and PlanMaker HD together costs $11USD.

Doesn't the Play Store give you 30 minutes to play with the app before sale becomes final? I seem to remember that...

That's not too bad,
Jake
Thanks, will have to look further into this!

FYI, for me the Softmaker "Office HD" apps seems to go for 40 NOK (~ 5 USD) each, which is what they have been at when I have looked at them before... So seems there is no "special" for me. (And it would have been a more expensive "special" if it was... And although that too would have been really SPECIAL, I don't really think it would be a deal I would like to make   ) And they do have the 30 day trial versions, so will probably try that for a time I know I will probably be using word/spreadsheet (and maybe presentation) software on my Gemini. If I just install them now I would probably either have to just experiment with it NOW to see how it works (and not just the workaround), without really producing anything, or using it for anything useful, OR manage to forget about it and have the trial run out before I get a chance to test it properly...                  

(Unless you are talking about versions for Windows, or a combination of Android/Windows??)

jakfish

  • Sr. Member
  • ****
  • Posts: 364
    • View Profile
Double Backspace
« Reply #10 on: October 07, 2018, 01:53:30 pm »
No, the 11USD is for Android TextMaker HD and Android PlanMaker HD in US.

Man, if you can get both apps for 10USD in Norway, what are you waiting for?

Doesn't a beer cost 10USD in Norway? And these will last a lot longer

Anyway, just kidding--you know best about your money.

Jake

Eldkatten

  • Jr. Member
  • **
  • Posts: 98
    • View Profile
Double Backspace
« Reply #11 on: October 07, 2018, 02:34:56 pm »
Hello,

it actually works with Planmaker HD on the Gemini :-)
There you go to (I switched the dialog language to 'English UK' for this porpose) Tools - Customize - Keyboard mappings. Higlight "Default" and click "Edit".
You find the mapping under "Keyboard", quite at the end of the list. There you highlight in order "Left", "Right", "Up" and "Down", each time click into the field "Please press accelerator" and press Cntrl and the appropriate arrow on the keyboard. On my Gemini the important button is below the lower end of the screen, so each time scroll down and push "Add".
When you're ready, click "Ok" in the upper right, and in the next dialog push "Apply".

Ready! Thanks to those having the original idea.

Kind regards

P.S.: Works with Textmaker HD as well, just as dicribed in jakfish's post above.
« Last Edit: October 07, 2018, 02:40:58 pm by Eldkatten »

jakfish

  • Sr. Member
  • ****
  • Posts: 364
    • View Profile
Double Backspace
« Reply #12 on: October 08, 2018, 10:43:27 am »
I'm glad we figured this out. TextMaker has many more features than Word and the rest of the crew. And I'm happy that PlanMaker can be tweaked as well, to get rid of the doubled-cursor.

Jake