Author Topic: Ubuntu with userland  (Read 1082 times)

LinuxGuy

  • Newbie
  • *
  • Posts: 30
    • View Profile
Ubuntu with userland
« on: January 03, 2020, 07:47:58 am »
Hi folks,
I am pretty new here, with only a little Linux knowledge. I use it as main OS at home and backed the cosmo to have a tiny Linux Laptop on the go. As we are still waiitng for the promised nativ linux -support, I played aroudn with userland-app. I finallygot lxde running, but:
- all desktop elements are so tiny, that the system is unusable (forwordprocessing p.e.)
- changing configuration files to correct this fail, as the keyboard doesnt really match. Having a german keyboard, i choose plain german in the installation process (from 10 variants).
- external mouse (via usb-c) does not work

Any help would be appreciated.

NormMonkey

  • Full Member
  • ***
  • Posts: 110
    • View Profile
Ubuntu with userland
« Reply #1 on: January 03, 2020, 08:58:34 am »
Quote from: LinuxGuy
- changing configuration files to correct this fail

Have you tried adjusting the DPI in X?  Most applications (using Qt, GTK, etc.) will respect it.

This article has useful information: https://wiki.archlinux.org/index.php/Xorg#D...ay_size_and_DPI
Try for example:
xrandr --dpi 192

Note you will need to restart applications so that they notice the change.  
Also note the bit about the optional Xresource
Xft.dpi  
You may need to explicitly set this to the same value (e.g. 192)
« Last Edit: January 03, 2020, 08:59:18 am by NormMonkey »

LinuxGuy

  • Newbie
  • *
  • Posts: 30
    • View Profile
Ubuntu with userland
« Reply #2 on: January 04, 2020, 01:03:26 am »
Hi NormMonkey


thanks for your help.
Quote from: NormMonkey
Try for example:
xrandr --dpi 192
This doesnt work: "RandR extension missing" Also in reading the arch-wiki entry, I couldnt find a solution.
Any ideas?

NormMonkey

  • Full Member
  • ***
  • Posts: 110
    • View Profile
Ubuntu with userland
« Reply #3 on: January 06, 2020, 09:28:52 am »
Quote from: LinuxGuy
Hi NormMonkey


thanks for your help.
Quote from: NormMonkey
Try for example:
xrandr --dpi 192
This doesnt work: "RandR extension missing" Also in reading the arch-wiki entry, I couldnt find a solution.
Any ideas?

Hmmm, if tweaking the Xresource Xft.dpi doesn't work either, then I don't have anything else off the top of my head.
I think you can tweak Xft.dpi using xrdb temporarily, and set it permanently in .XResources once you have something that works, but I'm just going by old memory so don't quote me on that

LinuxGuy

  • Newbie
  • *
  • Posts: 30
    • View Profile
Re: Ubuntu with userland
« Reply #4 on: September 28, 2020, 11:07:20 pm »
Hi folks,
I am pretty new here, with only a little Linux knowledge. I use it as main OS at home and backed the cosmo to have a tiny Linux Laptop on the go. As we are still waiitng for the promised nativ linux -support, I played aroudn with userland-app. I finallygot lxde running, but:
- all desktop elements are so tiny, that the system is unusable (forwordprocessing p.e.)

Discovered an  easy  fix:
in the linux--filesystem, just edit screen-resolution to your liking in ~/.vncrc - works like charm! Userland, once set up makes for a good Linux Option without need for reboot!
I use 1140x560
« Last Edit: September 29, 2020, 01:10:16 am by LinuxGuy »