Author Topic: NAND-Bricked my SL-C750 and looking for bootloader copy  (Read 90 times)

JustAnother

  • Newbie
  • *
  • Posts: 6
    • View Profile
NAND-Bricked my SL-C750 and looking for bootloader copy
« on: June 15, 2021, 04:17:13 pm »
Hello, it's me again! It seems I've played with Zaurus too much: after brute force reset (just taking off battery) device is stopped to power on, LEDs not working, combo keys like OK+Power, D+M, D+B not working too. But C+D combo still works: on an empty CF card Mail LED started flashing. On old Russian  forum HPC.ru I found that this means I need to recover my bootloader. Unfortunately, I was unable to find anything about it. The NAND Backup (like those DBK files, obtained from Trisoft.de) is useless in my case?

Tried Fn+D+M combo, worked but after moving DBK on formatted CF and inserting it I got message "Can not initialize CF". What is that?

Used 1 Gb SDcard, NAND restored, but device is still dead. This means that built-in flash memory died?

Unfortunately yes, 4096 bad blocks in NAND. Too bad(

« Last Edit: June 16, 2021, 05:16:02 am by Varti »

Varti

  • Administrator
  • Hero Member
  • *****
  • Posts: 1148
    • View Profile
Re: NAND-Bricked my SL-C750 %u2013 looking for bootloader copy
« Reply #1 on: June 16, 2021, 05:05:19 am »
Damn, really sorry for that, I was going to reply to your other thread :( The only thing that might still work on it could be kexecboot on NAND, to boot any distro off an SD or CF card. Otherwise, the only way to fix this would be to desolder the NAND and solder another one in its place, but that's not guaranteed to work. It might be much easier to pick one of those cheap second-hand Zauruses on Yahoo Japan Auction. I'm currently looking for a 5000D there myself.

https://buyee.jp/item/search/query/sharp%20zaurus?searchHis=1

Varti
Planet Gemini PDA WiFi/LTE with Mediatek x27
SL-C1000 running Arch Linux ARM May2017, K30225 Wi-Fi CF Card, 64GB SDXC card
and many other Zauruses!

JustAnother

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: NAND-Bricked my SL-C750 and looking for bootloader copy
« Reply #2 on: June 16, 2021, 07:25:12 am »
Thanks, I'm considering to obtain a new one. Played with my semi-broken and found an interesting moment. I played around diagnostic menu and make this – first attempted to NAND Erase (anyway it's nothing to lose for me), got an error (ecc related, as I can remember), then activated option NAND Read&Write Rpt. Strangely, but this thing worked – procedure was ended without error, and after this option NAND Bad Blocks says it's none founded and everything is OK. But device still not working properly – after choosing "EXTRA" – "Zaurus Test" – "Reset" (or "Off") no reaction to pressing on "Power" button and both LED constantly on (not blinking). After removal of battery it even stops doing this, and only reboot from diagnostic menu returns LEDs to work. Also tried to run NAND CheckSum, and got NG status on positions ROFLSYS and PRESET. Tried to flash NAND Backup, downloaded from Trisoft.de – it's restoring without error (only from 1 Gb SD, CF still not working), but no help at all, device is still dead. It's definitely a hardware issue?

Varti

  • Administrator
  • Hero Member
  • *****
  • Posts: 1148
    • View Profile
Re: NAND-Bricked my SL-C750 and looking for bootloader copy
« Reply #3 on: June 16, 2021, 11:34:59 am »
We used to have a Zaurus wiki containing lots of info and many tutorial, though it needed a cleanup and reorganization. An upgrade was planned but I have not yet found some free time to do it. I'll see if I'll manage to put online a copy of the old version in the next days, no promises though, you might find some help there. The two LEDs being constantly turned on might be an indication that the device is being flashed, or at least it's attempting to do so:

https://www.oesf.org/repository/websites/cacko-crow/flash_instructions.html

Varti
Planet Gemini PDA WiFi/LTE with Mediatek x27
SL-C1000 running Arch Linux ARM May2017, K30225 Wi-Fi CF Card, 64GB SDXC card
and many other Zauruses!