Author Topic: Mobile connection flipping  (Read 3413 times)

Oliver Riesen

  • Newbie
  • *
  • Posts: 8
    • View Profile
Mobile connection flipping
« on: December 19, 2022, 02:39:34 am »
Hi,

the mobile connection on my Astro is flipping. Sometime I have connection, sometime not. My german SIM card is from Telekom. I tried first and second SIM slot. First slot seems to work better. After restarting the device I have a connection for several hours. Then the connection ist lost ("No SIM Card"). Second slot ist flipping every few minutes from connected to not connected and reverse.

That's annoying and the worst bug.

Regards
Oliver

TauPan

  • Newbie
  • *
  • Posts: 43
    • View Profile
    • http://
Re: Mobile connection flipping
« Reply #1 on: December 19, 2022, 04:56:33 am »
I have (almost) the same bug, also on "Telekom.de". I've contacted support at hello@planetcom.co.uk (which you definitely should do as well) and they've asked me to set "preferred network type" to 4G to see if it helps and it didn't make a difference at all.

Also I see no difference between first and second sim card slot. I'm waiting for the next instructions from support right now.

wovoja

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Mobile connection flipping
« Reply #2 on: December 19, 2022, 03:24:33 pm »
I am on Telekom too. I use SIM1 slot, I will try SIM2 later, in the moment I do not need mobile data speed, only WIFI and phone. I have set the preferred network type to 2G (!), then the telephone works. With 3/4/5G settings the network switches on and of, on and off... The Planet support is informed in detail since 9. August. I used an other SIM-card from O2 already with the same result. I hope for a real Planet support.

Varti

  • Administrator
  • Hero Member
  • *****
  • Posts: 1267
    • View Profile
Re: Mobile connection flipping
« Reply #3 on: December 20, 2022, 03:55:46 am »
the mobile connection on my Astro is flipping. Sometime I have connection, sometime not. My german SIM card is from Telekom. I tried first and second SIM slot. First slot seems to work better. After restarting the device I have a connection for several hours. Then the connection ist lost ("No SIM Card"). Second slot ist flipping every few minutes from connected to not connected and reverse.
This seems to me like a bad SIM contact issue in the SIM holder, providing that the "No SIM Card" error is actually correct. Have you tried using another SIM card?
Though I see that all of you are having issues with the same mobile operator. It might be worth checking if the APN is correct. If the type of connection is set to IPv6, it might be worth to try to set it to IPv4 only too; where I live IPv6 support is still under testing or must be deployed, only one operator officially supports it.

Varti
« Last Edit: December 20, 2022, 04:02:19 am by Varti »
Planet Gemini PDA WiFi/LTE with Mediatek x27
SL-C1000 running Arch Linux ARM May2017, K30225 Wi-Fi CF Card, 64GB SDXC card
and many other Zauruses!

Zarhan

  • Sr. Member
  • ****
  • Posts: 369
    • View Profile
Re: Mobile connection flipping
« Reply #4 on: December 20, 2022, 10:29:45 am »
Does the phone stay registered if mobile data is turned off and only starts flipping after you try to activate mobile data? If yes, then changing the bearer-type to IPv4 might indeed help. I've had this happen with laptop's mobile data SIM (not with DT though).

Oliver Riesen

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Mobile connection flipping
« Reply #5 on: December 27, 2022, 03:20:07 am »
I installed yesterday evening the app "GSM Signal Monitor & SIM Info" https://play.google.com/store/apps/details?id=paskov.biz.noservice. Since this moment my mobile connection didn't switch anymore.

wovoja

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Mobile connection flipping
« Reply #6 on: December 28, 2022, 02:04:58 pm »
@Oliver Riesen, Gratulation. so I installed "your" App GSM Signal Monitor and switched my Astro with SIM1 in the outer place from 2G to 4G.

- Again as written some days before (and in August to Planet) the alternating Signal from "no signal n/a" (10 to 30 seconds) to "great" (91...98 dB, some seconds) was switching repeatedly.

- With SIM2 in the medial place there was the same alternating but then I recognized that the App also showed SIM1!!!
- I restarted the Astro.
- Now the App showed SIM2. But the same flipping.
- I switsched the settings:
- I tried to switch the Access-Protocol from IPv4/IPv6 to IPv4
- I tried to switch the bearer from no specification to LTE
- I switched from the older APN to internet.v6.telekom

But always the same flipping...
I Googled +APN and +Mediatec (or +Redme) but no better infos.

- Back in Settings 2G instead of 3/4/5G the Signal is constant "great" after some seconds since another bearer is used than with 4G. Not just optimal for a 5G mobile internet access but enough for phone.

Hopeful there will come a solution from Planet in the next time.

wovoja

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Mobile connection flipping
« Reply #7 on: January 12, 2023, 04:02:44 pm »
On my phone LG G8s there is an App "Carrier Services" that is updated regularely via Google. In one of its comments is written that the carriers often use this app to correct, update and install some parameters and functions.

I installed this App on my Astro. Now the signet of datas with settings "preferred netwok type 4G" is constant and not flipping. But no data transfer to/from the WEB.

After reinstalling the App "GSM Signal Monitor" the App says 2G and great Signal. The same after restart the Astro...

I will wait for some time when the app is updated on the G8s (and Astro?).

And I will try again and again to find a Telekom Guy that can help me - sometimes it seems as difficult to find a non-only-selling-guy as with PC as I think (I wrote this problem to PC in August 2022).

StevieD49

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Mobile connection flipping
« Reply #8 on: March 01, 2023, 08:00:32 am »
I received my Astro here in the UK at the beginning of January 2023. Having previously read of issues with EE I decided to purchase a pre-pay EE sim to try before committing to  making the Astro my main driver.
The area where I live does not have 5G, just 4G.  The EE sim worked perfectly, with a strong stable connection. However as soon as I moved to an area with 5G area coverage I got the dropped signal reported above and the Astro kept cycling through trying to connect until eventually the No SIM error was displayed.  This behavior continued regardless of weither the sim was mounted in slot 1 or slot 2.
I then purchased a pre-paid sim from 3 and this has worked perfectly in both sim slots. There have been no issues with connection moving from a 4G to 5G area - the 3 sim works perfectly.
I then tried both sims at once - EE sim in slot 1, 3 sim in slot 2. Again in a 4G area both sims performed perfectly.  I tried using each one for data, calls and texts and every combination I could think of.  All worked perfectly.  Unfortunately as soon as I entered a 5G area the connection problems recurred, causing both sims  to lose connection and after a few minutes of trying the No Sim error was displayed. I tried swapping the slot positions of the sims and varying which sim was used for data, calls and texts, but nothing worked.  On returning to a 4G area the only way I could get connection again was by rebooting the Astro.  Thereafter the connection of both sims was stable as long as long as I remained in a 4G area. I even experimented with and without different sd cards mounted, but this has no effect on the connection behaviour.
As I sit here typing on the Astro I have the 3 sim in slot 1 working perfectly. The EE sim is in slot 2, but disabled.  Disappointingly I can't use the Astro as my main driver because EE is my telecoms provider and my  I'm tied into a sim deal for another 6 months.  I thought the EE issues had been resolved by a firmware update before the phone was delivered, but clearly this is not the case.
I just wanted to let you know of my experience in case it's helpful to someone with more technical knowledge than I.  I must say that I love the Astro and this small glitch has been a minor irritation rather than a deal-breaker.

polarwinkel

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Mobile connection flipping
« Reply #9 on: April 09, 2023, 11:16:36 am »
I can confirm this issue in the german Telekom-network, having my Astro now for a month or so.
Getting myself a prepaid sim in the Vodafone-network and I don't have any probems with that anymore, but that's no solutions for a daily driver.

I would guess it's the same/similar firmware-issue like the EE-issue in GB. Let's hope for a fix from PC for this...