Author Topic: Astro screen randomly shutting off  (Read 1989 times)

mrjpaxton

  • Newbie
  • *
  • Posts: 2
    • View Profile
Astro screen randomly shutting off
« on: January 04, 2024, 01:39:16 am »
Hey guys, I'm having a weird bug with the Astro where the screen sometimes turns off randomly. Can happen whenever I'm scrolling or just after scrolling, it seems. Anyone else had that problem?

It actually just started happening more recently, like after a year of using it.

It will still show up when I do "adb devices" over USB. I would try getting "adb shell" then "logcat", but it's hard because it says the phone is not authorized, and the screen is turning off randomly, but also predictably sometimes (if that makes any sense) making it hard and frustrating to use the device properly. Any ideas?

mrjpaxton

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Astro screen randomly shutting off
« Reply #1 on: January 04, 2024, 01:49:13 am »
Okay I'm able to get adb and logcat running, and I think this snippet of messages may relate to what's going on here:

Code: [Select]
01-03 22:45:21.910  1133  1139 E RILC    : getVoiceRegistrationStateResponse Invalid response: NULL                                                                                                                                           
01-03 22:45:23.115   621   843 E hwcomposer: [DRMDEV] failed to drmWaitVBlank with dpy_0: -1                                                                                                                                                   
01-03 22:45:23.115   621   843 W hwcomposer: (0) failed to waitNextVsync: -1
01-03 22:45:23.116   621   843 E hwcomposer: [DRMDEV] failed to drmWaitVBlank with dpy_0: -1 
01-03 22:45:23.116   621   843 W hwcomposer: (0) failed to waitNextVsync: -1
01-03 22:45:23.133   621   843 E hwcomposer: [DRMDEV] failed to drmWaitVBlank with dpy_0: -1 
01-03 22:45:23.133   621   843 W hwcomposer: (0) failed to waitNextVsync: -1
01-03 22:45:23.148   662   721 I BufferQueueProducer: [StatusBar#0](this:0xb40000739dea0858,id:6,api:1,p:1580,c:662) queueBuffer: fps=0.16 dur=6353.37 max=6353.37 min=6353.37
01-03 22:45:23.149   621   843 E hwcomposer: [DRMDEV] failed to drmWaitVBlank with dpy_0: -1 
01-03 22:45:23.150   621   843 W hwcomposer: (0) failed to waitNextVsync: -1
01-03 22:45:23.162   662   662 I BufferQueueProducer: [FramebufferSurface](this:0xb40000738dae7340,id:-1,api:1,p:662,c:662) queueBuffer: fps=0.16 dur=6349.95 max=6349.95 min=6349.95
01-03 22:45:23.163   621   621 I hwcomposer: [HWCDisplay] [Display_0 (type:1)] fps:0.157482,dur:6349.93,max:6349.93,min:6349.93 
01-03 22:45:23.166   621   843 E hwcomposer: [DRMDEV] failed to drmWaitVBlank with dpy_0: -1 
01-03 22:45:23.166   621   843 W hwcomposer: (0) failed to waitNextVsync: -1
01-03 22:45:23.244   621   843 E hwcomposer: [DRMDEV] failed to drmWaitVBlank with dpy_0: -1 
01-03 22:45:23.244   662   829 W HWComposer: Ignoring duplicate VSYNC event from HWC for display 0 (t=1341692284000)
01-03 22:45:23.244   621   843 W hwcomposer: (0) failed to waitNextVsync: -1
01-03 22:45:23.249   621   843 E hwcomposer: [DRMDEV] failed to drmWaitVBlank with dpy_0: -1 
01-03 22:45:23.250   621   843 W hwcomposer: (0) failed to waitNextVsync: -1

Not sure though.

gary99

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Astro screen randomly shutting off
« Reply #2 on: January 07, 2024, 01:36:50 pm »
Hey, i also noticed that with my AstroSlide after updating to V7. I found a possible solution (worked for me): Turn of the automatic brightness in the display settings.

Good luck!

Daniel W

  • Sr. Member
  • ****
  • Posts: 372
    • View Profile
Re: Astro screen randomly shutting off
« Reply #3 on: February 15, 2024, 06:38:56 am »
Sorry for being late to the party. I had this issue too, even before the V07 update.

In my case, I narrowed it down to the screen brightness. If set below 17%, my screen would soon go completely black. Increasing the brightness manually (Fn+N on my Fin/Swe layout) made it wake up again. This issue made auto brightness useless for me, as the screen would go black when it got dim enough, so I used to set my brightness manually and avoid going below 20%.

I hoped V07 would fix the issue, but it completely disabled my screen (my Astro has been with Planet for months, without getting fixed and now they seem to have stopped responding to e-mail too). :-\