Author Topic: SL5500:OZ 3.3.6pre1 & OPIE 1.1.4 Snapshot preload custom  (Read 11188 times)

claude

  • Newbie
  • *
  • Posts: 8
    • View Profile
SL5500:OZ 3.3.6pre1 & OPIE 1.1.4 Snapshot preload custom
« Reply #15 on: May 25, 2004, 04:53:11 pm »
Quote
First of all, I would like to thank Greg2 for the really useful link. Secondly, is anyone using a pdf viewer, email client that works with 3.3.6pre1? I am not able to get any working (qpdf, mailit, qtmail etc).
Perhaps qpdf2 + oz-compat-opie  (http://www.mithis.com/zaurus/ipkgs/)  if 3.3.6pre1 gcc 3.3.2  ?
BUT I do not know if it will work !!

ironstorm

  • Jr. Member
  • **
  • Posts: 86
    • View Profile
    • http://
SL5500:OZ 3.3.6pre1 & OPIE 1.1.4 Snapshot preload custom
« Reply #16 on: May 25, 2004, 11:34:01 pm »
Quote
Will this work or be modified for the sl-5600?


I don\'t have a 5600, but here is the script I used to do the upgrade

Code: [Select]
#!/bin/sh



alias beep=\'echo -en "\007"\'



# ipkg remove qpf-bitstream-vera-light; ipkg install opie-common libopiedb2 sqlite



PKGLST="libqte2 libqpe1 libopie1 libopiedb2

opie-addressbook opie-advancedfm opie-appearance opie-aqpkg opie-backup opie-batteryapplet opie-button-settings

opie-calculator opie-cardmon opie-citytime opie-clipboardapplet opie-clock opie-clockapplet opie-common opie-datebook

opie-deco-flat opie-deco-liquid opie-deco-polished opie-doctab opie-drawpad opie-embeddedkonsole opie-i18n-en

opie-irdaapplet opie-keytabs opie-language opie-light-and-power opie-liquid opie-login opie-multikey opie-networksettings

opie-networksettingsplugin-kppp opie-networksettingsplugin-wlan

opie-osearch opie-pickboard opie-pics opie-qcop opie-quicklauncher opie-screenshotapplet opie-security

opie-sounds opie-style-flat opie-style-fresh opie-sysinfo opie-systemtime opie-taskbar opie-textedit opie-today

opie-today-addressbookplugin opie-today-datebookplugin opie-today-todolistplugin opie-todo opie-volumeapplet opie-wirelessapplet

libopieobex0"



# opie-launcher-settings

# opie-opiealarm



ipkg remove qpf-bitstream-vera-light



for PKG in $PKGLST; do

#  echo

  ipkg remove $PKG

done



sleep 10



for PKG in $PKGLST; do

# echo $PKG

  ipkg install $PKG

  sleep 2

done



## All Done.

beep; sleep 1;

beep; sleep 1;

beep; sleep 1;

beep; sleep 1;

ln -s /usr/lib/libsqlite.so /usr/lib/libsqlite.so.0


and then use OZone to back it up to a ROM.

Greg2

  • Hero Member
  • *****
  • Posts: 790
    • View Profile
    • http://
SL5500:OZ 3.3.6pre1 & OPIE 1.1.4 Snapshot preload custom
« Reply #17 on: May 26, 2004, 04:20:26 pm »
Quote
is anyone using a pdf viewer, email client that works  

Make sure you have installed the following from the proper feed:

libetpan
libmailwrapper
libopie2
opie-mail
opie-mailapplet
opie-qpdf

The feed:
http://opie.handhelds.org/feed/openzaurus/...le-gcc3/SL5xxx/

libpcap
and anything else you need are in this feed:
http://www.openzaurus.org/official/experim...4.18-gcc3/ipks/

If you use the AQPkg-Package Manager the output will tell you (sometimes) if you need anything else. If it\'s not in the first feed you can \'try\' to use some things in the other feed.

You can also use the Openzaurus-users mailing list where other users solve these problems:
https://lists.sourceforge.net/lists/listinf...penzaurus-users

Greg

Keola

  • Newbie
  • *
  • Posts: 48
    • View Profile
    • http://fruitwerks.us
SL5500:OZ 3.3.6pre1 & OPIE 1.1.4 Snapshot preload custom
« Reply #18 on: May 27, 2004, 03:00:04 pm »
I am using the supplied tar file.. that script rendered my Oz unusable... I can\'t even get Oz reflashed.. Sharp-based works though.. and anyway how do you get to the console in Oz?  When I quit opie, it just says openzaurus login: and is frozen.

circuit_breaker

  • Newbie
  • *
  • Posts: 8
    • View Profile
SL5500:OZ 3.3.6pre1 & OPIE 1.1.4 Snapshot preload custom
« Reply #19 on: June 12, 2004, 01:26:58 am »
Quote
You\'d have noticed this if you\'d run OZ3.3.6pre1 before, as that is a problem common to all ROMs built off of it... (I didn\'t upgrade any non-opie packages, I didn\'t even do all of the opie ones - just enough to get the basics and pim stuff working)


All of that stuff worked for me before with my ambicom just fine, but with this new flash it\'s broken.  My 5500 detected the Ambicom wireless CF card but I don\'t get a WLAN configuration tab, just a DHCP and IP config window.  Anyone else see that?

circuit_breaker

  • Newbie
  • *
  • Posts: 8
    • View Profile
SL5500:OZ 3.3.6pre1 & OPIE 1.1.4 Snapshot preload custom
« Reply #20 on: June 12, 2004, 04:33:29 am »
I figured out my problem, after editing wireless.conf in /etc/pcmcia everything is functioning WLAN wise.  My wireless router is selective about ESSID and whatnot, so w/out specifics it wasnt gonna find it.  I suppose this opie just doesnt have the extra config apps for it like previous ones? I had tried to reinstall pkgs earlier and ended up digging around by hand... i can say, i feel a lot better on the 5500 keypad already and it\'s not a hassle much anymore.

Just wish the clipboard was more reliable  seems to not work in a lot of instances.

yay a stable-appearing oz installation.   finally.  Now to figure out how to install apps with minimal breakage, and not fill my root fs -AGAIN-

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
SL5500:OZ 3.3.6pre1 & OPIE 1.1.4 Snapshot preload custom
« Reply #21 on: June 15, 2004, 06:22:45 pm »
Well just for something to do I uninstalled the packages listed above (from my C750 with OZ3.3.6pre1) and then manually installed them from the opie 1.1.4 feed.

It works, but I don\'t have a touchscreen (which is a bit of an issue).

Any ideas as to how I should resolve this (other than reflashing of course)?

Cheers,


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
SL5500:OZ 3.3.6pre1 & OPIE 1.1.4 Snapshot preload custom
« Reply #22 on: June 15, 2004, 06:54:47 pm »
Well I\'ve played around a bit with it (using the keyboard).

It\'s nice that the Home key now works to change tabs (it didn\'t use to), but everything looks even smaller than it did before!

The reason I started messing about with this was to try out the new version of Konsole which alegedly allows one to change the font size (make it bigger!). Unfortunately, I can\'t access the font menu as the touchscreen isn\'t playing.

Just clearing out my CF for the reflash....


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

elvis

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
    • http://
SL5500:OZ 3.3.6pre1 & OPIE 1.1.4 Snapshot preload custom
« Reply #23 on: June 15, 2004, 07:43:40 pm »
APkg keeps on going nuts on me. I can\'t install anything. Anyone having this problem?

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
SL5500:OZ 3.3.6pre1 & OPIE 1.1.4 Snapshot preload custom
« Reply #24 on: June 16, 2004, 10:14:32 am »
Disclaimer: I promise I won\'t raise that issue ever again on this forum, since I\'m as fed up as you with it.

But once and for all... if you folks would spend just a fraction of the energy you spend into shaping up an outdated and unmaintained release without a future instead into helping us to get a current release out, then the world would be a better place.

I just can\'t understand that. Work on OZ 3.3.x is pretty much wasted and pointless and people who have experience enough to produce a derived work would be very valuable for the project\'s future. But with wasting your time on old releases you weaken us as a community.
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.

zenyatta

  • Sr. Member
  • ****
  • Posts: 366
    • View Profile
    • http://
SL5500:OZ 3.3.6pre1 & OPIE 1.1.4 Snapshot preload custom
« Reply #25 on: June 16, 2004, 10:26:42 am »
Mickeyl: people are tinkerers, they need something to tinker with - something they can flash rather than compile. Give them an OE-based pre-pre-alpha release and they will play with that. Bit of a chicken/egg problem there, isn\'t it...

z.
SL-5500, 256MB Kingston CF card, 128MB EDGE SD card, Thomson HED-155 headphones
OpenZaurus 3.5.3 / Opie (kernel 64-0)

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
SL5500:OZ 3.3.6pre1 & OPIE 1.1.4 Snapshot preload custom
« Reply #26 on: June 16, 2004, 12:18:39 pm »
It\'s my view that people who want to help us will have to build images themselves anyway. If I put one up I probably just get \"this and that doesn\'t work\" and this is not bringing us forward since we already know what doesn\'t work (http://openembedded.org/oe_wiki/index.php/OzTODO3.5.1)- we would need competent testers who can fix things.

You can\'t really test fixes without building images.
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.

ironstorm

  • Jr. Member
  • **
  • Posts: 86
    • View Profile
    • http://
SL5500:OZ 3.3.6pre1 & OPIE 1.1.4 Snapshot preload custom
« Reply #27 on: June 16, 2004, 05:00:56 pm »
Quote
But once and for all... if you folks would spend just a fraction of the energy you spend into shaping up an outdated and unmaintained release without a future instead into helping us to get a current release out, then the world would be a better place.

I just can\'t understand that. Work on OZ 3.3.x is pretty much wasted and pointless and people who have experience enough to produce a derived work would be very valuable for the project\'s future.  


You know, I wonder why we bother too...  

Maybe it\'s because we operate in the dark (when\'s the last time you looked at the OZ homepage) or maybe it\'s because that\'s the last snapshot we have (and yes I know it\'s more then 6 months old) so we use it because we actually need to use PIM stuff or maybe it\'s because we don\'t want  to fuck around trying to set-up a toolchain to build something that might not even compile...

I can tell you that after my experince with OpieSDK ( http://www.zaurususergroup.com/index.php?n...c&p=23095#23095 ), which resulted in something unusable (change a widget in Qtdesigner and nothing compiles), I think the bar for entry is far too high...  

Maybe somewhere on the OE Wiki there is some page that says I can just do the following:  
Code: [Select]
apt-get install OE-toolchain OE-src-snapshot; cd /opt/OE/src; make clean; make initrd; make kernel
and get a working rom or a half-working rom, but how would I know?

Quote
But with wasting your time on old releases you weaken us as a community.


There is no OZ/OE community, we are but the left-overs...  

zenyatta

  • Sr. Member
  • ****
  • Posts: 366
    • View Profile
    • http://
SL5500:OZ 3.3.6pre1 & OPIE 1.1.4 Snapshot preload custom
« Reply #28 on: June 16, 2004, 06:11:49 pm »
Erm... If I\'m correct, Mickey touched on this topic in his newest OE/OZ/Opie Newsletter (good job by the way).

The point about testers having to build stuff is a good one. There probably isn\'t any shortcut - we just need to plow through the process and if we can come up with a simpler HOWTO (or another way to lower the barrier to entry) then we need to share it.

Still, people limited to dial-up connections (such as myself) would prefer one big self-contained chunk to download and experiment with. If I understand things correctly, running oebuild opie-image means contacting CVS repositories and/or FTP servers of the individual packages. That\'s pretty much off limits for me (perhaps I\'m wrong).

z.
SL-5500, 256MB Kingston CF card, 128MB EDGE SD card, Thomson HED-155 headphones
OpenZaurus 3.5.3 / Opie (kernel 64-0)

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
SL5500:OZ 3.3.6pre1 & OPIE 1.1.4 Snapshot preload custom
« Reply #29 on: June 16, 2004, 06:58:30 pm »
Right. Even a small linux distribution like OpenZaurus contains heaps of sources which we download them from the respective upstream repositories. It probably isn\'t much fun with anything less than DSL. You also need around 4G of free storage for opie-image.
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.