Author Topic: Invalid magic  (Read 1299 times)

jnmonteiro

  • Newbie
  • *
  • Posts: 15
    • View Profile
    • http://
Invalid magic
« on: May 27, 2004, 04:01:44 pm »
Using OZ3.2 after playing around with OZ3.3.6pre1 (just decided to wait for OpenEmbedded) and am now finding the following error when trying to reinstall programs that used to work before:

   Dealing with package xxx
   ipkg: Invalid magic
   ipkg: *** Couldn\'t kill old gunzip process*** aborting loading conf file /etc/ipkg.conf

I believe that \"Invalid magic\" is due to not having certain libraries loaded.  But I am trying to load packages that just need the already installed required libraries.

BTW, I may have given up on OZ3.3.6pre1 too early, but there needs to be a decent HOW-TO on migrating from OZ3.2 to the new ROM including how to use the Hancom Apps.

Thanks

John

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Invalid magic
« Reply #1 on: May 28, 2004, 06:55:24 am »
invalid magic comes from a corrupt tar.gz (read ipk) file.


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva