Author Topic: wellenreiter II - opie 1.1.4 - oz 3.3.6-pre1  (Read 2523 times)

bluey

  • Full Member
  • ***
  • Posts: 125
    • View Profile
    • http://
wellenreiter II - opie 1.1.4 - oz 3.3.6-pre1
« on: May 27, 2004, 10:56:36 am »
Mickeyl: wellenreiter is complaining about wireless extensions differing... WL 15 to WL 16...

Is it opie 1.1.4 problem?

Is there a TODO for OE images? I believe when they\'re out I\'d be reporting problems helping development, as many other people, what is there to do to get them out?

Can anyone point (put together) out a well defined TODO to get OE OZ images on their way?

It was pointed out as a problem that keeps people from helping, should I need to go search and dedicate more time and effort on finding what is needed to be done? [EDIT] In opposition to read a detailed TODO and doing what is needed.[/EDIT]

What got out of that thread born about KDE\'s QA team?

Do people move to backstage when they are able to learn a bit more about everything and stop talking about what they\'re doing and what needs to be done?


It must be me, I better shut up and go seek information.
SL-5500 - OZ 3.5.3
256Mb Kingston SD Card
64Mb PQI CF Card
Netgear MA701 WiFi CF Card
Mandriva GNU/Linux LE2005
Dreaming of a C model...

bluey

  • Full Member
  • ***
  • Posts: 125
    • View Profile
    • http://
wellenreiter II - opie 1.1.4 - oz 3.3.6-pre1
« Reply #1 on: May 27, 2004, 11:04:48 am »
SL-5500 - OZ 3.5.3
256Mb Kingston SD Card
64Mb PQI CF Card
Netgear MA701 WiFi CF Card
Mandriva GNU/Linux LE2005
Dreaming of a C model...

x86Daddy

  • Newbie
  • *
  • Posts: 44
    • View Profile
    • http://
wellenreiter II - opie 1.1.4 - oz 3.3.6-pre1
« Reply #2 on: June 01, 2004, 02:39:34 pm »
Quote
wellenreiter is complaining about wireless extensions differing... WL 15 to WL 16...


I\'m getting the same thing (WE V15 vs WE v16)...  Please post if you find / have found a solution.

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
wellenreiter II - opie 1.1.4 - oz 3.3.6-pre1
« Reply #3 on: June 01, 2004, 03:34:00 pm »
WE (Wireless Extensions) V15 vs. WE V16 is an artifact of the Opie packager compiling Wellenreiter II using a home-brewn toolchain including kernel headers (which is not really a good idea). WE V15 and V16 are binary incompatible!

Earlier versions of Wellenreiter didn\'t make sure that the WE versions they were compiled against match the system they\'re running on. This lead to confusion and people getting the notion my fine software seemingly not working whereas it was the packager\'s fault (grrr!).

I won\'t have time to build own packages in the future, so your best bet is using OpenEmbedded to build Wellenreiter II or wait for the Opie packager releasing a new feed built with a more sane toolchain.
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
wellenreiter II - opie 1.1.4 - oz 3.3.6-pre1
« Reply #4 on: June 01, 2004, 03:35:39 pm »
By the way, I replied in another thread mail with an URL to the current OZ Todo.
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
wellenreiter II - opie 1.1.4 - oz 3.3.6-pre1
« Reply #5 on: June 02, 2004, 12:19:33 am »
Quote
I won\'t have time to build own packages in the future, so your best bet is using OpenEmbedded to build Wellenreiter II or wait for the Opie packager releasing a new feed built with a more sane toolchain.


Does that mean we\'re not going to see Wellenreiter buid for the Sharp ROM?

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
wellenreiter II - opie 1.1.4 - oz 3.3.6-pre1
« Reply #6 on: June 02, 2004, 09:36:13 am »
Martin Tuschik volunteered to build Opie 1.1.3 (which contains Wellenreiter 1.0.3) for the SharpROM. You might ask him on opie@handhelds.org to give a status update.
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
wellenreiter II - opie 1.1.4 - oz 3.3.6-pre1
« Reply #7 on: June 03, 2004, 04:27:36 am »
Quote
Martin Tuschik volunteered to build Opie 1.1.3 (which contains Wellenreiter 1.0.3) for the SharpROM. You might ask him on opie@handhelds.org to give a status update.


OK, thanks!

Do I understand correctly that Wellenreiter 1.0.3 will require exact version matching of wireless extentions? If so, tne I don\'t realy understand that - even wireless tools only give you a warning about a mismatched versions. And latest versions even handle different versions on runtime...

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
wellenreiter II - opie 1.1.4 - oz 3.3.6-pre1
« Reply #8 on: June 03, 2004, 05:06:51 am »
Yes, in the present form it requires exact matching. Everything else makes no sense in my opinion. As a program author I\'m not encouraging lazy packagers which compile my stuff false and then I get bug reports from people where instead the packager is to blame.
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
wellenreiter II - opie 1.1.4 - oz 3.3.6-pre1
« Reply #9 on: June 03, 2004, 06:36:02 am »
Quote
Yes, in the present form it requires exact matching. Everything else makes no sense in my opinion. As a program author I\'m not encouraging lazy packagers which compile my stuff false and then I get bug reports from people where instead the packager is to blame.


In this case, Sharp ROM version of wellenreiter will have to be compiled against WE 13, which is the version used in Sharp kernel. Then this version will be of no use to me, as I have my kernel patched to WE 15.

Well, no upgrade for me then, so be it. Version 1.0.2 (built by lardman if I\'m not mistaken) is still working fine...

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
wellenreiter II - opie 1.1.4 - oz 3.3.6-pre1
« Reply #10 on: June 03, 2004, 08:04:32 am »
Actually, if I ever make an open source version again, then I will probably tweak it not to need Wireless Extensions at all when detecting that it\'s running on the SharpROM. So... there\'s still hope ;-)
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
wellenreiter II - opie 1.1.4 - oz 3.3.6-pre1
« Reply #11 on: June 03, 2004, 08:20:06 am »
Quote
Actually, if I ever make an open source version again, then I will probably tweak it not to need Wireless Extensions at all when detecting that it\'s running on the SharpROM. So... there\'s still hope ;-)


Well, I\'m not counting on that any more