Author Topic: have we come up with a fix for the DATE/TIME yet?  (Read 2272 times)

omin0us

  • Full Member
  • ***
  • Posts: 105
    • View Profile
    • http://
have we come up with a fix for the DATE/TIME yet?
« on: July 13, 2004, 04:32:12 pm »
I don't know if this has been solved yet or not. but has anyone come up with a fix for the Date/Time settings on the latest rom yet? The clock always gets off when the zaurus is suspended. Its really annoying to have the Date and Time off when using PIMs. :-/. Thanks ahead of time if someone knows the fix for this.
pdaXrom Developer team member - http://www.pdaxrom.org
c760/X11 based ROM, sl-5500/OZ 3.3.5
Ambicom WL1100C-1 WiFi card, Targus CF 56k Modem.
Ericsson T610 phone. (still need a BT card though)
FreeBSD 4.8/Slackware 9.1

motorheadabega

  • Newbie
  • *
  • Posts: 7
    • View Profile
have we come up with a fix for the DATE/TIME yet?
« Reply #1 on: July 13, 2004, 07:39:12 pm »
The onboard clock has to be managed by the kernel, so this would have to be addressed in a future version of the ROM. I don't believe you'll see a fix in 1.0.6, but it has already been brought up in another thread. We are all aware of it.

Another idea would be to port ntp to pdaxrom. That would allow the Z to sync to a network clock at regular intervals. I believe this is on the roadmap also.

The thread on 1.0.6, while it is getting quite long, might be a better place to inquire.
SL-C860 pdaXrom 1.0.5
AmbiCom WL1100C-CF WiFi card
SanDisk Ultra II SD Storage card 512 MB

zxerx

  • Jr. Member
  • **
  • Posts: 61
    • View Profile
    • http://
have we come up with a fix for the DATE/TIME yet?
« Reply #2 on: July 14, 2004, 02:47:40 am »
This worked for me:
  • remove /etc/localtime if it exists (so that you are working in UTC)
  • use ntpdate to set the system clock to the correct time in UTC (or date --set)
  • use hwclock to set the hardware clock from the system clock(ie: hwclock --systohc)
  • tell hwclock to work in UTC (ie: hwclock --utc)
  • copy /usr/share/zoneinfo/whatever/whatever from a *nix box to /etc/localtime
  • turn zaurus on and off and enjoy having the correct time
[span style=\'font-size:7pt;line-height:100%\']Zaurus SL-C760 :: pdaXrom 1.0.5 :: Toshiba 512Mb SD :: Hagiwara 256Mb 10Mbit/s SD :: PQI 256Mb 40x CF :: Socket Low Power 10Mb/s Ethernet CF :: Seano WiFi CF :: Xircom 56k Modem CF[/span]

Laze

  • Hero Member
  • *****
  • Posts: 704
    • View Profile
    • http://www.pdaXrom.org
have we come up with a fix for the DATE/TIME yet?
« Reply #3 on: July 14, 2004, 07:21:29 pm »
The time/timezone problems are going to be fixed in the next release (fingers crossed).
C760 running pdaXrom lastest ;-)
SL5500 Running Cacko Qtopia
512 MB SD Card, 128 MB CF Card, Prism2 CF Wlan.

Always visit http://www.pdaXrom.org for latest news.