Author Topic: Troubles with FTP to X11  (Read 2132 times)

Reaper

  • Full Member
  • ***
  • Posts: 126
    • View Profile
Troubles with FTP to X11
« on: December 13, 2003, 02:48:24 pm »
After having the X11 ROM (version 0418081203) installed, I\'ve tried to connect to my Zaurus C760 via USB cable (as root with password, of course) and realized that it connects but it can\'t read subdirectories - it just hangs up instead. Also it can\'t transfer directories with a lot of files/or long filenames (especially!), though copying of several files without dirs works fine. I have the only user entry as a root. I tried to make an another user account to use for FTP transfers, but, unfortunately, useradd command doesn\'t seem to work at all (\"bad command\").

If anyone had the same experience and/or made it through this problem - please post your sitiation/suggestion here. My PC is powered by Win2K Pro/SP3, and I\'ve used standard IP-over-USB drivers from Japanese Zaurus CD which seemed to work fine with original ROM.

jerrybme

  • Hero Member
  • *****
  • Posts: 639
    • View Profile
    • http://
Troubles with FTP to X11
« Reply #1 on: December 13, 2003, 03:10:52 pm »
I\'ve used W2K, XP & Mandrake 9.2 without problems. Have you changed USB slots? I\'ve had to reinstall USB drivers to associate with different USB slot when I changed where I was plugging into.
SL-C3100
Angstrom-GPE
Lexar SD 1 GB
PQI 2GB CF
Ambicom WL1100 CF

Reaper

  • Full Member
  • ***
  • Posts: 126
    • View Profile
Troubles with FTP to X11
« Reply #2 on: December 16, 2003, 05:37:28 am »
No. I ever didn\'t remove the cable from the PC USB socket- only plugged it into Zaurus and out of it. In fact, even root dir doesn\'t work very good - trying to connect by ftp://ftp root@192.168.129.201 leads to hangup approximately 50% of times, especially when reconnecting

BTW, my motherboard is GA-7VAX.

jerrybme

  • Hero Member
  • *****
  • Posts: 639
    • View Profile
    • http://
Troubles with FTP to X11
« Reply #3 on: December 16, 2003, 07:15:46 am »
Quote
ftp://ftp root@192.168.129.201 leads to hangup approximately 50% of times, especially when reconnecting.

If you\'re using windblows explorer to ftp, it\'ll be slow and that may be your problem, try cuteftp or FlashFxp. I use FlashFxp without problems in W2K & XP.

Cheers
SL-C3100
Angstrom-GPE
Lexar SD 1 GB
PQI 2GB CF
Ambicom WL1100 CF

omin0us

  • Full Member
  • ***
  • Posts: 105
    • View Profile
    • http://
Troubles with FTP to X11
« Reply #4 on: December 16, 2003, 12:41:21 pm »
did you set a password on the zaurus itself? without one, FTP on Cacko linux will not connect. To do this open up the Terminal App and run the command \'passwd\'. it will then request that you enter a password and then confirm it. after that you may then FTP  in using that password.

regards,
omin0us
pdaXrom Developer team member - http://www.pdaxrom.org
c760/X11 based ROM, sl-5500/OZ 3.3.5
Ambicom WL1100C-1 WiFi card, Targus CF 56k Modem.
Ericsson T610 phone. (still need a BT card though)
FreeBSD 4.8/Slackware 9.1

Reaper

  • Full Member
  • ***
  • Posts: 126
    • View Profile
Troubles with FTP to X11
« Reply #5 on: December 16, 2003, 04:42:00 pm »
Yes, I did set the password. It\'s been written at the readme. So, problem can be due to Windows Explorer & FTP... Well, I\'ll try other programs with graphical interface and report about it.

P.S. I can even copy groups of files into subdirs of /home/root by dragging files onto the pictogram of required subdirectory. But I still cannot ENTER these subdirectories...

offroadgeek

  • Administrator
  • Hero Member
  • *****
  • Posts: 1419
    • View Profile
    • https://www.oesf.org
Troubles with FTP to X11
« Reply #6 on: December 16, 2003, 06:09:26 pm »
One note about using windows explorer (eek!) as an FTP client, sometimes I find that if I enter both the username AND password in the location bar, that sometimes helps... like this:

ftp://root:password@192.168.129.201
Search the OESF Wiki
C1000 w/Cacko 1.23 beta (from Streamline) / 760 pdaxrom rc9 / 6000L (thanks Santa's elf!) / 5500 - OZ 3.3.5 / SIMpad SL4
1GB, 256mb SanDisk CF / 2x 1GB, 512mb, 256mb, 128mb SanDisk SD
Ambicom WL100C-CF wifi / Socket 56k CF modem / AmbiCom BT2000-CF (x2)
Pocketop keyboard, Piel Frama case (1000 & 5500), PDAir case (760 & 1000)
sip:536093@fwd.pulver.com
| OESF | ELSI | Zaurus User Group | ZaurusThemes |

Reaper

  • Full Member
  • ***
  • Posts: 126
    • View Profile
Troubles with FTP to X11
« Reply #7 on: December 17, 2003, 12:10:00 am »
Yes, it definitely works better this way... even via Windows Explorer... enters subdirs almost without hangups... Thanks a lot!  

But... I still can\'t operate with files at the subdirectories (i.e. delete them). It just keeps hanging up (and after that, when restarting FTP,  I can\'t even enter these subdirectories).