Help - Search - Members - Calendar
Full Version: Suse 10.0 & Zaurus Sl-5500
OESF Portables Forum > Everything Else > Archived Forums > Zaurus General Forums > Desktop Operating Systems Issues > Linux Issues
I upgraded to SuSE 10.0 from 9.2 and I do not seem to be able to get the usbnet loaded automatically.

I can do:
# modprobe usbnet
# ifconfig usb0 netmask up

and ping/connect to the zaurus (runing OZ 3.5.1)

# ifconfig -a
shows correctly the usb0 (I also have the ifcfg-usb0 file in /etc/sysconfig/network
and the file ifroute-usb0 in the same directory.
This alone used to be enough in SuSE 9.2 to get connected each time, but know I have to do the modprobe as above after rebooting.
Is there a way to make this stick so the connection can be achieve after rebooting?
Do I have to add some script somewhere for this?

Many thanks in advance.
Well, I found out the solution myself so I am posting it in case it is of any use to others.

I added "usbnet" using Yast's /etc/sysconfig Editor.
I went to System>Kernel>MODULES_LOADED_ON_BOOT and added usbnet.
After rebooting, the zaurus can be connected even using Qtopia Desktop 1.7.0.

Thanks, worked like a charm! I had been looking for information on how to do this, and this thread was the only thing I found.

Thanks again.

I am using SuSE 10.0 but I don't know very much about setting up networking.
Can you help ?

QUOTE(-G- @ Nov 4 2005, 04:12 AM)
# modprobe usbnet
# ifconfig usb0 netmask up

If I do this, then try to connect to I get the local machine not the Zaurus.
This is what ifconfig tells me:

usb0      Link encap:Ethernet  HWaddr 86:66:13:82:C2:76
         inet addr:  Bcast:  Mask:
         inet6 addr: fe80::8466:13ff:fe82:c276/64 Scope:Link
         RX packets:43 errors:0 dropped:0 overruns:0 frame:0
         TX packets:122 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:5685 (5.5 Kb)  TX bytes:14218 (13.8 Kb)

Is this correct ?
I am running the Sharp ROM 3.13.

How can I make a connection to the Zaurus ?

thanks in advance


You are close. You are giving your desktop the same IP as the Zaurus, though. Try this:

# modprobe usbnet
# ifconfig usb0 netmask up

See if you are able to ping the Zaurus after that.
Hi fifer

Same problem! sad.gif
I ssh to and still get to my desktop.


I has some problems on SUSE 10.0. I get IO errors while plugin the Zaurus on my SUSE 10.0. After reloading the modul pxa27x_bi on the Zaurus it works for me.

You can relaod it with the following command:

# modprobe -r pxa27x_bi
# modprobe pxa27x_bi

I don't know if the module exist on you Zaurus. I am using Openzaurus 3.5.3 on a SL-C1000.

Also you can check:

# lsmod | grep usbnet

if the modul is really loaded.

What shows route -n on you Desktop?

Hope this will help you,
OK, here is what I have done to have the Zaurus connected to SUSE 10.0

In the desktop:
1. Create a file in the /etc/sysconfig/network called ifcfg-usb0 with the following entries:


2. Create a file in /etc/sysconfig/network called ifroute-usb0 with the following entry:
route add -host usb0

3. Set the Zaurus ip address to using the Z's Network application.

4. Set usb0 as the internal network in SuSEFirewall

5. In the desktop run this as root::
# modprobe usbnet
# ifconfig usb0 netmask up
# route add -host usb0
# ping
(this should show that there is a connection, abort with CTRL+C)

6. Add to /etc/hosts: zaurus

7. Make "usbnet" start when booting using Yast's /etc/sysconfig Editor.
Go to System>Kernel>MODULES_LOADED_ON_BOOT and add "usbnet" (without the quotations).

That's it
I hope I haven't forgot anything and that the steps are in the right order, Please post any corrections.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2020 Invision Power Services, Inc.