Help - Search - Members - Calendar
Full Version: Issue With Wget, Ipkg, Etc.
OESF Portables Forum > General Forums > Off Topic forum
I have an odd issue with wget, ipkg, apt-get, XVhat, and other apps that try to access the net. Many times they'll fail to find the site they're trying to access and assume it's IP is, then time out. It works much more often, if not almost always, over my desktop's wired connection, making me believe that it's a wireless thing.

Any ideas? This is getting really annoying.
I don't know how to fix it, but it sounds like a problem either with DHCP (ie getting your IP) or getting a nameserver (usually also assigned over DHCP when using WiFi). The only thing I would suggest is confirming the right WiFi settings and ejecting/reinserting the card, but I'm sure you've already tried that.
Basically you'll have to wait for someone better at this than me (which is most people) to help you out.

The nameserver used is located in /etc/resolv.conf, but I'm not sure how that gets assigned in pdaXrom.
I would run commands like "route" and "ifconfig" to see if/how you are connected before trying to do wget, etc.

Also try "ping" and "nslookup".

If no packets are returned by ping, and your Z can't find google, you ain't made it to the net for sure.

Oh, I know I'm connected. I'll be surfing the net just fine, then decide to wget some source or something, and it won't work.
QUOTE(Capn_Fish @ Sep 12 2007, 03:41 PM)
Oh, I know I'm connected. I'll be surfing the net just fine, then decide to wget some source or something, and it won't work.

proxy/ftp blocking issue? Obvious maybe, but..well... sometimes the obvious is worth mentioning
I don't think so. I can browse the sites just fiine, and DLing in the browser works OK, but wget/ipkg doesn't.
I would run strace every time I did a wget download that was likely to fail until I got the output from one of those time outs. The output can be huge (megs) but is usually worth it. Have you done that?

Oh, the default output sometimes doesn't reveal what I want to see, so I increase the character limit per line. Here's an example command with 100 characters, and output directed to my SD card (you can name the output file whatever you want):

strace -f -v -s 100 -o /mnt/card/wget.strace wget [any wget options go here] URL-OF-FILE-YOU-WANT-TO-FETCH &

I don't know why, but pinging the site before I wget from it seems to help, so I guess this issue is mostly solved.

Thanks for all the suggestions (I may still look into it)!
FWIW, it appears to be an issue with my DNS server. Switching to OpenDNS seems to fix the issue nicely.
you don't have http proxy set do you?

some ISPs do nasty things to people's DNS - NTL for example in the UK transparently hijack all DNS to their own resolvers - why, I don't know - but it really messes things up!

personally, I prefer to run my own caching resolver on my linux gateway - I don't like the idea of anyone being able to mangle DNS to favour anyone for whatever political correct purposes they purport to use - and opendns with their whitelisting/blacklisting strikes me as giving someone else control over what I do! I recall when verisign started hijacking NX results to favour advertisers which was pretty evil!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.