Help - Search - Members - Calendar
Full Version: Alternative Distros
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Asus Eee PC
cool.gif I very quickly installed the advanced desktop mode to my eeepc, using the advice on the forums and wiki.

It wasn't long before I invested in a 16GB SDHC card and dual booted eeeXubuntu. I was quite happy with that and had it working quite nicely.

However the originator of the eeexubuntu project has gone missing. Perhaps he ran away from all the demands for help from the dozier inhabitants of that forum! rolleyes.gif

So I'm just trying to put xubuntu on and trying to follow the suggestions on those forums and that wiki.

So what other distros are people using or experimenting with?

Any tips, suggestions are more than welcome. There are so many duplicate threads over at that it is quite hard to find the genuine article. wink.gif


I have a xubuntu dual boot working. After the xubuntu install I used the scripts from the ubuntu eee wiki and it seems to sort out the hardware issues, in particular the wifi drivers. The suggested webcam application seems a bit problematical. blink.gif
Actually I am looking forward to Debian/Eeepc:
Personally I prefer debian over eeexubunut because upstream work is very active and quick.
It seems ready to rock! But first i have to keep track of what are installed in my eeexubunutu setup and do backups before plunging into that.
QUOTE(ZDevil @ Mar 8 2008, 11:50 AM) *
Actually I am looking forward to Debian/Eeepc:
Personally I prefer debian over eeexubunut because upstream work is very active and quick.
It seems ready to rock! But first i have to keep track of what are installed in my eeexubunutu setup and do backups before plunging into that.

cool.gif just giving Debian a try biggrin.gif Might be able to relate the BigZ experience to this...But I suspect I'll settle for the Ubuntu experience in the end. wink.gif
I just have Ubuntu 7.10 on the SDHC with the scripts to get it more ready for the EEE ran (look in the eeeusercom wiki for the script set). Xandros is still on the SSD with Advanced desktop enabled, mplayer downgraded to have h.264 support and apt-pinning of repositories setup.
cool.gif I tried Debian and made a mess of it! I was trying to persuade it to live on my 16GB SD card and it wasn't as intuitive as the Ubuntu variants. There are all sorts of other possibilities. I have burnt a livecd of the distro that used to be known as geubuntu.It is Ubuntu using the Enlightenment window manager. It looks very pretty on my desktop machine. I might find time to try this out soon.

At the moment though I have installed Ubuntu using an external DVD drive. A s I said about eeexubuntu, I thought I'd better shift to a ubuntu variant that had a bit more Asus community support.

I used the scripts and tips from a wiki called Ubuntu-eee or something like that.

Here is the link: Ubuntu eee.

The script pack I took on trust: well almost completely. The script gives you a list of all the available options, if you don't specify any when you call it. wink.gif If you are brave you put all after the script. I specified the options individually with the exception of the X11 stuff. Everything works that needs to be fiddled for function keys and wireless. The tips for running the web camera in the eeexubuntu forum worked for me.

One problem: the overclocking by using a function key gave me a 'broken' display and a hang of the system. Maybe I need to use the X11 portion of the script to be able to use that? unsure.gif

I chose to install to the SDHC and used guided partitioning for the whole of it. This gave me a swap partition. I have seen comments that say that the SSD can cope happily with a swap partition and journalling systems without the 'traditional' wear problems. I've hedged my bets by installing to the SDHC. No problems so far.

As regards size of screen: I have put the Littlefox theme into Firefox and put 'show/hide' buttons on the panels. This helps a fair bit and the script mentioned above tweaks the fonts and desktop.

When I boot I get a traditional menu with options to check memory, run checks on the SSD and boot into Xandros from the SSD.

In Xandros, I have installed the advanced desktop and pinned the repositories in the hope that the extra ones won't bork the system. As a precaution I have made a restore usbstick from the ASUS dvd. It works!


Hmm. It looks like the Debian/Eee PC installer is getting smoother now. The installer will automatically install madwifi and ACPI packages also, which is nice.
I will give it a go right now after backing up my docs. My ultimate goal is to set up an identical environment (including desktop+WM) on both my Eee PC and my Z.
Will post the result later.
Just got Debian lenny/sid up and running. Installation went surprisingly smoothly! It took around 2 hours but most of the time was waiting for downloading and installing packages automatically. Things seem to work fine OOTB (after making a couple of modules following the installation steps). Wireless and X run and now it's almost ready to unify my eeepc/z experience ...
cool.gif Just in the process of putting Debian onto a spare SDHC. I have chosen the laptop option so I may need to go and make a pot of tea before the install stops. I'll report on my experiences later on. smile.gif

I hope I'm using the latest version of the Debian installer for the eeepc. Their instructions are still saying that I'll need to build the madwifi drivers and the other tweaks.

The idea of unifying the BigZ and Asus experience is quite attractive,: I suspect I'll probably settle on the hardy heron experience in a couple of weeks time though! biggrin.gif

I suppose really I'd be better putting these distros on bootable USB sticks and using ESC at boot time to use them. cool.gif

UPDATE: I'm trying to put the debian onto a 4GB usb stick and be able to boot from the ESC option. I suppose I need to look for an 'advanced' option in the installer.

**It might help that I now seem to have the most up-to-date version of the installer!!**
I've spent the past week setting up Debian + KDE on my eeepc and now it's working beautifully (apart from some suspend/hibernate problems - which I believe can be sorted since they were working ok when I did a test installation previously).

The impetus to install Debian was because of the recent availability in HK of those mini/nano usb-bluetooth dongles. I had been looking in vain for those in HK for ages and when I was over in the UK at Christmas I was tempted to buy one for around £18 but decided it was too expensive. But now within the last 2 weeks there are at least 3 different models available in HK, ranging in price from HK$45 to $130, so I bought one of each of the 2 cheaper ones.

So now I can take my eeepc out and get online anywhere via bluetooth dun and my phone. I never did get bluetooth working under Asus Xandros.
cool.gif I gave up on the Debian after the last two tries sank into the depths of my ignorance. rolleyes.gif I was trying to persuade the install to be isolated onto a bootable card. It failed miserably both time. sad.gif

biggrin.gif I think that it was down to my feeble attempts at trying to make a bootable install rather than proceed as normal! unsure.gif

Anyway, I'm in the process of trying to install a tweaked version of Hardy Heron from the ubuntu-eee site. Here is the link to the site: Ubuntu EEE Wiki

I can recommend the from PendriveLinux. Just remember to format your pendrive as FAT or FAT32. wink.gif

QUOTE(tux @ Apr 6 2008, 10:42 AM) *
cool.gif I gave up on the Debian after the last two tries sank into the depths of my ignorance. rolleyes.gif I was trying to persuade the install to be isolated onto a bootable card. It failed miserably both time. ... [SNIPPED] ... Ubuntu EEE Wiki

Why not just dump Xandros? Its repos are crippled and outdated.
QUOTE(ZDevil @ Apr 6 2008, 06:58 PM) *
Why not just dump Xandros? Its repos are crippled and outdated.

cool.gif I did but not out of policy. tongue.gif I wanted to dual boot because it simplifies running the 'real' OS from the SDHC card and because I would still have a reasonably capable system, if the 'grown-up' version got broken! biggrin.gif

I had, at the time, multiple failures at installing dual boot or running hardy from the SDHC card from the ESC boot menu. At the moment there is a very nasty bug preventing the dual-boot route. It is worth noting that the upgrade path from Gutsy to hardy falls over on the eeepc for lack of storage space. So that is why Xandros got dumped. laugh.gif YMMV

By the way Hardy works fine if you use the script or the python app from the wiki at Script and Python app to make Hardy hardware work on eeepc.

I used the script first and then I tried the python thing. Both basically do the same things and they don't conflict with each other. I'm looking through the scripts and python and they are looking quite straightforward. biggrin.gif

unsure.gif As you can see in my signature I used a manual partitioning set up and put a swap partition (512MB) and a /home partition on the SDHC card. Any suggestions for other partitions it would be safe to set up on the card? smile.gif

I just got one of those things ....
not sure if they are all the same but mine has:
900Mhz celeron M
512Mb ram
4Gb Solid State Didk
antherons WiFi
antherons LAN
intel ICH6M chipset
intel 915GM/GSM/910GML VGA and display controller
internal SD/MMC card reader (on usb bus ... read below for more details on this)

I think all this hardware is widely supported by any distribution currently (might need a little tweeging on the less user friendly ones) so I'll be trying slackware asap (a deley dew to my usb cdrom not working on my EeePC).

I opened up the door on the bottom and all I saw was the ram .... the SSD is not servicable from there (has anyone opened it up ?)

The SD slot seems to be on the usb bus in fact I see devices plugged there as usb-storage and somewhere in dmesg one can see :
scsi x:0:0:0: Direct Access USB2.0 CardReader ......
That's where you plug in the SD/MMC ;-)

The thing boots up using grub but the real menu.lst is not accessible once up because of unionfs hiding the real one.
If you want access to the real filesystems pm me about it ... there is a sysadmin way to do this while rebooting but potentially dangerous if you do not know what you're doing.

BTW: there is no need to go snooping around for a terminal utility ... xandros comes with bothe xterm and konsole.
Use the file manager to to execute them with admin privileges (find them in /usr/bin).
I've put a copy of konsole in my home dir to reach it quicker.

Can someone tell me howto put it in the favoutits menu ? (usefull till I get slackware installed)
cool.gif Try looking at this forum, Eeeuser forums and Wiki, there is a tremendous lot of hardware information about the different models and there is a section on installing Slax6 which is a mini version of Slackware, as I expect you know. smile.gif It shows how to install to an SDHC card and leave the SSD untouched. You boot into the SDHC card by tapping the ESC key while your eeepc is booting. You then select the SDHC card from the menu. wink.gif Lots of fun! biggrin.gif

Cheers biggrin.gif
Hum did not have a look at the wiki ....
but I've booted the slack 12 install CD (with usb CD from work) and I can see the SD card.

I'm currently installing slackware 12 in expert mode only choosing stuff that I actually use and I'm installing to SD ... I plan tu use xandros grub to boot my slackware on SD ... well at least I'm gonna try.

If I fail I'll look at the wiki ... well I'll look anyway to maybe see if other tweeks work better then what I'm dooing ..... and maybe find out howto ad konsole to favourites menu on xandros (which is going to be left untouched on the SSD.
Ok I installed slackware 12 on SD and I can load the kernel from lilo installed on Boot Record of the SD (press esc at boot and select the SD device to boot from .... that loads lilo from the boot record on the SD) ... but then I get kernel panic probabbly because the usb-storage driver is module and root is on usb-storage.

There is also another problem: it takes about 30 seconds after boot for the SD to be seen my kernel ... and this could be too long even if I compile usb-storage into kernel.

Somehow all these problems have been solved on slax6 ... but I still prefer making my own custom install.
Also it's not so clear exactly how these problems were solved.
I will try making a bootable usb-stick and see if I can boot up from there.
I was having some trouble with slackware 12's mkinitrd .... in the meantime slackware 12.1 was released so I decided to start over again.

So I now have:
xandros on SSD untouched (eccept grub config to also boot slackware on SD)
slackware 12.1 installed on a 4 Gb SD and lilo also installed on Boot Record of SD (but very slow to load kernel and initrd .... this is why I'm using grub from xandros).

To get slackware 12.1 to boot up correctly I had to make a little twinging:
build a custom kernel with usb-storage compiled in,
build an initrd anyway because the SD takes some time to settle so that kernel can see it (and hence a normal boot ended up in a kernel panic: cannot mount root),
made some adjustments to initrd to do fdisk -l and sleep for 10 seconds before attempting to mount root file system (found this helpful in order to boot successfully).

Hope this may be usefull to other people.
For those who like Slackwre there ale other alternatives to slackx (which I found not to have the correct driver for the eeepc atheros card).

Apart from doing things from scratch from current these guys have gotten things working correctly out of the box:

In fact thanks to these dudes i revisited the madwifi-nr-r3366+ar5007 driver which dew to pci express hotplug I was unable to get working the first time I attempted.
Just got an E, its running Ubuntu 8.04 Hardy Now, Custom Kernel.

SD has everything but the /usr directory on it, including a swap partition. Soon to undergo physical mods.
Oh yeah, if anyone wants a works straight out of the box distro for the EEE, Mandriva (spring 2008 release) is the way to go. I installed it to an 8GB SDHC in my EEE 900 a few days ago to try out some things (mainly the updated video drivers compared to Xandros), and the hot keys, wifi and most other things worked. No scripts to run, just works. I've heard some things like the mic don't work, but at least that's not a critical thing. All other distros I've tried don't have WiFi out of the box, and need to plug it into Ethernet to run a script to get it working. dry.gif
Found Ubuntu to be pretty easy to set up with a script I found at eeepcusers site. Was painless for the most part. Now to get a gprs modem for it smile.gif
lol - switched to pclinuxos (the one fluxflux modified). Its very stable so far, has its issues but all is good. On 512 megs it leaves over half untouched most of the time. All keys work thus far, battery life is good and media playback is solid. Leaves about 400 or so megs left on a 2gig ssd. Mounted the /var, /tmp and /home on a sd card.

Will post a pic soon.
I got a 4G EeePC, plain vanilla Xandros distribution. After playing with it a bit, found that it is an OK distro, but I love Ubuntu too much. So I installed Ubuntu-eee (8.04), with the Riceeey fixes. Works like a charm! tongue.gif

Zaurus SL-C1000, Cacko 1.23
EeePC 4G, Ubuntu-eee 8.04
cool.gif Just finished installing Ubuntu 8.10 aka Intrepid Ibex as dual boot with the original xandros. The xandros install is on the ssd and the Intrepid is on the 16 GB SDHC card.

Seems to need less 'tweaking' than previous generations of Ubuntu.

After trying eeeBuntu NBR, I am right now using fluxflux eee, which is a modified version of PcOSLinux or so, it is gtk based, fast, nice, everything works besides my bluetooth dongle.....

I don´t really need more.

Greetings from Austria.
I have a 2G surf. I left the Xandros on the SSD because I want all the hardware to work and it hasn't given me any major grief. I now have both ubuntu and puppeee installed on removable media and I am playing with them. I recommend unetbootin to create bootable usb sticks or sd cards. Works great on a standard ubuntu desktop.
A recommendation when installing another distro to an SDHC card; don't use the internal SSD for /home. If you fill up /home Xandros can't even boot and KDE can't load in other distros (IceWM did load in Mandriva, but it complained about dcopserver interprocess communications). I accidentally filled up /home (16GB SSD) by copying files from an external disc that I meant to copy to SDHC card, which had enough room, to the internal SSD, which didn't.

If I install another distro, I'll likely just have /home be on the card, and link to the internal SSD from there.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2020 Invision Power Services, Inc.