Help - Search - Members - Calendar
Full Version: Gemini multiboot - Boot problems
OESF Portables Forum > Model Specific Forums > Gemini PDA > Gemini PDA - Android
Will Atl
I recently got my Gemini 4G and flashed multiboot Android 41GB and Linux 15GB (Please see Multiboot file attached).

Got Debian and Linux running ok but I experienced a few freezes and crashes on Debian as mentioned elsewhere.
After a few times it did not boot anymore into anything.
As I had very little data, I just re-flashed the Gemini again and it started to work fine.
I used it in Linux and Android with no problems. Rebooted it into Linux and Android several times to test it with no issues for a few days.

After that I started downloading apps, data and configuring it.

All of a sudden and with no apparent cause, it did not boot into Android any longer. It continued to be able to boot perfectly well into Linux and into Recovery mode.
But when I tried to boot into Android it just stayed stuck in the Planet image forever. (Did not get to the part that says “Powered by Android”, nor the spinning Planets).

In Recovery Mode I did a "Root integrity check” and everything was fine. Also through recovery Mode rebooted the system, and rebooted into boot loader with the same results.
(I could always boot into Linux perfectly fine but not into Android)

While trying to fix it, I tried using the Flash Tool set to “Download Only” instead of “Firmware Upgrade”, but nevertheless it erased everything (I had hoped it would preserve the data).

I cannot point to any evident cause to generate this. The only thing I can mention is that right before it started to happen I tried to copy files on Linux from a MicroSD card I had used with another Android phone before (using a USBC Adapter that worked fine with Note 9 and Mac - The card is separate from the one on the Gemini). Linux said it could not read it, so that is why I decided to boot into Android to have it reformat the card to avoid issues. It never rebooted into Android.
(This seems completely unrelated though)

I fear it might continue to happen again and again after investing a lot of time setting everything up just to erase it all again.

I just emailed Planet Computers support but in the meantime is this a known issue ?
Seems something to do with the boot loader. I am sure the underlying data was fine. Had anyone else experienced this?

If I only used Android would this potentially happen too ? Or that is much more reliable ?
I've never heard of delayed problems like you describe, so I'd guess they're not too common. However, I don't know how many Gemini users frequently boot between different OSes.

(I have only rooted Android installed on mine, and I don't need to shut it down except for upgrades, so I've only booted it a handful of times.)

Of course, even one person experiencing such problems is one too many. And it's certainly worth contacting Planet, so they're aware. But if you were considering sticking to just one OS, that might work better for you.
Will Atl
Yes, I could use just Android - I use it now as my primary OS on my Note 9, but part of the reason of getting the Gemini was to tinker on Linux and code on the go with that awesome keyboard.

ie: running same Python/Ruby scripts and C/Julia programs on Android/Termux and also on Linux Debian so see which was faster / most efficient.
So necessarily would boot into both a few times.(*)

I enjoy the power of having a full fledged linux OS on a tiny computer, even if it was just to use a full fledged browser such as Chrome for example.

I can use only Android just fine but would not be that much fun. I would prefer to be able to tinker and switch when needed.

(*) On a side note: Interestingly, with a prime number script I found python performance between the 2 (Android / Debian) the same, but Ruby was much faster on Linux Debian than Android. Still pending to run comparatively same benchmark in C, Java, C++, Kotlin, BASIC!, and Julia. (As I also run the same in all my devices slowly building a small database of comparative benchmark speeds between devices and languages).
Adam Boardman
I don't really understand what happened to your device, I frequently boot between OS's and variants of the same OS (stretch/buster), never any unexpected problems. I can point you to some info that might let you figure it out if it ever occurs again, and also maybe short circuit some of the faff of a full reinstall.

The four different key combinations just launch a different kernel from a different boot partition [boot, recover, boot2, boot3], technically you can flash (with dd in linux or the flash tool) any kernel for any os to any of these, the recovery one doesn't turn on some hardware features so its best not to re-use for a proper os.

If android is not booting then you can use the flash tool with the tick boxes to only re-flash the android parts, it is known that mounting the android partitions rw from other OS's is enough to cause android to stick its middle finger up at you* so if you want to nose about you need to just mount ro.

The original tri (and/deb/sfos) boot made use of stowaways where debian and sailfish used the same partition with debian on the root and sailfish in .stowaway/sailfish folder that was then mounted as the root point by the modified sailfish ramdisk. From the sounds of it the newer sailfish is moving to LVM. I've had no reports of anyone trying the new tri boot so I don't know what it does just now but LVM does sound like it might be a nice solution as it would avoid the OS's interfering with each others files but still allow say 50/50 split until the user decides which is more important and then zero flash station (zero data loss) resize/removal of the lesser/unused one once the more used one runs out of space. Basically its more likely that deb/sfos would mess each other up than that they'd mess up android. I also still like the stowaways form as it lets you completely avoid any need to allocate space between os's.

* - I don't recall what form that took, it could have been a reboot, not something I ever tried myself.
Will Atl
it is known that mounting the android partitions rw from other OS's is enough to cause android to stick its middle finger up at you* so if you want to nose about you need to just mount ro.

Thank you Adam. I have no clue either. First time around I was for sure NOT trying to mount any Android partition, the second time I was actually trying to copy files from a USB drive (but Linux could not read it), so perhaps moments before I tried to mount the android partition by mistake...perhaps.

As you said "LVM does sound like it might be a nice solution". I need to investigate that further. Any pointers ?

Side note:
Now, after re-flashing both OSs work ok, but on Android copying files between the SDCard and Internal Memory does sometimes give me errors or it just hangs and I need to cancel and try 3 or 4 times until successful (small text script files). Specially if I use Solid Explorer. The included File Manager seems more reliable. On Linux things are MUCH more reliable and error free.

Is that known ? or something might not be quite right with the formatting of Android partition on my Gemini ?
QUOTE(Will Atl @ Jan 26 2019, 11:28 PM) *
I recently got my Gemini 4G and flashed multiboot Android 41GB and Linux 15GB (Please see Multiboot file attached).


Cannot see the multiboot file.

What is your boot order? boot? boot2? boot3?

I can confirm boot problems like this if you have not put android to the 1st boot (boot) and if you are using magisk to root the system. The changes to the boot.img done by magisk are always done to the 1st boot partition (boot). If you have selected linux to the 1st boot partition, magisk kills the it. Update for android are a problem too if it is not on 1st boot.

My personal advise: Always select android as 1st boot option if you like to use android on gemini pda.
Will Atl
Cannot see the multiboot file.

What is your boot order? boot? boot2? boot3?

Hi, Thanks for the help.

Here uploaded the file.
Boot order is Android, Recovery, Debian Linux.

After flashing last time (always with the same scatter file and firmware), things operate normally except for copying files with Solid Explorer as mentioned.

Rebooted several times into Android and Debian and had no issues.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2020 Invision Power Services, Inc.