Help - Search - Members - Calendar
Full Version: A failure to root Android
OESF Portables Forum > Model Specific Forums > Gemini PDA > Gemini PDA - Android
rodgos
As my earlier post "Checking foe a successful root" does not seem to have found a definite answer, I'm assuming that the flashing has not resulted in a rooted Android.
Oddly my very first attempt at a rooted Android did in fact work. I'd flashed it to have a rooted Android and Sailfish OS. It did work, but I've no idea how or why. I didn't like Sailfish over much, and decided to replace it with the Debian alternative. and re-flashed the thing, and replaced Sailfish with Debian. However, to my mind the full monitor screen layout did not suit the small display in a workable fashion. I also found out that the option to invoke root access was absent. The machine reported that there was no executable command 'su' and listing was not available for anything at root level.
Since then I've re-flashed the thing more than a dozen times in every combination possible, but every time I get the same answer. The final time, I opted for a double boot of Android. Boot one for normal and boot2 for rooted. It did work, I could boot into either, but neither of them appears to be a rooted Android.
Since the whole operation is carried out on a "monkey see, monkey do" fashion, there is little one can infer to explain it. It does seem a little odd that both the normal and the rooted option use the same zipped up set of image files, the loaded image for both should have the same complement of files, including the su executable. If anyone knows how it all works, I'd be most interested. The "monkey see, monkey do" principle infuriated me for the whole of my time in IT admin, since for what seemed about 80% of the time, the given instructions failed to perform, leaving you in a sort of no-mans land, with no idea of where to go from there. Whenever we finally got a piece of kit working, we would vow never to touch it again, since it was seldom that we knew the how and why of our final success.
Eldkatten
Hello,

QUOTE(rodgos @ Mar 31 2019, 07:27 AM) *
(...) The "monkey see, monkey do" principle infuriated me for the whole of my time in IT admin, since for what seemed about 80% of the time, the given instructions failed to perform, leaving you in a sort of no-mans land, with no idea of where to go from there. Whenever we finally got a piece of kit working, we would vow never to touch it again, since it was seldom that we knew the how and why of our final success.

Oh, how well I understand you! tongue.gif I'm interested in answers to your question as well, since I certainly will reflash the device again in the future (shouldn't there be a version 8 android image by now?). Unfortunately I can't help you with the original issue. I didn't answer in your earlier post, because, when I look for a solution to a current problem, I do hate all those "oh, strange, it works for me"-posts.

Good luck and kind regards
gidds
Strange, I had no such trouble...

If I recall, the important points were: download the rooted Android firmware from Planet; flash it; download and install Magisk Manager (not just Magisk); install Termux; install Termux's 'tsu' package; run 'tsu'. (Termux doesn't have an 'su' command; 'tsu' is a rough equivalent.) If you've done all those, I don't know why it would fail.
rodgos
Ah, Gidds. Do I take it from your post that simply installing the rooted Android does not indicate that the user is automatically able to obtain superuser rights? And that further action in respect of Magisk is required? My distro of choice, Mageia, what I would term as a 'proper' Linux, from the very start assumes that superuser function is an essential part of the system.
jakfish
http://support.planetcom.co.uk/index.php/L..._Flashing_Guide

Under the "Rooted Android notes," you'll see:

"If you choose to flash the rooted Android firmware, remember that you will have to complete the process by installing Magisk Manager using the following steps."

Gidds brings up a key issue: it's Magisk Manager, not Magisk

Jake
rodgos
Thanks, Jakfish. It would appear to be a RTFM matter, I'll get onto it.
Since my last post, the situation has become a bit clearer. As my first post, I've installed Android twice, as a normal version and a rooted version, but both appear to be the same. Today, I've been installing, for the n'th, time the applications I want, and arranging the launch icons as I like them. Opening each one to check and set the app requirements. One of the apps was the Barclays mobile banking app. As it happened, I was, in fact in the rooted version, and the app indicated that it could not be setup on a rooted machine. This is the very first, and only formal indication that the machine was, in fact rooted. I re-booted into normal mode, and lo and behold, I was able to setup the banking app with no problems.
I shall now go and have a look at the Magisk Manager installation and setup.
rodgos
Lol
The particular installation guide I was working from was "Android Flashing Guide" rather than "Linux Flashing Guide", and although the two are virtually identical, the "Android Flashing Guide" DOES NOT have the "Rooted Android Notes". Which may account for why my first attempt actually succeeded in getting root access, but being run in a semi panic, I'd failed to remember exactly what I'd done. I would have done the installation on my Mageia machine, but the version I was using threw up a number of errors, and I finally dragged out an old laptop with Windows.
rodgos
Following the Magiskmanager instructions have shaken out a few memories of the first install, and I've come up against the problem I had then. To whit, having installed and opened Magiskmanager, as in the instructions, the display I get is the "Magisk is not installed". The instructions indicate that this is what you will see if I was running a non-rooted version. However, my Barclays Mobile app litmus test tells me that I am indeed running a rooted Android. My jogged memory told me that this had happened last time, and as in all "monkey see, monkey do" installations, it leaves you totally lost. Last time as I now recall, I simply gave it up and went off to do something less infuriating. Quite a long time later, when I returned the magic popup, "Requires additional setup" had appeared out of the blue and totally unprompted. Answering 'yes' to this, and all was well, and the "Magisk is up to date" message and tick had replaced the previous display.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.