Help - Search - Members - Calendar
Full Version: AirMail send fails
OESF Portables Forum > Model Specific Forums > Gemini PDA > Gemini PDA - Android
Wille
Hi,
I have used AirMail successfully until now. I have couple of Google account and some others also.
Sending emails from google account fails every now and then, and there's no way to get message send but needs to be deleted.

Sending from another account works fine, so it seems to be related to google. But is there any log files to check what is going on?

BR,
Wille
Daniel W
This isn't my area of expertise, though since there has been zero replies in three two three (one browser says August 9, another August 10 - probably something with time zones) days, here goes...

When in Airmail, either press Ctrl+M or tap the little envelope icon in the top left corner, to open the menu. Select either "Global settings" or "Settings" (because why should the menu be consistent between views...) and scroll down to "Debugging", which has a toggle for "Enable dubug logging". Unfortunately I don't know where the log ends up. I have, thus far, not found it. I think /System/Data/Data/com.gemini.airmail would seem likely. It is, however, not accessible without root, so I can't check. Perhaps some more GNU/Linux/Unix savvy member can add some details here?

When sending regular e-mail, one would typically use the SMTP server of the current internet provider. Quite often an ISP will only allow use of their own SMTP server, and may even block attempts to reach somebody else's, perhaps in an attempt to better control spam. This causes me some grief, as, when I'm connected to WiFi at home, the SMTP that works is different from when I'm on mobile data, but I can only configure one SMTP server per email account. Personally I've set it to the SMTP server of my mobile data provider, and will briefly turn off WiFi on my Gemini before sending e-mail, thus forcing mobile data to be used. Unless I knew what was going on, it would seem to me as if sending email would just sometimes fail (which is when I'm on WiFi). Could something similar be happening to you?

When a message fails to send, it ends up in the drafts folder of whatever account it was (attempted to be) sent from. Usually, I can open the message from there, and try to send it again, once I'm om the "correct" network.

Since I had to look more than twice to find the setting for outgoing server; enter into, say, the inbox of the account of interest, press Ctrl+M and select "Account settings". Note: even though "Account settings" shows up on the menu, when opened from the "Unified inbox", nothing will happen if you select it, probably since Airmail can't figure out which account you are trying to configure. Once the account settings are opened, scroll down to "Sending mail". The very last item, before the next section (which is "Folders"), is "Outgoing server". It's in a completely logical place, but I still found it hard to locate for some reason. In there, you can check the outgoing settings for your gmail account. Perhaps you can compare them to an account from which sending mail works and see if something is set up differently.

I have no idea if any of this is helpful at all, but it's the best I can do. If nothing else, keeping the thread a bit active might increase the chance that someone else, who might know more, might read and respond.
gymbo
QUOTE(Daniel W @ Aug 12 2019, 11:28 PM) *
This isn't my area of expertise, though since there has been zero replies in three two three (one browser says August 9, another August 10 - probably something with time zones) days, here goes...

When in Airmail, either press Ctrl+M or tap the little envelope icon in the top left corner, to open the menu. Select either "Global settings" or "Settings" (because why should the menu be consistent between views...) and scroll down to "Debugging", which has a toggle for "Enable dubug logging". Unfortunately I don't know where the log ends up. I have, thus far, not found it. I think /System/Data/Data/com.gemini.airmail would seem likely. It is, however, not accessible without root, so I can't check. Perhaps some more GNU/Linux/Unix savvy member can add some details here?

When sending regular e-mail, one would typically use the SMTP server of the current internet provider. Quite often an ISP will only allow use of their own SMTP server, and may even block attempts to reach somebody else's, perhaps in an attempt to better control spam. This causes me some grief, as, when I'm connected to WiFi at home, the SMTP that works is different from when I'm on mobile data, but I can only configure one SMTP server per email account. Personally I've set it to the SMTP server of my mobile data provider, and will briefly turn off WiFi on my Gemini before sending e-mail, thus forcing mobile data to be used. Unless I knew what was going on, it would seem to me as if sending email would just sometimes fail (which is when I'm on WiFi). Could something similar be happening to you?

When a message fails to send, it ends up in the drafts folder of whatever account it was (attempted to be) sent from. Usually, I can open the message from there, and try to send it again, once I'm om the "correct" network.

Since I had to look more than twice to find the setting for outgoing server; enter into, say, the inbox of the account of interest, press Ctrl+M and select "Account settings". Note: even though "Account settings" shows up on the menu, when opened from the "Unified inbox", nothing will happen if you select it, probably since Airmail can't figure out which account you are trying to configure. Once the account settings are opened, scroll down to "Sending mail". The very last item, before the next section (which is "Folders"), is "Outgoing server". It's in a completely logical place, but I still found it hard to locate for some reason. In there, you can check the outgoing settings for your gmail account. Perhaps you can compare them to an account from which sending mail works and see if something is set up differently.

I have no idea if any of this is helpful at all, but it's the best I can do. If nothing else, keeping the thread a bit active might increase the chance that someone else, who might know more, might read and respond.

I have Airmail installed, but haven't set it up (I briefly set up K9-mail, and do believe I got it sending as a test as well), I use ProfiMail (which, although it is now freeware, is sadly not maintained anymore, but it has a widget with a display of "recent" mails, and a three-pane-view in the main program, and that are my reasons for staying with it for now). But I have set it up with my mail-providers SMTP-servers for outgoing mail. And it works both on mobile and wifi. But I have it set up with the ports my e-mail-provider uses/requires, and it requires password on the sending as well...

Don't know if this was helpful at all, but I do believe it should be possible to send with any SMTP with correct ports and username/password. Unless your mobile provider for some reason blocks those ports... (I do successfully send mail with this setup when roaming as well, so might be the ports my mail-provider is using are "open", but I do believe it should be possible to set up on most mail-accounts. I have a G-mail-account, but I really don't use it much, so haven't set it up in my mail-program, so I don't know what ports and SMTP's it should use...)
Wille
This was solved by *not* using google smtp. But for the clarity, it worked long time (year or so), and when the problem started it happened in both wifi and mobile connections.
I noticed logging options but never find log files.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.