Help - Search - Members - Calendar
Full Version: Battery usage on Oreo
OESF Portables Forum > Model Specific Forums > Gemini PDA > Gemini PDA - General Discussion
smapmap
Does anyone else have an issue with battery life on their Gemini on Oreo 8.1?

Things I've noticed

- battery usage is worse than with Nougat - can not get more than a few hrs out of it
- occasionally turning itself off even when the battery has charge
- sudden battery drain - like 50% disappears in 30 mins
- misreporting battery charge - Android thinks its got 0% left and turns off, when I plug the charger in with the device off it reports 28% - its as though the OS and the battery are out of sync

It's really frustrating. It's liek the calibration and optimisation on 8 is totally out of whack...? sad.gif

Daniel W
QUOTE(smapmap @ Sep 1 2019, 02:03 PM) *
Does anyone else have an issue with battery life on their Gemini on Oreo 8.1?

Things I've noticed

- battery usage is worse than with Nougat - can not get more than a few hrs out of it
- occasionally turning itself off even when the battery has charge
- sudden battery drain - like 50% disappears in 30 mins
- misreporting battery charge - Android thinks its got 0% left and turns off, when I plug the charger in with the device off it reports 28% - its as though the OS and the battery are out of sync

It's really frustrating. It's like the calibration and optimization on 8 is totally out of whack...? sad.gif

While sharing what I've experienced may not solve your issue, it might be useful to know that I haven't had any of the above issues. If my battery drain went up with Oreo, it wasn't enough for me to notice. If what you describe would be common, we'd probably have heard a lot more about it here. For reference, after getting Oreo, I did at one time charge my Gemini to 100% and kept it in flight mode (with "Intelligent power saving standby" on but "Battery saver" off), only using it for brief notes. I used 5-6% battery per day, until, after 14 days and 2.7h of screen-on.time, I had 25% battery left, so, apparently, Oreo on a Gemini CAN use very little power.

Regarding your issue, a Gemini actually consuming half a normal battery charge in half an hour, would get quite hot. If yours does heat up during the sudden drains, I'd suspect faulty software, and would recommend running a reputable malware scanner just in case (I got a malware-laden update via Google Play once, so, while unlikely, it can happen). If it doesn't heat up, I'd suspect the battery and/or the battery meter (though you could still also have a software problem).

There seems to be a few more reports in this post regarding Geminis suddenly turning off and/or reporting weird battery levels, so it seems you're not alone in this, though their problems does not seems to be limited to Oreo. One user had success with deliberately running the battery very low, turning off the Gemini off and recharged it fully. This may of course be hard to do, if Android thinks the battery is empty and keeps shutting down too soon. Anyway, while deeply discharging Li-ion batteries often, may be detrimental to their longevity, doing it once if the battery meter seems inaccurate, may help recalibrate the charge controller.

Other than that, I can only really suggest trying a factory reset, and if that doesn't help, sending basically your post above to Planet Computers support at hello@planetcom.co.uk and be prepared to send your device for service.
smapmap
QUOTE(Daniel W @ Sep 1 2019, 10:50 PM) *
QUOTE(smapmap @ Sep 1 2019, 02:03 PM) *
Does anyone else have an issue with battery life on their Gemini on Oreo 8.1?

Things I've noticed

- battery usage is worse than with Nougat - can not get more than a few hrs out of it
- occasionally turning itself off even when the battery has charge
- sudden battery drain - like 50% disappears in 30 mins
- misreporting battery charge - Android thinks its got 0% left and turns off, when I plug the charger in with the device off it reports 28% - its as though the OS and the battery are out of sync

It's really frustrating. It's like the calibration and optimization on 8 is totally out of whack...? sad.gif

While sharing what I've experienced may not solve your issue, it might be useful to know that I haven't had any of the above issues. If my battery drain went up with Oreo, it wasn't enough for me to notice. If what you describe would be common, we'd probably have heard a lot more about it here. For reference, after getting Oreo, I did at one time charge my Gemini to 100% and kept it in flight mode (with "Intelligent power saving standby" on but "Battery saver" off), only using it for brief notes. I used 5-6% battery per day, until, after 14 days and 2.7h of screen-on.time, I had 25% battery left, so, apparently, Oreo on a Gemini CAN use very little power.

Regarding your issue, a Gemini actually consuming half a normal battery charge in half an hour, would get quite hot. If yours does heat up during the sudden drains, I'd suspect faulty software, and would recommend running a reputable malware scanner just in case (I got a malware-laden update via Google Play once, so, while unlikely, it can happen). If it doesn't heat up, I'd suspect the battery and/or the battery meter (though you could still also have a software problem).

Thanks Daniel - I'm going to see if I can do a full battery discharge/recharge/recalibration - hopefully this will sort it.
There seems to be a few more reports in this post regarding Geminis suddenly turning off and/or reporting weird battery levels, so it seems you're not alone in this, though their problems does not seems to be limited to Oreo. One user had success with deliberately running the battery very low, turning off the Gemini off and recharged it fully. This may of course be hand to do, if Android thinks the battery is empty and keeps shutting down too soon. Anyway, while deeply discharging Li-ion batteries often, may be detrimental to their longevity, doing it once if the battery meter seems inaccurate, may help recalibrate the charge controller.

Other than that, I can only really suggest trying a factory reset, and if that doesn't help, sending basically your post above to Planet Computers support at hello@planetcom.co.uk and be prepared to send your device for service.

Dixit
I have the same issues as you have, but I am still wondering if that is Oreo or actually the physical state and age of the battery. My Gemini dates from June 2018.
smapmap
QUOTE(Dixit @ Sep 3 2019, 07:40 PM) *
I have the same issues as you have, but I am still wondering if that is Oreo or actually the physical state and age of the battery. My Gemini dates from June 2018.


Mine is a new x27 a replacement for one of the early x25 units - same on both
spook
Over on the Gemini users facebook page a LOT of people have commented that the battery is much worse with 8.1. And many of these mention that it was pretty much immediately after upgrading. Some have even done a full factory reset and noted that they still have the drain before even installing apps. To me this indicates a couple of things:

1. It is not due to the age of the battery - or at least not solely this.
2. It seems to be widespread enough that it is related to the update, not user configs / apps installed etc.

While some have said that they don't have any noticeable change since the upgrade, to me this doesn't prove that there is not a problem with Oreo. It just shows that their particular unit / configuration isn't affected by whatever bug is causing this. There are so many variables that could be involved that it is - in my opinion - virtually impossible for us to say what might be causing it.

For example, maybe the Oreo update only causes a drain on certain frequency bands (maybe certain bands stop the unit from going into deep sleep mode), maybe a certain setting is stopping deep sleep (like having a timeout on the screen). These are obviously just wild speculations and almost definitely not the cause, but I'm trying to demonstrate that - despite many users not experiencing it - this battery drain may very likely not just be due to software installed or user settings, but actually a bug with the update.

I've certainly seen enough posts about it to make be believe there is an issue and to postpone the upgrade to 8.1 on my device.
Kero
wifi-only model, and I have the feeling of a faster draining battery too.

Bad wifi is really sucking power when the unit is not doing anything. up to 20% overnight.

Switching off wifi and allowing the screen to go dark before clsing, however, makes my unit survive the night with a reasonale 1-2% or so.

My hyopthesis: fancy power saving mechanisms in Oreo that require support from the kernel.
Our kernel is to old to provide those hooks/api, or perhaps the hooks/api are badly implemented.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.